summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-03-23 21:15:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-03-23 21:15:50 -0500
commit1ab18c9d10f4f4e2df6ec801414befb1200e9985 (patch)
tree09d142318e24835379d79fe0602272691446f418 /www-apps/novnc/novnc-1.1.0.ebuild
parentsys-cluster/swift: clarify the kernel check (diff)
downloadgentoo-1ab18c9d10f4f4e2df6ec801414befb1200e9985.tar.gz
gentoo-1ab18c9d10f4f4e2df6ec801414befb1200e9985.tar.bz2
gentoo-1ab18c9d10f4f4e2df6ec801414befb1200e9985.zip
www-apps/novnc: bump to 1.1.0
Closes: https://bugs.gentoo.org/714116 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps/novnc/novnc-1.1.0.ebuild')
-rw-r--r--www-apps/novnc/novnc-1.1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/novnc/novnc-1.1.0.ebuild b/www-apps/novnc/novnc-1.1.0.ebuild
new file mode 100644
index 000000000000..130e5d594698
--- /dev/null
+++ b/www-apps/novnc/novnc-1.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
+HOMEPAGE="https://kanaka.github.com/noVNC/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
+else
+ SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/websockify[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+python_compile() {
+ :
+}
+
+src_install() {
+ exeinto /usr/share/novnc/utils
+ for f in utils/*; do
+ [[ ! f = utils/README.md ]] && doexe $f
+ done
+
+ dodoc README.md LICENSE.txt
+
+ insinto /usr/share/novnc
+ doins -r vnc.html vnc_lite.html app/ core/ vendor/
+ dosym vnc_lite.html /usr/share/novnc/vnc_auto.html # for compat
+}