summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-07-15 21:50:55 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-07-15 21:51:14 -0500
commit6194e7533aed11c5597ed429134d826bf60fb267 (patch)
tree721cea8efeb5bd0b5c5fa590650860aa452d229e /www-apps/novnc
parentdev-python/pillow: amd64 stable wrt bug #660548 (diff)
downloadgentoo-6194e7533aed11c5597ed429134d826bf60fb267.tar.gz
gentoo-6194e7533aed11c5597ed429134d826bf60fb267.tar.bz2
gentoo-6194e7533aed11c5597ed429134d826bf60fb267.zip
www-apps/novnc: 1.0.0 bup
Closes: https://bugs.gentoo.org/661130 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-apps/novnc')
-rw-r--r--www-apps/novnc/Manifest1
-rw-r--r--www-apps/novnc/novnc-1.0.0.ebuild47
-rw-r--r--www-apps/novnc/novnc-9999.ebuild4
3 files changed, 50 insertions, 2 deletions
diff --git a/www-apps/novnc/Manifest b/www-apps/novnc/Manifest
index ad2e2ecddab4..a72a4ad314ee 100644
--- a/www-apps/novnc/Manifest
+++ b/www-apps/novnc/Manifest
@@ -1 +1,2 @@
DIST novnc-0.6.2.tar.gz 600675 BLAKE2B f9779a9f03ba653f77090639112cd0c967ff5925d2f9897da6508fd077fb79a2f543467e32210572935a642e06fbbcac4a44c34b4342474f54ef7ec7a9bdbf4f SHA512 245d205f8935c82722a55d6cfcd2cea1825176c0cd695fd0eec34aa19cdc3b766fed62e741ff41b0a8c4a3b3cbabc5a39dfa6ad8ffa6169f5b88420a4a845a7c
+DIST novnc-1.0.0.tar.gz 1551574 BLAKE2B 58bd63eb0480b3f20ed16907725e0abcf8c699671614dc195f46a363d6ab9cdb5b0b033ba0ba16bbe39b16437fb94f64a741acd69d1c3c3957a0e60353d78a89 SHA512 97a86be5f10f382e2ed641360f5f6c3b22998f68f980c78138aca900ef6a011c1f6aa9cbdd8cd07afd4884e8c65af30d65487e87bb34e524c10f16cf4cd116a3
diff --git a/www-apps/novnc/novnc-1.0.0.ebuild b/www-apps/novnc/novnc-1.0.0.ebuild
new file mode 100644
index 000000000000..8ef65ad0e359
--- /dev/null
+++ b/www-apps/novnc/novnc-1.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
+HOMEPAGE="https://kanaka.github.com/noVNC/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
+else
+ SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/noVNC-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/websockify[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+python_compile() {
+ echo
+}
+
+src_install() {
+ exeinto /usr/share/novnc/utils
+ for f in utils/*; do
+ [[ ! f = utils/README.md ]] && doexe $f
+ done
+
+ dodoc README.md LICENSE.txt
+
+ insinto /usr/share/novnc
+ doins -r vnc.html vnc_lite.html app/ core/ vendor/
+ dosym /usr/share/novnc/vnc_lite.html /usr/share/novnc/vnc_auto.html # for compat
+}
diff --git a/www-apps/novnc/novnc-9999.ebuild b/www-apps/novnc/novnc-9999.ebuild
index fb8b22ba491e..8ef65ad0e359 100644
--- a/www-apps/novnc/novnc-9999.ebuild
+++ b/www-apps/novnc/novnc-9999.ebuild
@@ -42,6 +42,6 @@ src_install() {
dodoc README.md LICENSE.txt
insinto /usr/share/novnc
- doins -r *.html include/ images/
- dosym images/favicon.ico /usr/share/novnc/favicon.ico
+ doins -r vnc.html vnc_lite.html app/ core/ vendor/
+ dosym /usr/share/novnc/vnc_lite.html /usr/share/novnc/vnc_auto.html # for compat
}