summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-07-20 14:09:04 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2016-07-20 14:09:04 +0200
commit25e16955b94745dc24132cb567a6bd4cd65c1752 (patch)
tree5db001d199403716ffe6c26c37a5214a2950f852 /www-apps/owncloud/owncloud-8.1.9.ebuild
parentgnustep-apps/gorm: version bump (diff)
downloadgentoo-25e16955b94745dc24132cb567a6bd4cd65c1752.tar.gz
gentoo-25e16955b94745dc24132cb567a6bd4cd65c1752.tar.bz2
gentoo-25e16955b94745dc24132cb567a6bd4cd65c1752.zip
www-apps/owncloud: version bumps, including security fix
Package-Manager: portage-2.3.0
Diffstat (limited to 'www-apps/owncloud/owncloud-8.1.9.ebuild')
-rw-r--r--www-apps/owncloud/owncloud-8.1.9.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/www-apps/owncloud/owncloud-8.1.9.ebuild b/www-apps/owncloud/owncloud-8.1.9.ebuild
new file mode 100644
index 000000000000..98c81ffae5b2
--- /dev/null
+++ b/www-apps/owncloud/owncloud-8.1.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils webapp
+
+DESCRIPTION="Web-based storage application where all your data is under your own control"
+HOMEPAGE="http://owncloud.org"
+SRC_URI="http://download.owncloud.org/community/${P}.tar.bz2 -> ${PF}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+curl mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash,json,mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,xmlwriter,zip]
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "Additional applications (calendar, ...) are no longer provided by default."
+ elog "You can install them after login via the applications management page"
+ elog "(check the recommended tab). No application data is lost."
+ webapp_pkg_postinst
+}