summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/webdavcgi/webdavcgi-0.8.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/webdavcgi/webdavcgi-0.8.4.ebuild')
-rw-r--r--www-apps/webdavcgi/webdavcgi-0.8.4.ebuild164
1 files changed, 164 insertions, 0 deletions
diff --git a/www-apps/webdavcgi/webdavcgi-0.8.4.ebuild b/www-apps/webdavcgi/webdavcgi-0.8.4.ebuild
new file mode 100644
index 000000000000..6b72717a039e
--- /dev/null
+++ b/www-apps/webdavcgi/webdavcgi-0.8.4.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs versionator
+
+DESCRIPTION="A Perl CGI for accessing and sharing files, or calendar/addressbooks via WebDAV"
+HOMEPAGE="http://webdavcgi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+
+# Provide slotting on minor versions. WebDAV CGI is a web application which
+# can be shared by multiple instances and thus major updates shouldn't be
+# enforced to all users/instances at the same time.
+SLOT="$(get_version_component_range 1-2)"
+
+KEYWORDS="~amd64"
+IUSE="afs kerberos mysql postgres rcs samba +sqlite +suid"
+
+DEPEND=""
+RDEPEND="!www-apps/webdavcgi:0
+ afs? ( net-fs/openafs )
+ dev-lang/perl
+ dev-perl/Archive-Zip
+ dev-perl/File-Copy-Link
+ dev-perl/PerlIO-gzip
+ dev-perl/Quota
+ dev-perl/TimeDate
+ dev-perl/URI
+ dev-perl/UUID-Tiny
+ dev-perl/XML-Simple
+ kerberos? ( virtual/krb5 )
+ media-gfx/graphicsmagick[perl]
+ mysql? ( dev-perl/DBD-mysql )
+ virtual/perl-Module-Load
+ postgres? ( dev-perl/DBD-Pg )
+ rcs? ( dev-perl/Rcs )
+ samba? ( dev-perl/Filesys-SmbClient )
+ sqlite? ( dev-perl/DBD-SQLite )
+ dev-perl/CGI
+ virtual/perl-File-Spec
+ || ( virtual/httpd-cgi virtual/httpd-fastcgi )"
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+CGIBINDIR="cgi-bin"
+
+src_compile() {
+ if use suid; then
+ WEBDAVWRAPPERS="webdavwrapper" # Standard UID/GID wrapper
+
+ use afs && WEBDAVWRAPPERS+=" webdavwrapper-afs"
+ use kerberos && WEBDAVWRAPPERS+=" webdavwrapper-krb"
+
+ export WEBDAVWRAPPERS
+
+ local wrapper
+ for wrapper in ${WEBDAVWRAPPERS}; do
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} \
+ -o "${CGIBINDIR}/${wrapper}" \
+ "helper/${wrapper}.c" || die "compile ${wrapper} failed"
+ done
+ fi
+}
+
+src_install() {
+ exeinto "/usr/libexec/${PN}-${SLOT}/${CGIBINDIR}"
+ newexe "${CGIBINDIR}/logout-dist" "logout"
+ doexe "${CGIBINDIR}/webdav.pl"
+
+ use afs && doexe "${CGIBINDIR}/afswrapper"
+ use samba && doexe "${CGIBINDIR}/smbwrapper"
+
+ if use suid; then
+ # In order to change the user and group ID at runtime, the webdavwrapper
+ # needs to be run as root (set-user-ID and set-group-ID bit)
+ exeopts -o root -g root -m 6755
+
+ local wrapper
+ for wrapper in ${WEBDAVWRAPPERS}; do
+ einfo "Installing UID/GID wrapper ${wrapper}"
+ doexe "${CGIBINDIR}/${wrapper}"
+ done
+
+ # reset install opts
+ exeopts
+ else
+ ewarn "You have the 'suid' USE flag disabled"
+ ewarn "WebDAV CGI won't be able to switch user ids"
+ fi
+
+ local confDir='etc'
+ local webdavConfDir="/etc/${PN}-${SLOT}/default"
+
+ export WEBDAVCONFIG="${webdavConfDir}/webdav.conf"
+
+ insinto "${webdavConfDir}"
+ doins "${confDir}/mime.types"
+ newins "${FILESDIR}/webdav-${SLOT}.conf" "webdav.conf"
+
+ local installBaseDir="/usr/share/${PN}-${SLOT}"
+ local currentDir
+ for currentDir in htdocs lib locale; do
+ insinto "${installBaseDir}/${currentDir}"
+ doins -r "${currentDir}"/*
+ done
+
+ if use mysql || use postgres; then
+ local sqlDir='sql'
+ insinto "${installBaseDir}/${sqlDir}"
+ use mysql && "${sqlDir}/mysql.sql"
+ use postgres && "${sqlDir}/postgresql.sql"
+ fi
+
+ if use sqlite; then
+ # Directory where the SQLite database resides
+ local sqliteRootDir="/var/lib/${PN}/${SLOT}"
+ keepdir "${sqliteRootDir}"
+
+ # Default database directory where all users are able to create and
+ # share the databases, this can be changed within the config file and
+ # restricted to user/group only access if required.
+ export SQLITEDIR="${sqliteRootDir}/default"
+ keepdir "${SQLITEDIR}"
+ fperms 1777 "${SQLITEDIR}"
+ fi
+
+ # Default thumbnail directory, writable by all users
+ export THUMBNAILDIR="/var/cache/${PN}/${SLOT}/default/thumbnails"
+ keepdir "${THUMBNAILDIR}"
+ fperms 1777 "${THUMBNAILDIR}"
+
+ export APACHEEXAMPLECONFIG="apache-webdavcgi-${SLOT}-example.conf"
+ dodoc CHANGELOG TODO
+ dodoc "${FILESDIR}/${APACHEEXAMPLECONFIG}"
+ dohtml -r doc/*
+}
+
+pkg_postinst() {
+ ewarn "In order to allow different users to create and share files,"
+ ewarn "some directories were installed with world write access by default."
+ ewarn "To set restrictive permissions, add all WebDAV CGI users to a"
+ ewarn "common group, and allow access to the following directories by this"
+ ewarn "group only."
+ ewarn "Thumbnail directory: ${THUMBNAILDIR}"
+ use sqlite && ewarn "SQLite directory: ${SQLITEDIR}"
+
+ ewarn
+ ewarn "Until bug #456180 is fixed, you probably have to re-emerge"
+ ewarn "media-gfx/graphicsmagick"
+
+ elog
+ elog "The WebDAV CGI config is located at ${WEBDAVCONFIG}."
+ elog
+ elog "An example Apache HTTP server configuration snippet is available in"
+ elog "/usr/share/doc/${PF} in the file ${APACHEEXAMPLECONFIG}"
+
+ einfo
+ einfo "Detailed installation and configuration instructions can be found at"
+ einfo "http://webdavcgi.sourceforge.net/"
+}