summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-11-15 11:45:54 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-11-15 11:46:06 +0100
commitfa761a9ba322221401d26f901b07995180d172c2 (patch)
tree43b024160807c0b32ca1c502785f6732c50cfd00 /www-apps/wordpress
parentsys-block/open-iscsi: Bump to version 2.1.0 (diff)
downloadgentoo-fa761a9ba322221401d26f901b07995180d172c2.tar.gz
gentoo-fa761a9ba322221401d26f901b07995180d172c2.tar.bz2
gentoo-fa761a9ba322221401d26f901b07995180d172c2.zip
web-apps/wordpress-5.3: bump
1) style cleanup 2) allowing plugins to be updated via wordpress 3) updated postinstall-en.txt and postupgrade-en.txt Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'www-apps/wordpress')
-rw-r--r--www-apps/wordpress/Manifest1
-rw-r--r--www-apps/wordpress/files/postinstall-en.txt7
-rw-r--r--www-apps/wordpress/files/postupgrade-en.txt14
-rw-r--r--www-apps/wordpress/wordpress-5.3.ebuild57
4 files changed, 58 insertions, 21 deletions
diff --git a/www-apps/wordpress/Manifest b/www-apps/wordpress/Manifest
index 8d48c9f145f3..325160cd1228 100644
--- a/www-apps/wordpress/Manifest
+++ b/www-apps/wordpress/Manifest
@@ -1 +1,2 @@
DIST wordpress-5.2.4.tar.gz 11199173 BLAKE2B 879f5de709b56474674aef575ba79fffa57263080a043d51adada12fe9f766f7c0731195d468f0103bca8e5ffa2d9775ec3d328a76fd0fe104044de131c11037 SHA512 eaf6e1555f13e4fe1f1a99691b271e658d9a83ab5fa7de1480987875565aab45d246bf8bb2e9828bd43979b96a0fb0db1ebf61c62c4967d9af08a370bef083e0
+DIST wordpress-5.3.tar.gz 12372564 BLAKE2B a3cb1e76dd62ffe4e3689e9d3fdb1a96b8f787a763610684a0fbb0ae7fe9ad34252d1cb7119f3edf24c771bf50ca4a322e26e9b3894d12250ceb299f6fd3b019 SHA512 90a0df8a2b965c06ac10ba0dd3521b98bbd6040780bd2ccfa14a445bd2cbdb1311277563dd30f5cdc918a4177ec7c49e89260d95309fb08e271173f242fcfc07
diff --git a/www-apps/wordpress/files/postinstall-en.txt b/www-apps/wordpress/files/postinstall-en.txt
index 54c97717bc37..aa26202b493a 100644
--- a/www-apps/wordpress/files/postinstall-en.txt
+++ b/www-apps/wordpress/files/postinstall-en.txt
@@ -25,13 +25,6 @@ Wordpress has had a history of serious security flaws. Any application
with less widespread use but the same amount of security issues would
have been removed from the tree.
-After a short period of being in the unstable tree we once again decided
-that we hard mask the package.
-
-THIS MEANS THAT THERE IS NO GUARANTEE WHATSOEVER THAT THE PACKAGE WILL
-GET UPGRADED WITHIN A REASONABLE AMOUNT OF TIME EVEN IN THE CASE OF
-SEVERE SECURITY ISSUES.
-
We consider installing this package a severe risk to your system and
you should keep a close eye on the common security trackers so
that you are able to fix problems with your installation yourself if
diff --git a/www-apps/wordpress/files/postupgrade-en.txt b/www-apps/wordpress/files/postupgrade-en.txt
index 5c7b3276db98..030326fbf632 100644
--- a/www-apps/wordpress/files/postupgrade-en.txt
+++ b/www-apps/wordpress/files/postupgrade-en.txt
@@ -10,28 +10,14 @@ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/wp-admin/upgrade.php
and follow the instructions on the screen.
-Note that the default theme has changed between Wordpress 2.x and 3.x,
-so if you were using the default theme, your site will fail to load after
-the upgrade. Log in to the admin interface and open the themes section to
-reset to the new default theme. If you face other troubles after the
-upgrade, you might want to look for broken plugins or themes.
-
------------------------------------------------------------------------
!!!!!!!!! SECURITY WARNING !!!!!!!!!!!
Wordpress has had a history of serious security flaws. Any application
with less widespread use but the same amount of security issues would
have been removed from the tree.
-
-After a short period of being in the unstable tree we once again decided
-that we hard mask the package.
-
-THIS MEANS THAT THERE IS NO GUARANTEE WHATSOEVER THAT THE PACKAGE WILL
-GET UPGRADED WITHIN A REASONABLE AMOUNT OF TIME EVEN IN THE CASE OF
-SEVERE SECURITY ISSUES.
We consider installing this package a severe risk to your system and
you should keep a close eye on the common security trackers so
that you are able to fix problems with your installation yourself if
required.
-
diff --git a/www-apps/wordpress/wordpress-5.3.ebuild b/www-apps/wordpress/wordpress-5.3.ebuild
new file mode 100644
index 000000000000..5a8f16d8897e
--- /dev/null
+++ b/www-apps/wordpress/wordpress-5.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+S=${WORKDIR}/${PN}
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc readme.html
+ rm readme.html license.txt || die
+
+ if use !akismet ; then
+ rm -R wp-content/plugins/akismet/ || die
+ fi
+ if use !examples ; then
+ rm wp-content/plugins/hello.php || die
+ fi
+ if use !themes ; then
+ rm -R wp-content/themes/*/ || die
+ fi
+
+ [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ # allows plugins update if allowed within WP
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/includes/file.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/wp-config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}