summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-04-13 11:43:16 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-04-13 12:38:52 +0200
commit0d545697dbc0457957a3249aef27ea57fae36f76 (patch)
tree24c1a8173789044e955b2eae9e533b13fa5cb2d6 /www-apps
parentmedia-libs/jasper: fix USE=doc breakage (diff)
downloadgentoo-0d545697dbc0457957a3249aef27ea57fae36f76.tar.gz
gentoo-0d545697dbc0457957a3249aef27ea57fae36f76.tar.bz2
gentoo-0d545697dbc0457957a3249aef27ea57fae36f76.zip
www-apps/nextcloud: add 24.0.11, 25.0.5, 26.0.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nextcloud/Manifest3
-rw-r--r--www-apps/nextcloud/nextcloud-24.0.11.ebuild43
-rw-r--r--www-apps/nextcloud/nextcloud-25.0.5.ebuild43
-rw-r--r--www-apps/nextcloud/nextcloud-26.0.0.ebuild43
4 files changed, 132 insertions, 0 deletions
diff --git a/www-apps/nextcloud/Manifest b/www-apps/nextcloud/Manifest
index d43976626035..ca86afa756e0 100644
--- a/www-apps/nextcloud/Manifest
+++ b/www-apps/nextcloud/Manifest
@@ -1,2 +1,5 @@
DIST nextcloud-24.0.10.tar.bz2 124303994 BLAKE2B 17d83a5dc5fd54ce5cdf84678f23e02ec49177d717d854977457cefacdfc7c58ab98bf7a31fc48f69c8b8ec06bf978e0de1bf03e45620369a39d6bc9b269c1df SHA512 519ad653a64ee329f769b6a047ef6826984846af3a6dc3e5666a4101c997af5e8e50ebc5678623d5bdb98b55f0a6bdb1c82ed410ce4671dca41e313f36de3309
+DIST nextcloud-24.0.11.tar.bz2 124651413 BLAKE2B 3ee7f5da74e15d21b3384537688af7b3f40f2ea1be22b5910150511e87b6780a5ec450db256ae21d55e1ba0ef64d78aaa5f28aae3bc01ea0585934328e631577 SHA512 20c5f65bb72ca5b144702b522dc9bbac94a839801c392a25ef8c2765800909678b6bb85a1c088fccc92d035a0316a9e038358878d8e00db63b09fc23907cfbef
DIST nextcloud-25.0.4.tar.bz2 145687281 BLAKE2B b349cea558ef2b1925da19713b76553076d57ee9e2fd07123796c0f329e139ccfb66c3e113ddb4bcdb7841d5e61eb1237748fd1c38216f7ae43c006e87730deb SHA512 0a9a6a2cc26951ede77509926fd6192668d140559daaa49611e8f9d592ccec39f22c7289d2d55794885afc7665bfb6f5eae43a0e6d160954b21c3e236da944e5
+DIST nextcloud-25.0.5.tar.bz2 145918261 BLAKE2B a9f9f40f36b5024f7a1a1f9ea6e2488c790cc761f26cf137975a31fdbd711fada90bc1fc621094987467de59d8bb434dedabee09400ee0253d61953a8d84ba7e SHA512 03563ff552ab2ef195070079ef54a24d8f04b30b09ffb2f870eeb64fab3575c1e8535d98043ab9bd2e0a54fc515cf64ab3d2f9e14e71df2e482f104b0fcf0231
+DIST nextcloud-26.0.0.tar.bz2 149346219 BLAKE2B 0e01dc1b364a27d0bbb58f91c831f099679c9d78dd21bafd0e50867fd3ccc7f2b50158bc393b7e6b87e51805d653007148e2aa06f26c0c12942e5cbe840beafe SHA512 ad589d2e128fd73e9282e1f41d5189dc3216270e546524e8feaefa9013202e806047cc304ef77a8954eac16b010b3d65bc99ce8547256c1df6e90b69aa2f232a
diff --git a/www-apps/nextcloud/nextcloud-24.0.11.ebuild b/www-apps/nextcloud/nextcloud-24.0.11.ebuild
new file mode 100644
index 000000000000..e9db891d0021
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-24.0.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.2[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/nextcloud/nextcloud-25.0.5.ebuild b/www-apps/nextcloud/nextcloud-25.0.5.ebuild
new file mode 100644
index 000000000000..e9db891d0021
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-25.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.2[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/nextcloud/nextcloud-26.0.0.ebuild b/www-apps/nextcloud/nextcloud-26.0.0.ebuild
new file mode 100644
index 000000000000..e9db891d0021
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-26.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.2[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}