summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-12-25 22:05:50 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-12-25 22:05:50 +0100
commit0fefadf11c8c0028f95fed9c2fa9dfdbf0fd8f24 (patch)
tree6d68176e44f01bb58d468bb6711c70555237e1c6 /www-apps
parentwww-apps/gitea: Remove old (diff)
downloadgentoo-0fefadf11c8c0028f95fed9c2fa9dfdbf0fd8f24.tar.gz
gentoo-0fefadf11c8c0028f95fed9c2fa9dfdbf0fd8f24.tar.bz2
gentoo-0fefadf11c8c0028f95fed9c2fa9dfdbf0fd8f24.zip
www-apps/gitea: Use git user by default
Package-Manager: portage-2.3.3
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/files/gitea.logrotated2
-rw-r--r--www-apps/gitea/gitea-1.0.0-r2.ebuild (renamed from www-apps/gitea/gitea-1.0.0-r1.ebuild)9
2 files changed, 5 insertions, 6 deletions
diff --git a/www-apps/gitea/files/gitea.logrotated b/www-apps/gitea/files/gitea.logrotated
index 4ddfdf06bdaf..ec6ddfe606b9 100644
--- a/www-apps/gitea/files/gitea.logrotated
+++ b/www-apps/gitea/files/gitea.logrotated
@@ -1,5 +1,5 @@
/var/log/gitea/* {
- su gitea gitea
+ su git git
missingok
size 5M
rotate 3
diff --git a/www-apps/gitea/gitea-1.0.0-r1.ebuild b/www-apps/gitea/gitea-1.0.0-r2.ebuild
index 8283d50ed3ca..ca6a3eb6fa8d 100644
--- a/www-apps/gitea/gitea-1.0.0-r1.ebuild
+++ b/www-apps/gitea/gitea-1.0.0-r2.ebuild
@@ -22,8 +22,8 @@ DEPEND="dev-go/go-bindata"
RDEPEND="dev-vcs/git"
pkg_setup() {
- enewgroup gitea
- enewuser gitea -1 /bin/bash /var/lib/gitea gitea
+ enewgroup git
+ enewuser git -1 /bin/bash /var/lib/gitea git
}
src_prepare() {
@@ -32,8 +32,7 @@ src_prepare() {
sed -i -e "s/git rev-parse --short HEAD/echo ${EGIT_COMMIT:0:7}/"\
-e "s/^LDFLAGS += -X \"main.Version.*$/LDFLAGS += -X \"main.Version=${PV}\"/"\
-e "s/-ldflags '-s/-ldflags '/" src/${EGO_PN%/*}/Makefile || die
- sed -i -e "s#RUN_USER = git#RUN_USER = gitea#"\
- -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${GITEA_PREFIX}/data#"\
+ sed -i -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${GITEA_PREFIX}/data#"\
-e "s#^PATH = data/gitea.db#PATH = ${GITEA_PREFIX}/data/gitea.db#"\
-e "s#^PROVIDER_CONFIG = data/sessions#PROVIDER_CONFIG = ${GITEA_PREFIX}/data/sessions#"\
-e "s#^AVATAR_UPLOAD_PATH = data/avatars#AVATAR_UPLOAD_PATH = ${GITEA_PREFIX}/data/avatars#"\
@@ -58,5 +57,5 @@ src_install() {
newinitd "${FILESDIR}"/gitea.initd gitea
newconfd "${FILESDIR}"/gitea.confd gitea
keepdir /var/log/gitea /var/lib/gitea/data
- fowners -R gitea:gitea /var/log/gitea /var/lib/gitea/
+ fowners -R git:git /var/log/gitea /var/lib/gitea/
}