summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2020-12-29 04:53:53 -0500
committerSam James <sam@gentoo.org>2021-01-10 18:34:18 +0000
commit140e2d0f701eed29b9f9ef9c42c7f6ad5947422c (patch)
treecd71c5116ad29ccd7fa058825b497579cac622d0 /www-apps
parentsys-boot/refind: fix build with Bash 5.1 (diff)
downloadgentoo-140e2d0f701eed29b9f9ef9c42c7f6ad5947422c.tar.gz
gentoo-140e2d0f701eed29b9f9ef9c42c7f6ad5947422c.tar.bz2
gentoo-140e2d0f701eed29b9f9ef9c42c7f6ad5947422c.zip
www-apps/gitea: fix build with bash-5.1
Closes: https://bugs.gentoo.org/762391 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/gitea-1.13.0.ebuild4
-rw-r--r--www-apps/gitea/gitea-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/www-apps/gitea/gitea-1.13.0.ebuild b/www-apps/gitea/gitea-1.13.0.ebuild
index 7bb52ed548ee..2602c088b24f 100644
--- a/www-apps/gitea/gitea-1.13.0.ebuild
+++ b/www-apps/gitea/gitea-1.13.0.ebuild
@@ -84,8 +84,8 @@ src_compile() {
"-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
)
local makeenv=(
- TAGS="${gitea_tags[@]}"
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[@]}"
+ TAGS="${gitea_tags[*]}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
)
[[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${MY_PV}")
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index d6f5cfcf5a8e..b975338d0ffb 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -81,8 +81,8 @@ src_compile() {
"-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
)
local makeenv=(
- TAGS="${gitea_tags[@]}"
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[@]}"
+ TAGS="${gitea_tags[*]}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
)
[[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${MY_PV}")