summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-03-09 21:18:19 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-03-09 21:22:01 -0600
commit2674f01e3f1634d58dd88cba23be7387d3d6de14 (patch)
treecf2cb3fd450326d8332b7aeaea3747552b70e396 /www-apps
parentwww-apps/icingaweb2: 2.9.6 fast stable for path traversal bug (diff)
downloadgentoo-2674f01e3f1634d58dd88cba23be7387d3d6de14.tar.gz
gentoo-2674f01e3f1634d58dd88cba23be7387d3d6de14.tar.bz2
gentoo-2674f01e3f1634d58dd88cba23be7387d3d6de14.zip
www-apps/icingaweb2: clean up
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.9.5-r1.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 90a6947a3522..5e05a3512b06 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,2 +1 @@
-DIST icingaweb2-2.9.5.tar.gz 12313426 BLAKE2B cd044651128a560590a71a795e3ef55160db6ad8ac84cee8865258ea31747b1f1fcdc4ffab45f8e410ff7ed2d9db7c56bc3f10d856e2f0063f9608d485aa2c51 SHA512 1fa6f33c38283f0440e969ef5cd6f4aee088bfa473a7e738e70b73b19d9a512834bc6fc98b41352b8c54b3e0aa295404ab8a68d2c5009345010adfc7fe4f0abb
DIST icingaweb2-2.9.6.tar.gz 12313930 BLAKE2B 696b882fc1bb0fd0452dca9e8b13b336181d953c05ab43c1db38073aa817496ca431dfb0f68adab0a6eae7c2238878dda98a57d8b69b2bc19ed94f1afbd26fe5 SHA512 507ce9ab8e31f0afc19de173c56e9ce2986c9c2e945ff3516e005b49a69993ccb00ec53d4c53bc0beee865cebc533b4b91b0d7707abf9d30d4cb76b7545fb6a4
diff --git a/www-apps/icingaweb2/icingaweb2-2.9.5-r1.ebuild b/www-apps/icingaweb2/icingaweb2-2.9.5-r1.ebuild
deleted file mode 100644
index 1ef7a422fe00..000000000000
--- a/www-apps/icingaweb2/icingaweb2-2.9.5-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit depend.apache multilib
-
-DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
-HOMEPAGE="http://www.icinga.org/"
-
-if [[ ${PV} == *9999 ]];then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
-REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
-
-DEPEND=">=net-analyzer/icinga2-2.1.1
- dev-php/pecl-imagick
- pdf? ( media-gfx/imagemagick[png] )
- apache2-server? ( >=www-servers/apache-2.4.0 )
- nginx? ( >=www-servers/nginx-1.7.0:* )
- || (
- dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:8.0[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- )
- dev-libs/icinga-php-library
- dev-libs/icinga-php-thirdparty
- acct-group/icingacmd
- acct-group/icingaweb2"
-RDEPEND="${DEPEND}"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
-
- use nginx && usermod -a -G icingacmd,icingaweb2 nginx
- use apache2 && usermod -a -G icingacmd,icingaweb2 apache
-}
-
-pkg_config() {
- if [[ -d /etc/icingaweb2 ]] ; then
- einfo "Updating existing installation ..."
- else
- einfo "Running first time setup ..."
- einfo "Creating configuration directory ..."
- /usr/share/${PN}/bin/icingacli setup config directory
- einfo "Creating authentication token for web setup ..."
- /usr/share/${PN}/bin/icingacli setup token create
- if use apache2 ; then
- einfo "The following might be useful for your Apache2 configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
- fi
- if use nginx ; then
- einfo "The following might be useful for your NGinx configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
- fi
- fi
- einfo "All done."
-}
-
-src_install() {
- insinto "/usr/share/${PN}"
- doins -r "${S}"/*
- fperms -R a+rX "/usr/share/${PN}/public/"
- fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
- fowners root:icingaweb2 "/usr/share/${PN}/bin/icingacli"
-}
-
-pkg_postinst() {
- einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
-}