summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2018-12-06 22:06:50 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2018-12-06 22:06:50 -0100
commitab108a1dba6e0d0f8ebf5e8458a4a77972b04899 (patch)
treeca75c809a31be1c5445dae92d99e6f27f71ebc51 /www-apps
parentsys-apps/guix: switch to new ci.guix.info substitute server (diff)
downloadgentoo-ab108a1dba6e0d0f8ebf5e8458a4a77972b04899.tar.gz
gentoo-ab108a1dba6e0d0f8ebf5e8458a4a77972b04899.tar.bz2
gentoo-ab108a1dba6e0d0f8ebf5e8458a4a77972b04899.zip
www-apps/drupal: Bump to 8.6.4 release.
Follow Tyler Montbriand's suggestion on bug 660554. Closes: http://bugs.gentoo.org/660554 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.6.4.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 4377b1f428e6..1801f215435f 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -2,3 +2,4 @@ DIST drupal-7.60.tar.gz 3283058 BLAKE2B 2c29c089e0e13ce52c5d7a0bbf72c79596fbdc1a
DIST drupal-7.61.tar.gz 3287629 BLAKE2B 635fca54063bf3030cd3699f2395c64a4949719b38ad51e1ae67de928a0177bb8c049f383245ecd1ebf1d8dfe4dc1be012c0d83bd50eada8b05a959fd160d4ac SHA512 8f0bdd5b7ef33e62d09698b3889726fab1edb14df6263635bca65c9bbe0400df618dbf02ef298eeee169d48ab554d3b58d867bd4ce0d429b4b9167979917db51
DIST drupal-8.6.2.tar.gz 16240694 BLAKE2B 122ff2464af6376256d96db8b470cf5f83beeba80a5c63e549e7eb0cfc875629d0b2d4ed46b130294e2145ea5a428b15cfa0edfcd31596660188df769b68bcd2 SHA512 8cdcd31f3a112a577e622cca0fb7957580b5691102421344c6f6bfc3096f33aae3a68d7d8eb9062ad14761bac14b68c2967973b1b1ef367dcbd79b972493b7c5
DIST drupal-8.6.3.tar.gz 16372220 BLAKE2B b9bbf18e25292bfa87f23e2aa2329f86dfe714a265188c35998059b0075f31ceb6d0d6a23ed576615b1a6a6aef6b935a495e70b22aed0e649b41b79994bc9123 SHA512 93284235c9620ed235bfe0100317846694095ca96b1da7ac402c415e9f5f0819887c4da516655dabb49b4bbdba58935d7f78712c525c803125ec27d6a5692cea
+DIST drupal-8.6.4.tar.gz 16401179 BLAKE2B 15b44df0ddbc420aad07c95eda6c238a9862c186cd762c6f332452919340939f7b604b424a046adbe2111bd7ae4e50b7dad2a8d67b5122035fc0f30a7b2cb47a SHA512 ff81fe8aa10f635b5906d7a21efc5e8d44e96594d26a2637987ea2ef36b6ea323638bf4fca2374553d381645e4d187ef72d0284d4d0bad8663efe1e0b7bfcf8b
diff --git a/www-apps/drupal/drupal-8.6.4.ebuild b/www-apps/drupal/drupal-8.6.4.ebuild
new file mode 100644
index 000000000000..b6b875c85dfc
--- /dev/null
+++ b/www-apps/drupal/drupal-8.6.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}