summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-09-28 11:22:42 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-09-28 11:23:25 -0500
commitdf01e5a7e181e8985a363e9e428f6f0cea3d48c4 (patch)
tree774155976c6a177b7e183562b8010479f625772e /www-apps
parentdev-python/oslo-messaging: 5.30.1 bup (diff)
downloadgentoo-df01e5a7e181e8985a363e9e428f6f0cea3d48c4.tar.gz
gentoo-df01e5a7e181e8985a363e9e428f6f0cea3d48c4.tar.bz2
gentoo-df01e5a7e181e8985a363e9e428f6f0cea3d48c4.zip
www-apps/icingaweb2: 2.4.2 bup
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.4.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index f2c80cd15101..778f5b32c98c 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1 +1,2 @@
DIST icingaweb2-2.4.1.tar.gz 7176640 SHA256 27150d96a2172d0fa0c77389970052a1bf7aa6553494e80837f6699e96e24bc6 SHA512 21ac8faea3e339cfc668407cef826cf4a8f01c964ad102e2c9bc9716e20c3177cea10ec575b99a5a4bb0a9681032b83427c250c5288b037a70d27dc919d0f641 WHIRLPOOL 40c5e48f0c7b6b32cb1eb02c1a447512bdba397eda8c20110a1e4d0c0b794265fe413c2c3a1a56d3f009e4245e211322a5b97a16449af4a1ff90bb4831f781fb
+DIST icingaweb2-2.4.2.tar.gz 7180122 SHA256 8ce42b4f0fb3ddd93c56d70c642512af13db1d5db2ad0227ec7567a4413daa94 SHA512 2a6f80561b59fde1b7ca72b8a120f93685a4741e7af036a90cdd5a1371f8e6d6caa25161f136b379255032b16b21914325a26f078121743d1299e96e7685ef53 WHIRLPOOL 0f350e796e5b03c5d3e0c501cdae8c485c2eb745da87e308f57066cfe507d24482799ab9e6fe1ed621c19f14fcca3b97c7f57d67a28ac51e42c13aa7094afe83
diff --git a/www-apps/icingaweb2/icingaweb2-2.4.2.ebuild b/www-apps/icingaweb2/icingaweb2-2.4.2.ebuild
new file mode 100644
index 000000000000..9c54138b2b4f
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.4.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit depend.apache eutils multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 ldap mysql nginx pdf postgres"
+REQUIRED_USE="^^ ( apache2 nginx )"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2? (
+ >=www-servers/apache-2.4.0
+ || (
+ dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )
+ nginx? (
+ >=www-servers/nginx-1.7.0:*
+ || (
+ dev-lang/php:5.6[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}