summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-03-09 16:03:03 -0500
committerMike Gilbert <floppym@gentoo.org>2018-03-09 16:03:03 -0500
commit7df5c72df25e3c79e487df9ba464709702847f21 (patch)
treee01ec49ff065dfdaf411c9032c8c6aead69a1516 /www-client/chromium
parentnet-wireless/rtl_433: fix distfile name (diff)
downloadgentoo-7df5c72df25e3c79e487df9ba464709702847f21.tar.gz
gentoo-7df5c72df25e3c79e487df9ba464709702847f21.tar.bz2
gentoo-7df5c72df25e3c79e487df9ba464709702847f21.zip
www-client/chromium: fix bundled ffmpeg to not force lld
Package-Manager: Portage-2.3.24, Repoman-2.3.6_p81
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-65.0.3325.146.ebuild1
-rw-r--r--www-client/chromium/chromium-66.0.3355.0.ebuild1
-rw-r--r--www-client/chromium/files/chromium-ffmpeg-clang.patch21
3 files changed, 23 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-65.0.3325.146.ebuild b/www-client/chromium/chromium-65.0.3325.146.ebuild
index 11bbb4b77805..3ca4d45a0ba9 100644
--- a/www-client/chromium/chromium-65.0.3325.146.ebuild
+++ b/www-client/chromium/chromium-65.0.3325.146.ebuild
@@ -154,6 +154,7 @@ PATCHES=(
"${FILESDIR}/chromium-math.h-r0.patch"
"${FILESDIR}/chromium-clang-r3.patch"
"${FILESDIR}/chromium-stdint.patch"
+ "${FILESDIR}/chromium-ffmpeg-clang.patch"
)
pre_build_checks() {
diff --git a/www-client/chromium/chromium-66.0.3355.0.ebuild b/www-client/chromium/chromium-66.0.3355.0.ebuild
index 4c8e080b09ee..72c8738a74f3 100644
--- a/www-client/chromium/chromium-66.0.3355.0.ebuild
+++ b/www-client/chromium/chromium-66.0.3355.0.ebuild
@@ -154,6 +154,7 @@ PATCHES=(
"${FILESDIR}/chromium-stdint.patch"
"${FILESDIR}/chromium-clang-r4.patch"
"${FILESDIR}/chromium-ffmpeg-r1.patch"
+ "${FILESDIR}/chromium-ffmpeg-clang.patch"
)
pre_build_checks() {
diff --git a/www-client/chromium/files/chromium-ffmpeg-clang.patch b/www-client/chromium/files/chromium-ffmpeg-clang.patch
new file mode 100644
index 000000000000..6c5ac71323b4
--- /dev/null
+++ b/www-client/chromium/files/chromium-ffmpeg-clang.patch
@@ -0,0 +1,21 @@
+--- a/third_party/ffmpeg/chromium/scripts/build_ffmpeg.py
++++ b/third_party/ffmpeg/chromium/scripts/build_ffmpeg.py
+@@ -639,18 +639,8 @@
+ if 'win' not in target_os:
+ configure_flags['Common'].extend([
+ '--enable-pic',
+- '--cc=clang',
+- '--cxx=clang++',
+- '--ld=clang',
+ ])
+
+- # Clang Linux will use the first 'ld' it finds on the path, which will
+- # typically be the system one, so explicitly configure use of Clang's
+- # ld.lld, to ensure that things like cross-compilation and LTO work.
+- # This does not work for arm64, ia32 and is always used on mac.
+- if target_arch not in ['arm64', 'ia32', 'mipsel'] and target_os != 'mac':
+- configure_flags['Common'].append('--extra-ldflags=-fuse-ld=lld')
+-
+ # Should be run on Mac.
+ if target_os == 'mac':
+ if host_os != 'mac':