summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-11-12 12:48:17 -0500
committerMike Gilbert <floppym@gentoo.org>2017-11-12 12:48:17 -0500
commit86b59bfc2ab0a53a9b3cc59704bccb1e92964c4e (patch)
treeed98471facc9e2834a564c5c1807f339cac188bb /www-client/chromium
parentdev-lang/python: 3.5.4 stable on arm and ppc, bug #620940 (diff)
downloadgentoo-86b59bfc2ab0a53a9b3cc59704bccb1e92964c4e.tar.gz
gentoo-86b59bfc2ab0a53a9b3cc59704bccb1e92964c4e.tar.bz2
gentoo-86b59bfc2ab0a53a9b3cc59704bccb1e92964c4e.zip
www-client/chromium: fix build failure with gcc5
Closes: https://bugs.gentoo.org/637186 Package-Manager: Portage-2.3.13_p7, Repoman-2.3.3_p87
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-63.0.3239.30.ebuild1
-rw-r--r--www-client/chromium/chromium-64.0.3253.3.ebuild1
-rw-r--r--www-client/chromium/files/chromium-gcc5-r5.patch11
3 files changed, 13 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-63.0.3239.30.ebuild b/www-client/chromium/chromium-63.0.3239.30.ebuild
index 7cfd3eaf32bb..82207820db52 100644
--- a/www-client/chromium/chromium-63.0.3239.30.ebuild
+++ b/www-client/chromium/chromium-63.0.3239.30.ebuild
@@ -147,6 +147,7 @@ PATCHES=(
"${FILESDIR}/${PN}-gcc5-r4.patch"
"${FILESDIR}/${PN}-clang-r1.patch"
"${FILESDIR}/${PN}-webrtc-r0.patch"
+ "${FILESDIR}/${PN}-gcc5-r5.patch"
)
pre_build_checks() {
diff --git a/www-client/chromium/chromium-64.0.3253.3.ebuild b/www-client/chromium/chromium-64.0.3253.3.ebuild
index 2018f07b04ea..3961a106c128 100644
--- a/www-client/chromium/chromium-64.0.3253.3.ebuild
+++ b/www-client/chromium/chromium-64.0.3253.3.ebuild
@@ -147,6 +147,7 @@ PATCHES=(
"${FILESDIR}/chromium-webrtc-r0.patch"
"${FILESDIR}/chromium-math-includes-r0.patch"
"${FILESDIR}/chromium-${PV}-gpu_lists_version.h.patch"
+ "${FILESDIR}/chromium-gcc5-r5.patch"
)
pre_build_checks() {
diff --git a/www-client/chromium/files/chromium-gcc5-r5.patch b/www-client/chromium/files/chromium-gcc5-r5.patch
new file mode 100644
index 000000000000..a07b973d8c05
--- /dev/null
+++ b/www-client/chromium/files/chromium-gcc5-r5.patch
@@ -0,0 +1,11 @@
+--- a/third_party/WebKit/public/web/WebFrameClient.h
++++ b/third_party/WebKit/public/web/WebFrameClient.h
+@@ -507,7 +507,7 @@
+ // Returns string to be used as a frame id in the devtools protocol.
+ // It is derived from the content's devtools_frame_token, is
+ // defined by the browser and passed into Blink upon frame creation.
+- virtual WebString GetInstrumentationToken() { return ""; }
++ virtual WebString GetInstrumentationToken() { return WebString(); }
+
+ // PlzNavigate
+ // Called to abort a navigation that is being handled by the browser process.