summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-01-29 17:26:22 -0500
committerMike Gilbert <floppym@gentoo.org>2017-01-29 17:27:09 -0500
commitcafd6ad57a34ab75bcd488be996019dc6c3f8268 (patch)
treeace138a60262b8edf1b610824e787bbd5e7d97e5 /www-client/chromium
parentmedia-libs/libsidplay: Old. (diff)
downloadgentoo-cafd6ad57a34ab75bcd488be996019dc6c3f8268.tar.gz
gentoo-cafd6ad57a34ab75bcd488be996019dc6c3f8268.tar.bz2
gentoo-cafd6ad57a34ab75bcd488be996019dc6c3f8268.zip
www-client/chromium: fix warnings about _FORTIFY_SOURCE being redefined
Package-Manager: Portage-2.3.3_p42_p324477, Repoman-2.3.1_p35_p324477
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-57.0.2987.8.ebuild1
-rw-r--r--www-client/chromium/files/chromium-FORTIFY_SOURCE.patch27
2 files changed, 28 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-57.0.2987.8.ebuild b/www-client/chromium/chromium-57.0.2987.8.ebuild
index 139ec0c30d84..8613930c6866 100644
--- a/www-client/chromium/chromium-57.0.2987.8.ebuild
+++ b/www-client/chromium/chromium-57.0.2987.8.ebuild
@@ -158,6 +158,7 @@ For other desktop environments, try one of the following:
PATCHES=(
"${FILESDIR}/${PN}-system-ffmpeg-r4.patch"
"${FILESDIR}/${PN}-widevine-r1.patch"
+ "${FILESDIR}/${PN}-FORTIFY_SOURCE.patch"
)
pre_build_checks() {
diff --git a/www-client/chromium/files/chromium-FORTIFY_SOURCE.patch b/www-client/chromium/files/chromium-FORTIFY_SOURCE.patch
new file mode 100644
index 000000000000..c6477d690872
--- /dev/null
+++ b/www-client/chromium/files/chromium-FORTIFY_SOURCE.patch
@@ -0,0 +1,27 @@
+Drop _FORTIFY_SOURCE=2 from defines
+
+Gentoo toolchains enable this by default. Removing this prevents spammy
+warnings about the macro being redefined.
+
+--- a/build/config/compiler/BUILD.gn
++++ b/build/config/compiler/BUILD.gn
+@@ -1069,19 +1069,6 @@ config("chromium_code") {
+ "__STDC_FORMAT_MACROS",
+ ]
+
+- if (!is_debug && !using_sanitizer &&
+- (!is_linux || !is_clang || is_official_build)) {
+- # _FORTIFY_SOURCE isn't really supported by Clang now, see
+- # http://llvm.org/bugs/show_bug.cgi?id=16821.
+- # It seems to work fine with Ubuntu 12 headers though, so use it in
+- # official builds.
+- #
+- # Non-chromium code is not guaranteed to compile cleanly with
+- # _FORTIFY_SOURCE. Also, fortified build may fail when optimizations are
+- # disabled, so only do that for Release build.
+- defines += [ "_FORTIFY_SOURCE=2" ]
+- }
+-
+ if (is_mac || is_ios) {
+ cflags_objc = [ "-Wobjc-missing-property-synthesis" ]
+ cflags_objcc = [ "-Wobjc-missing-property-synthesis" ]