summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2020-08-01 18:05:20 -0400
committerSam James <sam@gentoo.org>2020-08-07 17:57:48 +0000
commit011b668c74c2141e72c78da4175bcbf26fe21988 (patch)
tree69901c47b0ef9d400fd07515b0a88b37451bb571 /www-client/elinks
parentwww-client/elinks: add support for gnutls (diff)
downloadgentoo-011b668c74c2141e72c78da4175bcbf26fe21988.tar.gz
gentoo-011b668c74c2141e72c78da4175bcbf26fe21988.tar.bz2
gentoo-011b668c74c2141e72c78da4175bcbf26fe21988.zip
www-client/elinks: bump to 0.13.4
Closes: https://bugs.gentoo.org/705478 Signed-off-by: Felix Janda <felix.janda@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/elinks')
-rw-r--r--www-client/elinks/Manifest1
-rw-r--r--www-client/elinks/elinks-0.13.4.ebuild142
2 files changed, 143 insertions, 0 deletions
diff --git a/www-client/elinks/Manifest b/www-client/elinks/Manifest
index 342efac72307..51fa0ee2ac24 100644
--- a/www-client/elinks/Manifest
+++ b/www-client/elinks/Manifest
@@ -1,3 +1,4 @@
DIST elinks-0.12_pre5-js185-patches.tar.bz2 13820 BLAKE2B b850c66cc74d59c6cfb0c7c6ebaaddfe0706e8cdcc14b1df5232ba2b3c75bf632e3b3e398b200876d7e594b122c6b27227ca92729129ef955174b05e7f0e6a06 SHA512 1552aeacdecb0a2db357402e0474d6b4810c767609d1d399b3350a4bcdc21ba9c0bde5a5d0bffd1d7b27d41ac46e3e85ae2527d715a1645a2dd51ab14b8eab3c
DIST elinks-0.12pre6.tar.bz2 2854500 BLAKE2B 3d91c2a4b03cf77a2a86131cfb5339a40c6e89c8aaab7293d5b7f6861f0b7647b1951f2bc15814e342c926a154707162a7814981cdc729329dfb04627133f3bf SHA512 bff70faafea7c4739695a7fad8f659109894b318588f5a035a5594a6053238789259ce6067c2f5cb97448f138db143adebb23f84bf689bea209ba37573484b7f
+DIST elinks-0.13.4.tar.gz 3594672 BLAKE2B 67a44c05a24c200f7b472c6e7c3d0f0966c820ff6d7837ec2cf60e985f5b64cdd63f67103fcc897c293867174cf7162178c2b4af2ec2fdc261b130907cd7f8f7 SHA512 028ed8e6c00de5c65cde80b2e2c42a6568696d277dc8e5645130377d7bb5a3f6adacbea626b6e19ae3e756eb40b4dca5d642839d57943c1a04eb1fe65aa98fe6
DIST elinks-0.13_pre_pre20180225.tar.gz 3518990 BLAKE2B 89c95b1d6e438975f5711f2e83960c90ced451953f395f3d73eeca40e6187b423b3c7d50b065c11673ee9fe03e8ee99a4c7642ebc01eea888c417645a0e53d7d SHA512 3f817768766e6dd6df042f7512163c5de70766e4d565fc081f4f755f7f7958d5487b9ff2ea29187a5cc813dc0841d75d440087fbdaf99f73d2a269dca70d5725
diff --git a/www-client/elinks/elinks-0.13.4.ebuild b/www-client/elinks/elinks-0.13.4.ebuild
new file mode 100644
index 000000000000..82731e98cabf
--- /dev/null
+++ b/www-client/elinks/elinks-0.13.4.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="Advanced and well-established text-mode web browser"
+HOMEPAGE="http://elinks.or.cz/"
+SRC_URI="https://github.com/rkd77/felinks/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/felinks-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bittorrent brotli bzip2 debug finger ftp gopher gnutls gpm guile idn ipv6
+ javascript libressl lua +mouse nls nntp perl ruby samba ssl tre unicode X xml zlib"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ brotli? ( app-arch/brotli:= )
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ gpm? ( >=sys-libs/ncurses-5.2:0= >=sys-libs/gpm-1.20.0-r5 )
+ guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
+ idn? ( net-dns/libidn:= )
+ javascript? ( >=dev-lang/spidermonkey-1.8.5:0= )
+ lua? ( >=dev-lang/lua-5:0= )
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-lang/ruby:* dev-ruby/rubygems:* )
+ samba? ( net-fs/samba )
+ ssl? (
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ gnutls? ( net-libs/gnutls:= )
+ )
+ tre? ( dev-libs/tre )
+ X? ( x11-libs/libX11 x11-libs/libXt )
+ xml? ( >=dev-libs/expat-1.95.4 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-parallel-make.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's/-Werror//' configure* || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --sysconfdir="${EPREFIX}"/etc/elinks
+ --enable-leds
+ --enable-88-colors
+ --enable-256-colors
+ --enable-true-color
+ --enable-html-highlight
+ $(use_with gpm)
+ $(use_with brotli)
+ $(use_with bzip2 bzlib)
+ $(use_with guile)
+ $(use_with idn)
+ $(use_with javascript spidermonkey)
+ --with-luapkg=$(usev lua)
+ $(use_with perl)
+ $(use_with ruby)
+ $(use_with tre)
+ $(use_with X x)
+ $(use_with zlib)
+ $(use_enable bittorrent)
+ $(use_enable finger)
+ $(use_enable ftp)
+ $(use_enable gopher)
+ $(use_enable ipv6)
+ $(use_enable mouse)
+ $(use_enable nls)
+ $(use_enable nntp)
+ $(use_enable samba smb)
+ $(use_enable xml xbel)
+ )
+
+ if use debug ; then
+ myconf+=( --enable-debug )
+ else
+ myconf+=( --enable-fastmem )
+ fi
+
+ if use ssl ; then
+ if use gnutls ; then
+ myconf+=( --with-gnutls )
+ else
+ myconf+=( --with-openssl="${EPREFIX}"/usr )
+ fi
+ else
+ myconf+=( --without-openssl --without-gnutls )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake V=1 DESTDIR="${D}" install
+
+ insinto /etc/elinks
+ newins contrib/keybind-full.conf keybind-full.sample
+ newins contrib/keybind.conf keybind.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES THANKS TODO doc/*.*
+ docinto contrib ; dodoc contrib/{README,colws.diff,elinks[-.]vim*}
+ docinto contrib/lua ; dodoc contrib/lua/{*.lua,elinks-remote}
+ docinto contrib/conv ; dodoc contrib/conv/*.*
+ docinto contrib/guile ; dodoc contrib/guile/*.scm
+
+ # elinks uses an internal copy of gettext which ships files that may
+ # collide with the system's gettext (https://bugs.gentoo.org/635090)
+ rm -f "${ED}"/usr/{share/locale/locale,lib/charset}.alias || die
+}
+
+pkg_postinst() {
+ elog "You may want to convert your html.cfg and links.cfg of"
+ elog "Links or older ELinks versions to the new ELinks elinks.conf"
+ elog "using /usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ elog
+ elog "Please have a look at /etc/elinks/keybind-full.sample and"
+ elog "/etc/elinks/keybind.conf.sample for some bindings examples."
+ elog
+ elog "You will have to set your TERM variable to 'xterm-256color'"
+ elog "to be able to use 256 colors in elinks."
+}