summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2020-10-24 21:12:01 -0400
committerSam James <sam@gentoo.org>2020-10-27 21:16:31 +0000
commit2bc6b8d63e6c3f6d778c5b5f5cd6c5ecb27b0374 (patch)
tree39502ab8277ea7bfd347382a811237db6fa60493 /www-client/elinks
parentnet-misc/unison: drop unison-2.51.2-r1 (diff)
downloadgentoo-2bc6b8d63e6c3f6d778c5b5f5cd6c5ecb27b0374.tar.gz
gentoo-2bc6b8d63e6c3f6d778c5b5f5cd6c5ecb27b0374.tar.bz2
gentoo-2bc6b8d63e6c3f6d778c5b5f5cd6c5ecb27b0374.zip
www-client/elinks: bump to 0.13.5
Signed-off-by: Felix Janda <felix.janda@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/elinks')
-rw-r--r--www-client/elinks/Manifest1
-rw-r--r--www-client/elinks/elinks-0.13.5.ebuild146
2 files changed, 147 insertions, 0 deletions
diff --git a/www-client/elinks/Manifest b/www-client/elinks/Manifest
index 8a51cb8261cc..102cce4b1a79 100644
--- a/www-client/elinks/Manifest
+++ b/www-client/elinks/Manifest
@@ -1 +1,2 @@
DIST elinks-0.13.4.tar.gz 3594672 BLAKE2B 67a44c05a24c200f7b472c6e7c3d0f0966c820ff6d7837ec2cf60e985f5b64cdd63f67103fcc897c293867174cf7162178c2b4af2ec2fdc261b130907cd7f8f7 SHA512 028ed8e6c00de5c65cde80b2e2c42a6568696d277dc8e5645130377d7bb5a3f6adacbea626b6e19ae3e756eb40b4dca5d642839d57943c1a04eb1fe65aa98fe6
+DIST elinks-0.13.5.tar.gz 3600196 BLAKE2B e1e51674b5630d6dab3de3030aee671876750fc97808bf4dca50b505fa2c31af669c4c3773b3830186fb98acda5c692ff1902c6e1240251ea699103a70bb4e43 SHA512 786f6142c03bca4a47a1043ca4f9c36aab431d192eb13bcad14c1da391f5746779a8f65e53eb781dff79f619ceb3ed30ef939eae8d81f64251fad9b803c0ae7b
diff --git a/www-client/elinks/elinks-0.13.5.ebuild b/www-client/elinks/elinks-0.13.5.ebuild
new file mode 100644
index 000000000000..278cf123dffe
--- /dev/null
+++ b/www-client/elinks/elinks-0.13.5.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="Advanced and well-established text-mode web browser"
+HOMEPAGE="http://elinks.or.cz/"
+SRC_URI="https://github.com/rkd77/felinks/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/felinks-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bittorrent brotli bzip2 debug finger ftp gopher gnutls gpm guile idn ipv6
+ libressl lua +mouse nls nntp perl ruby samba ssl tre unicode X xml zlib zstd"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ brotli? ( app-arch/brotli:= )
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ gpm? ( >=sys-libs/ncurses-5.2:0= >=sys-libs/gpm-1.20.0-r5 )
+ guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
+ idn? ( net-dns/libidn:= )
+ lua? ( >=dev-lang/lua-5:0= )
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-lang/ruby:* dev-ruby/rubygems:* )
+ samba? ( net-fs/samba )
+ ssl? (
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ gnutls? ( net-libs/gnutls:= )
+ )
+ tre? ( dev-libs/tre )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ )
+ xml? ( >=dev-libs/expat-1.95.4 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ zstd? ( app-arch/zstd:= )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-parallel-make.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's/-Werror//' configure* || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --sysconfdir="${EPREFIX}"/etc/elinks
+ --enable-leds
+ --enable-88-colors
+ --enable-256-colors
+ --enable-true-color
+ --enable-html-highlight
+ --without-spidermonkey
+ $(use_with gpm)
+ $(use_with brotli)
+ $(use_with bzip2 bzlib)
+ $(use_with guile)
+ $(use_with idn)
+ $(use_with lua luapkg lua)
+ $(use_with perl)
+ $(use_with ruby)
+ $(use_with tre)
+ $(use_with X x)
+ $(use_with zlib)
+ $(use_with zstd)
+ $(use_enable bittorrent)
+ $(use_enable finger)
+ $(use_enable ftp)
+ $(use_enable gopher)
+ $(use_enable ipv6)
+ $(use_enable mouse)
+ $(use_enable nls)
+ $(use_enable nntp)
+ $(use_enable samba smb)
+ $(use_enable xml xbel)
+ )
+
+ if use debug ; then
+ myconf+=( --enable-debug )
+ else
+ myconf+=( --enable-fastmem )
+ fi
+
+ if use ssl ; then
+ if use gnutls ; then
+ myconf+=( --with-gnutls )
+ else
+ myconf+=( --with-openssl="${EPREFIX}"/usr )
+ fi
+ else
+ myconf+=( --without-openssl --without-gnutls )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake V=1 DESTDIR="${D}" install
+
+ insinto /etc/elinks
+ newins contrib/keybind-full.conf keybind-full.sample
+ newins contrib/keybind.conf keybind.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES THANKS TODO doc/*.*
+ docinto contrib ; dodoc contrib/{README,colws.diff,elinks[-.]vim*}
+ docinto contrib/lua ; dodoc contrib/lua/{*.lua,elinks-remote}
+ docinto contrib/conv ; dodoc contrib/conv/*.*
+ docinto contrib/guile ; dodoc contrib/guile/*.scm
+
+ # elinks uses an internal copy of gettext which ships files that may
+ # collide with the system's gettext (https://bugs.gentoo.org/635090)
+ rm -f "${ED}"/usr/{share/locale/locale,lib/charset}.alias || die
+}
+
+pkg_postinst() {
+ elog "You may want to convert your html.cfg and links.cfg of"
+ elog "Links or older ELinks versions to the new ELinks elinks.conf"
+ elog "using /usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ elog
+ elog "Please have a look at /etc/elinks/keybind-full.sample and"
+ elog "/etc/elinks/keybind.conf.sample for some bindings examples."
+ elog
+ elog "You will have to set your TERM variable to 'xterm-256color'"
+ elog "to be able to use 256 colors in elinks."
+}