summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2020-08-01 18:03:36 -0400
committerSam James <sam@gentoo.org>2020-08-07 17:57:45 +0000
commit8b59848ca036c6edcef62e4ad0abe8d607d1d32b (patch)
tree98cf69751ac2a39102bf86c3670e8bdc84eb676d /www-client/elinks
parentdev-perl/Dist-Zilla: add workaround for broken `authordeps --missing` (diff)
downloadgentoo-8b59848ca036c6edcef62e4ad0abe8d607d1d32b.tar.gz
gentoo-8b59848ca036c6edcef62e4ad0abe8d607d1d32b.tar.bz2
gentoo-8b59848ca036c6edcef62e4ad0abe8d607d1d32b.zip
www-client/elinks: bump to EAPI 7
Signed-off-by: Felix Janda <felix.janda@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/elinks')
-rw-r--r--www-client/elinks/elinks-0.13_pre_pre20180225.ebuild11
-rw-r--r--www-client/elinks/elinks-9999.ebuild13
2 files changed, 15 insertions, 9 deletions
diff --git a/www-client/elinks/elinks-0.13_pre_pre20180225.ebuild b/www-client/elinks/elinks-0.13_pre_pre20180225.ebuild
index 61aa540f93cf..cb8f0fdd3d86 100644
--- a/www-client/elinks/elinks-0.13_pre_pre20180225.ebuild
+++ b/www-client/elinks/elinks-0.13_pre_pre20180225.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
+
inherit autotools python-any-r1
EGIT_COMMIT="0dd3aaabe61fbc5ed0d9a74915678d11d00c2a1c"
@@ -19,12 +21,13 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~a
IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm guile idn ipv6
javascript libressl lua +mouse nls nntp perl ruby samba ssl tre unicode X xml zlib"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
- brotli? ( app-arch/brotli )
+ brotli? ( app-arch/brotli:= )
bzip2? ( >=app-arch/bzip2-1.0.2 )
gpm? ( >=sys-libs/ncurses-5.2:0= >=sys-libs/gpm-1.20.0-r5 )
guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
- idn? ( net-dns/libidn )
+ idn? ( net-dns/libidn:= )
javascript? ( >=dev-lang/spidermonkey-1.8.5:0= )
lua? ( >=dev-lang/lua-5:0= )
perl? ( dev-lang/perl:= )
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index 0d10ee080caf..526c537b06d2 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
+
inherit autotools git-r3 python-any-r1
EGIT_REPO_URI="https://github.com/rkd77/felinks"
@@ -17,12 +19,13 @@ KEYWORDS=""
IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm guile idn ipv6
javascript libressl lua +mouse nls nntp perl ruby samba ssl tre unicode X xml zlib"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
- brotli? ( app-arch/brotli )
+ brotli? ( app-arch/brotli:= )
bzip2? ( >=app-arch/bzip2-1.0.2 )
gpm? ( >=sys-libs/ncurses-5.2:0= >=sys-libs/gpm-1.20.0-r5 )
guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
- idn? ( net-dns/libidn )
+ idn? ( net-dns/libidn:= )
javascript? ( >=dev-lang/spidermonkey-1.8.5:0= )
lua? ( >=dev-lang/lua-5:0= )
perl? ( dev-lang/perl:= )
@@ -41,7 +44,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-parallel-make.patch
- )
+)
src_unpack() {
default