summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/epiphany
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest3
-rw-r--r--www-client/epiphany/epiphany-3.14.2.ebuild97
-rw-r--r--www-client/epiphany/epiphany-3.16.2.ebuild103
-rw-r--r--www-client/epiphany/epiphany-3.16.3.ebuild96
-rw-r--r--www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch39
-rw-r--r--www-client/epiphany/files/epiphany-3.14.0-missing-symbol.patch39
-rw-r--r--www-client/epiphany/files/epiphany-3.14.0-unittest-1.patch30
-rw-r--r--www-client/epiphany/files/epiphany-3.14.0-unittest-2.patch45
-rw-r--r--www-client/epiphany/files/epiphany-3.16.0-unittest-1.patch30
-rw-r--r--www-client/epiphany/metadata.xml8
10 files changed, 490 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
new file mode 100644
index 000000000000..a85b05ccb59a
--- /dev/null
+++ b/www-client/epiphany/Manifest
@@ -0,0 +1,3 @@
+DIST epiphany-3.14.2.tar.xz 3063764 SHA256 cc69403b3b7addf30dd6eb703265a77102b8ab3c6194678ad0d2433f251492d0 SHA512 895f70768c4c765fdc221b2d44bfbb6e7599b0231b0af1a7a8a869fd461db6a09cbdd7a0120bda5dfd583d1d667391c574f18caf1aef5971b474d34911581dc7 WHIRLPOOL 0e235b3190b0ef42a9caa241258060dd5db1e8db07275102ec50b5223931badc56b6ad0c7ec32ccf27d74308845d4d9aef736775bbf6e5290a5d9275bd5c669a
+DIST epiphany-3.16.2.tar.xz 3084952 SHA256 a621b5f443bc168980d12452f1a031e0a50d99ffc825989a38b14d398def73e6 SHA512 424408e24bf69f8ad62e4c384d916890e128d164c8ab0c2932fa143f2989f017eb56d0b4a9c5e77518124c1e6d233df152ab6b85e3a1f26f28ddc97200c5aa83 WHIRLPOOL 2c970e2b22742193f7c2e9fd17a55f528132eb77dea0b3c8f83faf3c3f7d530343ccc26de51871a98fb92ab185b691b1d5dab49853b8415852c7b8b8518e6635
+DIST epiphany-3.16.3.tar.xz 3082680 SHA256 d527f1770779ec22d955aeb13b148a846a26144e433ff0480c981af80e2390b1 SHA512 68f4dc0e299b929f244818d93a9af14f48ef2c3a93813fe5457c11d37ddb5a5e2b5ae3f93f0d41e8095590f87d8679d2cee5b6298c128475a9ad9eb6aa3c8bae WHIRLPOOL c82ff5051ac3c1ac2480b846f77893f39f52517f0aa0f7a6084e8b24e98f490264a6adecd89671d89719da835ca84f0613019e281280380bb20d980c2294afe9
diff --git a/www-client/epiphany/epiphany-3.14.2.ebuild b/www-client/epiphany/epiphany-3.14.2.ebuild
new file mode 100644
index 000000000000..154e4c3c6933
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.14.2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 pax-utils versionator virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+# TODO: coverage
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+jit +nss test"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.5.5
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-2.5.90:4[jit?]
+ >=net-libs/libsoup-2.48:2.4
+ >=x11-libs/gtk+-3.13:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+
+ x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
+
+ nss? ( dev-libs/nss )
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${COMMON_DEPEND}
+ >=gnome-base/gnome-common-3.6
+ >=dev-util/intltool-0.50
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix missing symbol in webextension.so, bug #728972
+ epatch "${FILESDIR}"/${PN}-3.14.0-missing-symbol.patch
+
+ # Fix unittests
+ epatch "${FILESDIR}"/${PN}-3.14.0-unittest-*.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable nss) \
+ $(use_enable test tests) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # needed to avoid "Command line `dbus-launch ...' exited with non-zero exit status 1"
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DISPLAY
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+ gnome2_src_install
+ use jit && pax-mark m "${ED}usr/bin/epiphany"
+}
diff --git a/www-client/epiphany/epiphany-3.16.2.ebuild b/www-client/epiphany/epiphany-3.16.2.ebuild
new file mode 100644
index 000000000000..eee9b2f4b35e
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.16.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+#inherit autotools eutils gnome2 pax-utils versionator virtualx
+inherit eutils gnome2 pax-utils versionator virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+# TODO: coverage
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+jit +nss test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.5.5
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.38:2[dbus]
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-2.7.4:4[jit?]
+ >=net-libs/libsoup-2.48:2.4
+ >=x11-libs/gtk+-3.13:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+
+ x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
+
+ nss? ( dev-libs/nss )
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${COMMON_DEPEND}
+ >=gnome-base/gnome-common-3.6
+ >=dev-util/intltool-0.50
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix missing symbol in webextension.so, https://bugzilla.gnome.org/show_bug.cgi?id=728972
+ # FIXME: More information needed per https://bugzilla.gnome.org/show_bug.cgi?id=728972#c5
+ # If you are able to reproduce the failure, please provide it. Thanks
+# epatch "${FILESDIR}"/${PN}-3.14.0-missing-symbol.patch
+
+ # Fix unittests
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751591
+ epatch "${FILESDIR}"/${PN}-3.16.0-unittest-1.patch
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751593
+ epatch "${FILESDIR}"/${PN}-3.14.0-unittest-2.patch
+
+# eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable nss) \
+ $(use_enable test tests)
+}
+
+src_compile() {
+ # needed to avoid "Command line `dbus-launch ...' exited with non-zero exit status 1"
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DISPLAY
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+ gnome2_src_install
+ use jit && pax-mark m "${ED}usr/bin/epiphany"
+}
diff --git a/www-client/epiphany/epiphany-3.16.3.ebuild b/www-client/epiphany/epiphany-3.16.3.ebuild
new file mode 100644
index 000000000000..e24049c10606
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.16.3.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 pax-utils versionator virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+# TODO: coverage
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+jit +nss test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.5.5
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.38:2[dbus]
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-2.7.4:4[jit?]
+ >=net-libs/libsoup-2.48:2.4
+ >=x11-libs/gtk+-3.13:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+
+ x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
+
+ nss? ( dev-libs/nss )
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${COMMON_DEPEND}
+ >=gnome-base/gnome-common-3.6
+ >=dev-util/intltool-0.50
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix unittests
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751591
+ epatch "${FILESDIR}"/${PN}-3.16.0-unittest-1.patch
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751593
+ epatch "${FILESDIR}"/${PN}-3.14.0-unittest-2.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable nss) \
+ $(use_enable test tests)
+}
+
+src_compile() {
+ # needed to avoid "Command line `dbus-launch ...' exited with non-zero exit status 1"
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DISPLAY
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+ gnome2_src_install
+ use jit && pax-mark m "${ED}usr/bin/epiphany"
+}
diff --git a/www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch b/www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch
new file mode 100644
index 000000000000..6f2d8350ec23
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch
@@ -0,0 +1,39 @@
+From 267ec3e2d7ca0f1881cb76d702ac673727f7507a Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Tue, 22 Apr 2014 21:15:42 +0200
+Subject: [PATCH] Add missing files to webextension library
+
+Otherwise, results in:
+
+avril 22 21:09:36 kanae epiphany.desktop[32013]: Error loading module
+'/usr/lib64/epiphany/3.12/web-extensions/libephywebextension.so':
+/usr/lib64/epiphany/3.12/web-extensions/libephywebextension.so:
+undefined symbol: ephy_profile_utils_set_migration_version
+---
+ embed/web-extension/Makefile.am | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/embed/web-extension/Makefile.am b/embed/web-extension/Makefile.am
+index 5bdb174..be4b08f 100644
+--- a/embed/web-extension/Makefile.am
++++ b/embed/web-extension/Makefile.am
+@@ -22,6 +22,8 @@ libephywebextension_la_SOURCES = \
+ $(top_srcdir)/lib/ephy-file-helpers.h \
+ $(top_srcdir)/lib/ephy-form-auth-data.c \
+ $(top_srcdir)/lib/ephy-form-auth-data.h \
++ $(top_srcdir)/lib/ephy-profile-utils.c \
++ $(top_srcdir)/lib/ephy-profile-utils.h \
+ $(top_srcdir)/lib/ephy-settings.c \
+ $(top_srcdir)/lib/ephy-settings.h \
+ $(top_srcdir)/lib/ephy-string.c \
+@@ -39,6 +41,7 @@ libephywebextension_la_CPPFLAGS = \
+ libephywebextension_la_CFLAGS = \
+ -DSHARE_DIR=\"$(pkgdatadir)\" \
+ -DTOP_SRC_DATADIR=\"$(top_srcdir)/data\" \
++ -DABS_TOP_BUILD_DIR=\"$(abs_top_builddir)\" \
+ $(WEB_EXTENSION_CFLAGS)
+
+ libephywebextension_la_LIBADD = \
+--
+1.9.0
+
diff --git a/www-client/epiphany/files/epiphany-3.14.0-missing-symbol.patch b/www-client/epiphany/files/epiphany-3.14.0-missing-symbol.patch
new file mode 100644
index 000000000000..ede1a5d8407a
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-3.14.0-missing-symbol.patch
@@ -0,0 +1,39 @@
+From 46540674cec3fe63f1d560591720f946770159da Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Tue, 22 Apr 2014 21:15:42 +0200
+Subject: [PATCH 1/3] Add missing files to webextension library
+
+Otherwise, results in:
+
+avril 22 21:09:36 kanae epiphany.desktop[32013]: Error loading module
+'/usr/lib64/epiphany/3.12/web-extensions/libephywebextension.so':
+/usr/lib64/epiphany/3.12/web-extensions/libephywebextension.so:
+undefined symbol: ephy_profile_utils_set_migration_version
+---
+ embed/web-extension/Makefile.am | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/embed/web-extension/Makefile.am b/embed/web-extension/Makefile.am
+index 86b48b7..a755c89 100644
+--- a/embed/web-extension/Makefile.am
++++ b/embed/web-extension/Makefile.am
+@@ -22,6 +22,8 @@ libephywebextension_la_SOURCES = \
+ $(top_srcdir)/lib/ephy-file-helpers.h \
+ $(top_srcdir)/lib/ephy-form-auth-data.c \
+ $(top_srcdir)/lib/ephy-form-auth-data.h \
++ $(top_srcdir)/lib/ephy-profile-utils.c \
++ $(top_srcdir)/lib/ephy-profile-utils.h \
+ $(top_srcdir)/lib/ephy-settings.c \
+ $(top_srcdir)/lib/ephy-settings.h \
+ $(top_srcdir)/lib/ephy-string.c \
+@@ -39,6 +41,7 @@ libephywebextension_la_CPPFLAGS = \
+ libephywebextension_la_CFLAGS = \
+ -DSHARE_DIR=\"$(pkgdatadir)\" \
+ -DTOP_SRC_DATADIR=\"$(top_srcdir)/data\" \
++ -DABS_TOP_BUILD_DIR=\"$(abs_top_builddir)\" \
+ $(AM_CFLAGS) \
+ $(WEB_EXTENSION_CFLAGS)
+
+--
+2.1.2
+
diff --git a/www-client/epiphany/files/epiphany-3.14.0-unittest-1.patch b/www-client/epiphany/files/epiphany-3.14.0-unittest-1.patch
new file mode 100644
index 000000000000..3b948a5ae686
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-3.14.0-unittest-1.patch
@@ -0,0 +1,30 @@
+From ddf0dea8e4eb5fe263ddc85d661ce58e55dd554f Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 19 Oct 2014 23:03:02 +0200
+Subject: [PATCH 2/3] Gentoo tests run in ${PORTAGE_TMPDIR} which is not
+ guaranteed to be /tmp
+
+---
+ tests/ephy-file-helpers-test.c | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/tests/ephy-file-helpers-test.c b/tests/ephy-file-helpers-test.c
+index c33c1da..bdf7455 100644
+--- a/tests/ephy-file-helpers-test.c
++++ b/tests/ephy-file-helpers-test.c
+@@ -92,12 +92,7 @@ test_ephy_file_helpers_init (void)
+ GFile *file;
+
+ file = g_file_new_for_path (tmp_dir);
+- /* As a safety measure, only try recursive delete on paths
+- * prefixed with /tmp. */
+- if (g_str_has_prefix (tmp_dir, "/tmp"))
+ g_assert (ephy_file_delete_dir_recursively (file, NULL));
+- else
+- g_warning ("INIT: dangerous path returned as tmp_dir: %s", tmp_dir);
+
+ g_object_unref (file);
+ }
+--
+2.1.2
+
diff --git a/www-client/epiphany/files/epiphany-3.14.0-unittest-2.patch b/www-client/epiphany/files/epiphany-3.14.0-unittest-2.patch
new file mode 100644
index 000000000000..36dcb30ce3bd
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-3.14.0-unittest-2.patch
@@ -0,0 +1,45 @@
+From 3d2ca8dfb33f9dd658293d14d6b75983d1d2f57d Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 19 Oct 2014 23:06:29 +0200
+Subject: [PATCH 3/3] Disable broken tests
+
+Not the first time these are failing even though issue was reported
+upstream.
+---
+ tests/ephy-file-helpers-test.c | 4 ++--
+ tests/ephy-migration-test.c | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/tests/ephy-file-helpers-test.c b/tests/ephy-file-helpers-test.c
+index bdf7455..718fa29 100644
+--- a/tests/ephy-file-helpers-test.c
++++ b/tests/ephy-file-helpers-test.c
+@@ -341,8 +341,8 @@ main (int argc, char *argv[])
+ g_test_add_func ("/lib/ephy-file-helpers/get_downloads_dir",
+ test_ephy_file_get_downloads_dir);
+
+- g_test_add_func ("/lib/ephy-file-helpers/create_delete_dir",
+- test_ephy_file_create_delete_dir);
++ /*g_test_add_func ("/lib/ephy-file-helpers/create_delete_dir",
++ test_ephy_file_create_delete_dir);*/
+
+ g_test_add_func ("/lib/ephy-file-helpers/desktop_dir",
+ test_ephy_file_desktop_dir);
+diff --git a/tests/ephy-migration-test.c b/tests/ephy-migration-test.c
+index fab9ee7..64cdd65 100644
+--- a/tests/ephy-migration-test.c
++++ b/tests/ephy-migration-test.c
+@@ -65,8 +65,8 @@ main (int argc, char *argv[])
+
+ g_test_add_func ("/lib/ephy-profile-utils/do_migration_simple",
+ test_do_migration_simple);
+- g_test_add_func ("/lib/ephy-profile-utils/do_migration_invalid",
+- test_do_migration_invalid);
++ /*g_test_add_func ("/lib/ephy-profile-utils/do_migration_invalid",
++ test_do_migration_invalid);*/
+
+ return g_test_run ();
+ }
+--
+2.1.2
+
diff --git a/www-client/epiphany/files/epiphany-3.16.0-unittest-1.patch b/www-client/epiphany/files/epiphany-3.16.0-unittest-1.patch
new file mode 100644
index 000000000000..baa8a421da13
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-3.16.0-unittest-1.patch
@@ -0,0 +1,30 @@
+From 7ed4a68e2106480f0984703f70b7c25734803161 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 10 May 2015 17:35:57 +0200
+Subject: [PATCH 2/3] Gentoo tests run in ${PORTAGE_TMPDIR} which is not
+ guaranteed to be /tmp
+
+---
+ tests/ephy-file-helpers-test.c | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/tests/ephy-file-helpers-test.c b/tests/ephy-file-helpers-test.c
+index 43d0009..0fcb585 100644
+--- a/tests/ephy-file-helpers-test.c
++++ b/tests/ephy-file-helpers-test.c
+@@ -89,12 +89,7 @@ test_ephy_file_helpers_init (void)
+
+ /* Cleanup dir left behind. */
+ if (keep_dir) {
+- /* As a safety measure, only try recursive delete on paths
+- * prefixed with /tmp. */
+- if (g_str_has_prefix (tmp_dir, "/tmp"))
+ g_assert (ephy_file_delete_dir_recursively (tmp_dir, NULL));
+- else
+- g_warning ("INIT: dangerous path returned as tmp_dir: %s", tmp_dir);
+ }
+
+ g_free (tmp_dir);
+--
+2.3.6
+
diff --git a/www-client/epiphany/metadata.xml b/www-client/epiphany/metadata.xml
new file mode 100644
index 000000000000..72b304a074f2
--- /dev/null
+++ b/www-client/epiphany/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="nss">Import passwords from older gecko based <pkg>www-client/epiphany</pkg> keyring.</flag>
+</use>
+</pkgmetadata>