summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-05 22:25:41 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-05 22:26:05 -0400
commit9e5d89cee0418fd895e6602fa6769fe057a9aebb (patch)
tree58fcd59bc002ae36ae4816e96892cf47ebb261a8 /www-client/epiphany
parentnet-libs/glib-networking: Version bump to 2.72.2 (diff)
downloadgentoo-9e5d89cee0418fd895e6602fa6769fe057a9aebb.tar.gz
gentoo-9e5d89cee0418fd895e6602fa6769fe057a9aebb.tar.bz2
gentoo-9e5d89cee0418fd895e6602fa6769fe057a9aebb.zip
www-client/epiphany: Version bump to 42.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-42.4.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 7910243c16d9..b18df57487fa 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
DIST epiphany-42.2.tar.xz 6101892 BLAKE2B 81553836de2518b2aa490c34b238afe7dd71f63e5f9604ff98ada6663ad37d5a0457f5345574b776582c9ad7a728c0d221360af19cebc0157810757c8d09620b SHA512 3b7bcd9225f06caca547e8d822818e7d9b5a178028cd97b17b8e2474fec7337c4d6b4d718b3cf014784939d0b2f36e84305d6e9115521fdf762af178e5fc07d3
DIST epiphany-42.3.tar.xz 6106824 BLAKE2B 97dc47e0df026210c8c81966ae02a2916d6a738b291261894b3c3bc9a21073e547de1dab00a64e378fb049eec6fbbb15346eb7489f6100f79ab2a4e3309f3366 SHA512 3bdbbbf97e80fcd55780312b9ee5c631e0a9ce8cfb27c4cb202cc5db56579d4aeb098781c4853464f9c22faacdaf75a960b10d8b878139ad24c42728529a4364
+DIST epiphany-42.4.tar.xz 6107820 BLAKE2B 7ab18ac6d8eceb3577ef53c761e26a64291219311f2d6d82ed13ce6746767b83124faf28c9627056938351a05e5d6aff50eb95eb4dec10ce8847123fb5775b36 SHA512 55153078bc460cc5a0bc17bb8d12fd5ed6495cd2415e128ec0b4917b07a4d2fe1fb74e871c033aaef43c89c125d79ad37e99ea2fa2ada07fbcdf09603129ae47
diff --git a/www-client/epiphany/epiphany-42.4.ebuild b/www-client/epiphany/epiphany-42.4.ebuild
new file mode 100644
index 000000000000..2fd204d2c550
--- /dev/null
+++ b/www-client/epiphany/epiphany-42.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web https://gitlab.gnome.org/GNOME/epiphany"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.67.4:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.33.2:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=dev-libs/libdazzle-3.37.1
+ >=gui-libs/libhandy-1.5.0:1=
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-db/sqlite-3.22:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Dlibportal=disabled
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ -Dsoup2=enabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}