summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2016-11-09 11:10:02 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-11 13:46:21 +0100
commitec8ceb021ba71666cbd09767615782fc9562d372 (patch)
treee80bab65ebfd11f4d91313e9ef7c8916eef2baa9 /www-client/epiphany
parentnet-libs/webkit-gtk: add webkit-gtk-2.14.2.ebuild (diff)
downloadgentoo-ec8ceb021ba71666cbd09767615782fc9562d372.tar.gz
gentoo-ec8ceb021ba71666cbd09767615782fc9562d372.tar.bz2
gentoo-ec8ceb021ba71666cbd09767615782fc9562d372.zip
www-client/epiphany: add epiphany-3.22.2.ebuild
Bump from 3.22.1, upstepping the dependency on webkit-gtk as per https://git.gnome.org/browse/epiphany/diff/?id=3.22.2&&id2=3.22.1 https://git.gnome.org/browse/epiphany/diff/configure.ac?id=3.22.2&id2=3.22.1 Closes: https://github.com/gentoo/gentoo/pull/2788 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.22.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 6df420c4a6b4..332fc9623f1d 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
DIST epiphany-3.20.3.tar.xz 2182864 SHA256 4d9de1bdb44c14adf25aa6dc02ea3de60925cff5eb01fe89545e6032c9b424a2 SHA512 853a8efd67374f5550263cf4f102ac680b6b5bf1e948d5bb4448bc3dbe89401034709e391e527bce50a8f210cf2ae525d7f5c8e997fd665946986c5078caf3a9 WHIRLPOOL a7736abe4e121b15f27dc5ca32a7d9f6a26e2526523d605d8394d179e362b99c99067f7a2bc6f36004b9424e0fe295b2f6bb7a294b7dfbcceb7bb0ce3a80420c
DIST epiphany-3.22.1.tar.xz 2285912 SHA256 aab162ede54d71e583e382ab5e3567f28d81e0cd42719a11cad8008b56c5cc0e SHA512 a624196bbe0ec75b441c43a88b83ed7129f69e9e54744aad225d66c53a2cc3b197fbdabf34ee82177d4c55dfb23c0cb7e3862a2e1d368eb2027e0bc85a9a4573 WHIRLPOOL ef9a20d150232bae0e07e009b861fd5b3dc783a4f2cf8425fbeff3c2c9c7c3b2a679a2f8dd908b4208e144cf1a905a590de52c0edd5c582e3168990f2b754f30
+DIST epiphany-3.22.2.tar.xz 2288276 SHA256 89a3603c5006e67e69496724ae1ed76c492eaae80ca3ba623a35eee799a28651 SHA512 e753759f0ca29ce9330b1b64699516865f28eff4786cc6a245c8746b227354fcb25f9dd27cb1be5d187397407c930cbab562f3c008803b3e11866662f0be00c8 WHIRLPOOL 3fe4000f192fb5cbfaef575a354f66669721317c6dcc9a80a2d0b92959f8b003902fb02d61c1c808be80021a64a35a95fe90dbdff824e68540a1e4380e6c13c8
diff --git a/www-client/epiphany/epiphany-3.22.2.ebuild b/www-client/epiphany/epiphany-3.22.2.ebuild
new file mode 100644
index 000000000000..62c11216648a
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.22.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.5.5:=
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.44.0:2[dbus]
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-2.14.2:4=
+ >=net-libs/libsoup-2.48:2.4
+ >=x11-libs/gtk+-3.19.1:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libX11
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/adwaita-icon-theme
+ !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751591
+ "${FILESDIR}"/${PN}-3.16.0-unittest-1.patch
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751593
+ "${FILESDIR}"/${PN}-3.14.0-unittest-2.patch
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable test tests)
+}
+
+src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+ GSETTINGS_SCHEMA_DIR="${S}/data" virtx emake check
+}