summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-11-04 15:46:32 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-11-04 15:53:51 +0100
commit09821ae9942800256678a8b4335e907b5484b0b9 (patch)
treeb5af3e96b1d8fa6663da4a0d1fd1841c7d21591c /www-client/firefox-bin
parentprofiles/package.mask: ant-nodeps and ant-trax are still used (diff)
downloadgentoo-09821ae9942800256678a8b4335e907b5484b0b9.tar.gz
gentoo-09821ae9942800256678a8b4335e907b5484b0b9.tar.bz2
gentoo-09821ae9942800256678a8b4335e907b5484b0b9.zip
www-client/firefox-bin: disable auto-update using policies.json
Closes: https://bugs.gentoo.org/670196 Package-Manager: Portage-2.3.51, Repoman-2.3.11 RepoMan-Options: --force Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client/firefox-bin')
-rw-r--r--www-client/firefox-bin/files/all-gentoo-1.js2
-rw-r--r--www-client/firefox-bin/files/disable-auto-update.policy.json5
-rw-r--r--www-client/firefox-bin/firefox-bin-60.3.0-r1.ebuild (renamed from www-client/firefox-bin/firefox-bin-60.3.0.ebuild)4
-rw-r--r--www-client/firefox-bin/firefox-bin-63.0.1-r1.ebuild (renamed from www-client/firefox-bin/firefox-bin-63.0.1.ebuild)4
4 files changed, 14 insertions, 1 deletions
diff --git a/www-client/firefox-bin/files/all-gentoo-1.js b/www-client/firefox-bin/files/all-gentoo-1.js
index 0ac6d6a49886..a5e93b179d06 100644
--- a/www-client/firefox-bin/files/all-gentoo-1.js
+++ b/www-client/firefox-bin/files/all-gentoo-1.js
@@ -1,4 +1,4 @@
-// Ensure preference cann't be changed by users
+// Ensure preference can't be changed by users
lockPref("app.update.auto", false);
lockPref("app.update.enabled", false);
lockPref("intl.locale.matchOS", true);
diff --git a/www-client/firefox-bin/files/disable-auto-update.policy.json b/www-client/firefox-bin/files/disable-auto-update.policy.json
new file mode 100644
index 000000000000..f36622021fcd
--- /dev/null
+++ b/www-client/firefox-bin/files/disable-auto-update.policy.json
@@ -0,0 +1,5 @@
+{
+ "policies": {
+ "DisableAppUpdate": true
+ }
+}
diff --git a/www-client/firefox-bin/firefox-bin-60.3.0.ebuild b/www-client/firefox-bin/firefox-bin-60.3.0-r1.ebuild
index af452de7b79d..371ab74243bd 100644
--- a/www-client/firefox-bin/firefox-bin-60.3.0.ebuild
+++ b/www-client/firefox-bin/firefox-bin-60.3.0-r1.ebuild
@@ -115,6 +115,10 @@ src_install() {
dodir ${MOZILLA_FIVE_HOME%/*}
mv "${S}" "${ED}"${MOZILLA_FIVE_HOME} || die
+ # Disable built-in auto-update because we update firefox-bin through package manager
+ insinto ${MOZILLA_FIVE_HOME}/distribution/
+ newins "${FILESDIR}"/disable-auto-update.policy.json policies.json
+
# Fix prefs that make no sense for a system-wide install
insinto ${MOZILLA_FIVE_HOME}/defaults/pref/
doins "${FILESDIR}"/local-settings.js
diff --git a/www-client/firefox-bin/firefox-bin-63.0.1.ebuild b/www-client/firefox-bin/firefox-bin-63.0.1-r1.ebuild
index 39a6591abfd6..af7d272f28a5 100644
--- a/www-client/firefox-bin/firefox-bin-63.0.1.ebuild
+++ b/www-client/firefox-bin/firefox-bin-63.0.1-r1.ebuild
@@ -115,6 +115,10 @@ src_install() {
dodir ${MOZILLA_FIVE_HOME%/*}
mv "${S}" "${ED}"${MOZILLA_FIVE_HOME} || die
+ # Disable built-in auto-update because we update firefox-bin through package manager
+ insinto ${MOZILLA_FIVE_HOME}/distribution/
+ newins "${FILESDIR}"/disable-auto-update.policy.json policies.json
+
# Fix prefs that make no sense for a system-wide install
insinto ${MOZILLA_FIVE_HOME}/defaults/pref/
doins "${FILESDIR}"/local-settings.js