summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-04-29 12:45:58 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-04-29 12:48:06 -0400
commit19e2bb19b7e61a15fcf2b840ac5e7520cc282fc3 (patch)
treec2b56c8018efd8958d5db86682349e2e76f19485 /www-client/firefox
parentwww-client/firefox: fix musl build error, bug 616990 (diff)
downloadgentoo-19e2bb19b7e61a15fcf2b840ac5e7520cc282fc3.tar.gz
gentoo-19e2bb19b7e61a15fcf2b840ac5e7520cc282fc3.tar.bz2
gentoo-19e2bb19b7e61a15fcf2b840ac5e7520cc282fc3.zip
www-client/firefox: improve and unify apulse support
Create relative symlinks to a defined set of apulse libs instead of iterating over what libraries are installed on disk and using absolute symlinks. Also sync the code between 52.1 and 53.0 ebuilds Bug: http://bugs.gentoo.org/613980 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/firefox-52.1.0-r1.ebuild (renamed from www-client/firefox/firefox-52.1.0.ebuild)12
-rw-r--r--www-client/firefox/firefox-53.0.ebuild8
2 files changed, 13 insertions, 7 deletions
diff --git a/www-client/firefox/firefox-52.1.0.ebuild b/www-client/firefox/firefox-52.1.0-r1.ebuild
index e86292997622..91b2a431871e 100644
--- a/www-client/firefox/firefox-52.1.0.ebuild
+++ b/www-client/firefox/firefox-52.1.0-r1.ebuild
@@ -366,15 +366,15 @@ pkg_preinst() {
# if the apulse libs are available in MOZILLA_FIVE_HOME then apulse
# doesn't need to be forced into the LD_LIBRARY_PATH
- if use pulseaudio && [ -d "${EROOT}"usr/$(get_libdir)/apulse ] ; then
+ if use pulseaudio && has_version ">=media-sound/apulse-0.1.9" ; then
einfo "APULSE found - Generating library symlinks for sound support"
local lib
pushd "${ED}"${MOZILLA_FIVE_HOME} &>/dev/null || die
- for lib in "${EROOT}"usr/$(get_libdir)/apulse/libpulse* ; do
+ for lib in ../apulse/libpulse{.so{,.0},-simple.so{,.0}} ; do
# a quickpkg rolled by hand will grab symlinks as part of the package,
# so we need to avoid creating them if they already exist.
if ! [ -L ${lib##*/} ]; then
- ln -s "${lib}" || die
+ ln -s "${lib}" ${lib##*/} || die
fi
done
popd &>/dev/null || die
@@ -392,6 +392,12 @@ pkg_postinst() {
local plugin
for plugin in "${GMP_PLUGIN_LIST[@]}"; do elog "\t ${plugin}" ; done
fi
+
+ if use pulseaudio && has_version ">=media-sound/apulse-0.1.9" ; then
+ elog "Apulse was detected at merge time on this system and so it will always be"
+ elog "used for sound. If you wish to use pulseaudio instead please unmerge"
+ elog "media-sound/apulse."
+ fi
}
pkg_postrm() {
diff --git a/www-client/firefox/firefox-53.0.ebuild b/www-client/firefox/firefox-53.0.ebuild
index 16e714db9070..a911896f0de7 100644
--- a/www-client/firefox/firefox-53.0.ebuild
+++ b/www-client/firefox/firefox-53.0.ebuild
@@ -371,15 +371,15 @@ pkg_preinst() {
# if the apulse libs are available in MOZILLA_FIVE_HOME then apulse
# doesn't need to be forced into the LD_LIBRARY_PATH
- if use pulseaudio && [ -d "${EPREFIX}"/usr/$(get_libdir)/apulse ] ; then
+ if use pulseaudio && has_version ">=media-sound/apulse-0.1.9" ; then
einfo "APULSE found - Generating library symlinks for sound support"
local lib
pushd "${ED}"${MOZILLA_FIVE_HOME} &>/dev/null || die
- for lib in "${EPREFIX}"/usr/$(get_libdir)/apulse/libpulse* ; do
+ for lib in ../apulse/libpulse{.so{,.0},-simple.so{,.0}} ; do
# a quickpkg rolled by hand will grab symlinks as part of the package,
# so we need to avoid creating them if they already exist.
if ! [ -L ${lib##*/} ]; then
- ln -s "${lib}" || die
+ ln -s "${lib}" ${lib##*/} || die
fi
done
popd &>/dev/null || die
@@ -398,7 +398,7 @@ pkg_postinst() {
for plugin in "${GMP_PLUGIN_LIST[@]}"; do elog "\t ${plugin}" ; done
fi
- if use pulseaudio && [ -d "${EPREFIX}"/usr/$(get_libdir)/apulse ]; then
+ if use pulseaudio && has_version ">=media-sound/apulse-0.1.9"; then
elog "Apulse was detected at merge time on this system and so it will always be"
elog "used for sound. If you wish to use pulseaudio instead please unmerge"
elog "media-sound/apulse."