summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2016-04-29 14:16:40 -0400
committerIan Stakenvicius <axs@gentoo.org>2016-04-29 14:17:06 -0400
commit255b60802fb702c065999429fd3915751a3f056c (patch)
tree22fa1fbbdf700cf6e5bc63995e331375dba21829 /www-client/firefox
parentdev-qt/qt-creator: allow newer versions of clang (diff)
downloadgentoo-255b60802fb702c065999429fd3915751a3f056c.tar.gz
gentoo-255b60802fb702c065999429fd3915751a3f056c.tar.bz2
gentoo-255b60802fb702c065999429fd3915751a3f056c.zip
www-client/firefox-{45.1.0,46.0}: patch to fix branch64 calls missing from none-jit
Bug: http://bugs.gentoo.org/581474 Package-Manager: portage-2.2.26
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/files/jit-none-branch64.patch29
-rw-r--r--www-client/firefox/firefox-45.1.0.ebuild3
-rw-r--r--www-client/firefox/firefox-46.0.ebuild3
3 files changed, 33 insertions, 2 deletions
diff --git a/www-client/firefox/files/jit-none-branch64.patch b/www-client/firefox/files/jit-none-branch64.patch
new file mode 100644
index 000000000000..590f745d14d4
--- /dev/null
+++ b/www-client/firefox/files/jit-none-branch64.patch
@@ -0,0 +1,29 @@
+# HG changeset patch
+# User Nicolas B. Pierron <nicolas.b.pierron@mozilla.com>
+
+Bug 1266366 - Add branch64 functions to the none-backend MacroAssembler. r=
+
+diff --git a/js/src/jit/none/MacroAssembler-none.h b/js/src/jit/none/MacroAssembler-none.h
+index 512ae81..4441d8d 100644
+--- a/js/src/jit/none/MacroAssembler-none.h
++++ b/js/src/jit/none/MacroAssembler-none.h
+@@ -254,16 +254,18 @@ class MacroAssemblerNone : public Assembler
+ template <typename T, typename S> void branchSub32(Condition, T, S, Label*) { MOZ_CRASH(); }
+ template <typename T, typename S> void branchPtr(Condition, T, S, Label*) { MOZ_CRASH(); }
+ template <typename T, typename S> void branchTestPtr(Condition, T, S, Label*) { MOZ_CRASH(); }
+ template <typename T, typename S> void branchDouble(DoubleCondition, T, S, Label*) { MOZ_CRASH(); }
+ template <typename T, typename S> void branchFloat(DoubleCondition, T, S, Label*) { MOZ_CRASH(); }
+ template <typename T, typename S> void branchPrivatePtr(Condition, T, S, Label*) { MOZ_CRASH(); }
+ template <typename T, typename S> void decBranchPtr(Condition, T, S, Label*) { MOZ_CRASH(); }
+ template <typename T, typename S> void branchTest64(Condition, T, T, S, Label*) { MOZ_CRASH(); }
++ template <typename T, typename S> void branch64(Condition, T, S, Label*) { MOZ_CRASH(); }
++ template <typename T, typename S> void branch64(Condition, T, T, S, Label*) { MOZ_CRASH(); }
+ template <typename T, typename S> void mov(T, S) { MOZ_CRASH(); }
+ template <typename T, typename S> void movq(T, S) { MOZ_CRASH(); }
+ template <typename T, typename S> void movePtr(T, S) { MOZ_CRASH(); }
+ template <typename T, typename S> void move32(T, S) { MOZ_CRASH(); }
+ template <typename T, typename S> void moveFloat32(T, S) { MOZ_CRASH(); }
+ template <typename T, typename S> void moveDouble(T, S) { MOZ_CRASH(); }
+ template <typename T, typename S> void move64(T, S) { MOZ_CRASH(); }
+ template <typename T> CodeOffset movWithPatch(T, Register) { MOZ_CRASH(); }
+
diff --git a/www-client/firefox/firefox-45.1.0.ebuild b/www-client/firefox/firefox-45.1.0.ebuild
index 67e1b8b47706..832e18beb90d 100644
--- a/www-client/firefox/firefox-45.1.0.ebuild
+++ b/www-client/firefox/firefox-45.1.0.ebuild
@@ -132,7 +132,8 @@ src_prepare() {
# Apply our patches
eapply "${WORKDIR}/firefox" \
"${FILESDIR}"/arm64-4-link-chromium-mutex-based-atomics.patch \
- "${FILESDIR}"/arm64-5-mozjemalloc-no-static-page-sizes.patch
+ "${FILESDIR}"/arm64-5-mozjemalloc-no-static-page-sizes.patch \
+ "${FILESDIR}"/jit-none-branch64.patch
# Allow user to apply any additional patches without modifing ebuild
eapply_user
diff --git a/www-client/firefox/firefox-46.0.ebuild b/www-client/firefox/firefox-46.0.ebuild
index 3dd0989d0dd9..80407c0de119 100644
--- a/www-client/firefox/firefox-46.0.ebuild
+++ b/www-client/firefox/firefox-46.0.ebuild
@@ -116,7 +116,8 @@ src_unpack() {
src_prepare() {
# Apply our patches
- eapply "${WORKDIR}/firefox"
+ eapply "${WORKDIR}/firefox" \
+ "${FILESDIR}"/jit-none-branch64.patch
# Enable gnomebreakpad
if use debug ; then