summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-05-14 20:58:10 +0200
committerSebastian Pipping <sping@gentoo.org>2017-05-14 21:43:33 +0200
commit9a8e7d8a7acef690f861b084f0f4629924d79780 (patch)
tree222e17fc62165dbe2a3cecbe61127bca82884df3 /www-client/httrack/httrack-3.49.1.ebuild
parentmedia-radio/unixcw: Fix wrong usage of PKG_CHECK_MODULES in patch (bug #61675... (diff)
downloadgentoo-9a8e7d8a7acef690f861b084f0f4629924d79780.tar.gz
gentoo-9a8e7d8a7acef690f861b084f0f4629924d79780.tar.bz2
gentoo-9a8e7d8a7acef690f861b084f0f4629924d79780.zip
www-client/httrack: 3.49.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'www-client/httrack/httrack-3.49.1.ebuild')
-rw-r--r--www-client/httrack/httrack-3.49.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/www-client/httrack/httrack-3.49.1.ebuild b/www-client/httrack/httrack-3.49.1.ebuild
new file mode 100644
index 000000000000..4018cd13894d
--- /dev/null
+++ b/www-client/httrack/httrack-3.49.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils
+
+DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
+HOMEPAGE="http://www.httrack.com/"
+SRC_URI="http://mirror.httrack.com/historical/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="libressl static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.5.1-r1
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( dev-libs/libressl )
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README greetings.txt history.txt )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.48.13-minizip.patch
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ # Make webhttrack work despite FEATURES=nodoc cutting
+ # all of /usr/share/doc/ away (bug #493376)
+ if has nodoc ${FEATURES} ; then
+ dodir /usr/share/${PF}/
+ mv "${D}"/usr/share/{doc/,}${PF}/html || die
+
+ rm "${D}"/usr/share/${PN}/html || die
+ dosym /usr/share/${PF}/html /usr/share/${PN}/html
+ fi
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}