summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-08-06 21:58:40 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-08-06 21:58:40 +0900
commit17f03420def497770746b04abaa7a191ea464194 (patch)
tree13ec8498fe04d23d90e5f11263292116860a1d2b /www-client/jd
parentwww-client/jd: add oniguruma USE flag (diff)
downloadgentoo-17f03420def497770746b04abaa7a191ea464194.tar.gz
gentoo-17f03420def497770746b04abaa7a191ea464194.tar.bz2
gentoo-17f03420def497770746b04abaa7a191ea464194.zip
www-client/jd: new upstream release
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-client/jd')
-rw-r--r--www-client/jd/Manifest1
-rw-r--r--www-client/jd/jd-2.8.9_p150226.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/www-client/jd/Manifest b/www-client/jd/Manifest
index de82228d91b8..e5dc862b2f34 100644
--- a/www-client/jd/Manifest
+++ b/www-client/jd/Manifest
@@ -1 +1,2 @@
DIST jd-2.8.5-120826.tgz 784657 BLAKE2B 07e3ef150ddbc58cdd5d4e7bddfeb5f4cb5dd9b0c6bfc9fda4309768e34b7f4534549dad919c18ed8c5918d519e672ea4d3728d8bc87280096764d87a74151cb SHA512 0c4aa0845aca71f1172a565d7b9e4a7099fa27c221b452c623b818144b958c8b042e5ab00582eee07bc8d44186a172c9abb750550ae3293851e03382e527e11b
+DIST jd-2.8.9-150226.tgz 770110 BLAKE2B 096469fdc343dab64485897c5a402a48093ab1cc49e30973ab2f969fd60c389b1987c90246cf897125ab0d1787960574b35b811feacbc68e8079a00366c74602 SHA512 39bb4f0242426a5eff40e2a8c4bfc703491d260d4764be3745581b77a39d6db553521f2e09ea36c15d0318847a6fea8f48e079504f1f575fb600cb196c94df70
diff --git a/www-client/jd/jd-2.8.9_p150226.ebuild b/www-client/jd/jd-2.8.9_p150226.ebuild
new file mode 100644
index 000000000000..f195e5ab810e
--- /dev/null
+++ b/www-client/jd/jd-2.8.9_p150226.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils autotools flag-o-matic
+
+MY_P="${P/_p/-}"
+
+DESCRIPTION="gtk2 based 2ch browser written in C++"
+HOMEPAGE="http://jd4linux.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}4linux/62877/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa gnutls migemo oniguruma"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ dev-libs/glib:2
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-misc/xdg-utils
+ alsa? ( >=media-libs/alsa-lib-1 )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl:0 )
+ migemo? ( app-text/cmigemo )
+ oniguruma? ( dev-libs/oniguruma )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${PN}-gcc-5.patch )
+
+src_prepare() {
+ default
+ append-cxxflags -std=c++11
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with alsa) \
+ $(use_with !gnutls openssl) \
+ $(use_with migemo) \
+ $(use_with migemo migemodict "${EREPFIX}"/usr/share/migemo/migemo-dict) \
+ $(use_with oniguruma) \
+ --with-sessionlib=xsmp \
+ --with-xdgopen
+}
+
+src_install() {
+ default
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+}