summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/luakit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/luakit')
-rw-r--r--www-client/luakit/Manifest1
-rw-r--r--www-client/luakit/files/luakit-2010.12.25-fix-deprecated.patch25
-rw-r--r--www-client/luakit/luakit-2012.09.13_p1-r1.ebuild83
-rw-r--r--www-client/luakit/luakit-9999.ebuild87
-rw-r--r--www-client/luakit/metadata.xml16
5 files changed, 212 insertions, 0 deletions
diff --git a/www-client/luakit/Manifest b/www-client/luakit/Manifest
new file mode 100644
index 000000000000..68c612757191
--- /dev/null
+++ b/www-client/luakit/Manifest
@@ -0,0 +1 @@
+DIST luakit-2012.09.13_p1.tar.gz 215431 SHA256 688950fda11f032976998b52ba6505fc1bf5bba40552293f9ddc748b00f76132 SHA512 429f2911e6c0e28966579721925d3f9bf492461b3f43cecb07df5f2a7ee5e791d30885c50039da6849ec8d16e8b042286482966c036089e87c568fb394aade09 WHIRLPOOL de90607402cc13eab7a84a3f9f75edaca976f444aabccd1391f7c7f20fe0211d78d8d4c3d3685bcabb84622556617411c9778eaf6abb23ca826992c4914f0064
diff --git a/www-client/luakit/files/luakit-2010.12.25-fix-deprecated.patch b/www-client/luakit/files/luakit-2010.12.25-fix-deprecated.patch
new file mode 100644
index 000000000000..71eba8942bfc
--- /dev/null
+++ b/www-client/luakit/files/luakit-2010.12.25-fix-deprecated.patch
@@ -0,0 +1,25 @@
+Change handling of "argument table" in `lousy/util.lua` from
+deprecated (Lua 5.0) to modern (5.1 and up) syntax.
+
+written by Stjujsckij Nickolaj
+
+https://bugs.gentoo.org/show_bug.cgi?id=354355
+https://github.com/mason-larobina/luakit/commit/99b1bb394beff0dd872dd822c930d412b98d00a9
+--- a/lib/lousy/util.lua
++++ b/lib/lousy/util.lua
+@@ -98,9 +98,9 @@ end
+ -- @return A new table containing all keys from the arguments.
+ function table.join(...)
+ local ret = {}
+- for i = 1, arg.n do
+- if arg[i] then
+- for k, v in pairs(arg[i]) do
++ for i, tbl in pairs({...}) do
++ if tbl then
++ for k, v in pairs(tbl) do
+ if type(k) == "number" then
+ rtable.insert(ret, v)
+ else
+--
+1.7.4.rc3
+
diff --git a/www-client/luakit/luakit-2012.09.13_p1-r1.ebuild b/www-client/luakit/luakit-2012.09.13_p1-r1.ebuild
new file mode 100644
index 000000000000..ae17604f88d4
--- /dev/null
+++ b/www-client/luakit/luakit-2012.09.13_p1-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+IUSE="luajit vim-syntax"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mason-larobina/${PN}.git
+ https://github.com/mason-larobina/${PN}.git"
+ EGIT_BRANCH="develop"
+ KEYWORDS=""
+ SRC_URI=""
+else
+ inherit vcs-snapshot
+ MY_PV="${PV/_p/-r}"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/mason-larobina/${PN}/tarball/${MY_PV} -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="fast, small, webkit-gtk based micro-browser extensible by lua"
+HOMEPAGE="http://mason-larobina.github.com/luakit/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+COMMON_DEPEND="
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( >=dev-lang/lua-5.1 )
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libunique:1
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+"
+
+DEPEND="
+ virtual/pkgconfig
+ sys-apps/help2man
+ ${COMMON_DEPEND}
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-lua/luafilesystem
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+
+src_prepare() {
+ sed -i -e "/^CFLAGS/s/-ggdb//" config.mk || die
+}
+
+src_compile() {
+ myconf="PREFIX=/usr DEVELOPMENT_PATHS=0"
+ if use luajit; then
+ myconf+=" USE_LUAJIT=1"
+ else
+ myconf+=" USE_LUAJIT=0"
+ fi
+
+ if [[ ${PV} != *9999* ]]; then
+ myconf+=" VERSION=${PV}"
+ fi
+
+ tc-export CC
+ emake ${myconf}
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" DOCDIR="${D}/usr/share/doc/${PF}" install
+
+ if use vim-syntax; then
+ local t
+ for t in $(ls "${S}"/extras/vim/); do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins "${S}"/extras/vim/"${t}"/luakit.vim
+ done
+ fi
+}
diff --git a/www-client/luakit/luakit-9999.ebuild b/www-client/luakit/luakit-9999.ebuild
new file mode 100644
index 000000000000..fa62202a80bd
--- /dev/null
+++ b/www-client/luakit/luakit-9999.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+IUSE="luajit pax_kernel vim-syntax"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mason-larobina/${PN}.git
+ https://github.com/mason-larobina/${PN}.git"
+ EGIT_BRANCH="develop"
+ KEYWORDS=""
+ SRC_URI=""
+else
+ inherit vcs-snapshot
+ MY_PV="${PV/_p/-r}"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/mason-larobina/${PN}/tarball/${MY_PV} -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="fast, small, webkit-gtk based micro-browser extensible by lua"
+HOMEPAGE="http://mason-larobina.github.com/luakit/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+COMMON_DEPEND="
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( >=dev-lang/lua-5.1 )
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libunique:1
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+"
+
+DEPEND="
+ virtual/pkgconfig
+ sys-apps/help2man
+ pax_kernel? ( sys-apps/elfix )
+ ${COMMON_DEPEND}
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-lua/luafilesystem
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+
+src_prepare() {
+ sed -i -e "/^CFLAGS/s/-ggdb//" config.mk || die
+ # bug 385471
+ use pax_kernel && sed "s,@\$(CC) -o \$@ \$(OBJS) \$(LDFLAGS),@\$(CC) \
+ -o \$@ \$(OBJS) \$(LDFLAGS)\n\tpaxmark.sh -m luakit,g" -i Makefile
+}
+
+src_compile() {
+ myconf="PREFIX=/usr DEVELOPMENT_PATHS=0"
+ if use luajit; then
+ myconf+=" USE_LUAJIT=1"
+ else
+ myconf+=" USE_LUAJIT=0"
+ fi
+
+ if [[ ${PV} != *9999* ]]; then
+ myconf+=" VERSION=${PV}"
+ fi
+
+ tc-export CC
+ emake ${myconf}
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" DOCDIR="${D}/usr/share/doc/${PF}" install
+
+ if use vim-syntax; then
+ local t
+ for t in $(ls "${S}"/extras/vim/); do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins "${S}"/extras/vim/"${t}"/luakit.vim
+ done
+ fi
+}
diff --git a/www-client/luakit/metadata.xml b/www-client/luakit/metadata.xml
new file mode 100644
index 000000000000..9156b89c7a5d
--- /dev/null
+++ b/www-client/luakit/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="luajit">Use the lua just-in-time compiler
+ <pkg>dev-lang/luajit</pkg> instead of <pkg>dev-lang/lua</pkg>, which
+ should make luakit faster.</flag>
+ <flag name="pax_kernel">Use paxctl to mark the luakit binary.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">mason-larobina/luakit</remote-id>
+ </upstream>
+</pkgmetadata>