summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-12-02 17:13:45 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-02 17:15:01 +0100
commit51e1a1112b3bca5bef16f7d23b7f78c1f92c41eb (patch)
treea9e753939731642e3ec2f9945896ef4e0eff3033 /www-client/midori
parentnet-analyzer/nagios-core: remove nagios-core-4.3.3 to fix CVE-2017-14312. (diff)
downloadgentoo-51e1a1112b3bca5bef16f7d23b7f78c1f92c41eb.tar.gz
gentoo-51e1a1112b3bca5bef16f7d23b7f78c1f92c41eb.tar.bz2
gentoo-51e1a1112b3bca5bef16f7d23b7f78c1f92c41eb.zip
www-client/midori: Bump to 7.0
Closes: https://bugs.gentoo.org/670192 Closes: https://bugs.gentoo.org/670270 Closes: https://bugs.gentoo.org/670354 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-client/midori')
-rw-r--r--www-client/midori/Manifest1
-rw-r--r--www-client/midori/midori-7.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/www-client/midori/Manifest b/www-client/midori/Manifest
index 7e27f724eb4f..2ab860caa96d 100644
--- a/www-client/midori/Manifest
+++ b/www-client/midori/Manifest
@@ -1,2 +1,3 @@
DIST midori-v6.0.tar.gz 1823209 BLAKE2B dd00bef8da638d993c9918e991fa4f65d79b9f0d736b865895fae94f7f9d7552d671bda38cff933e65b7017cadfb810b7c180e00ba4e6f26abd471affc4cd903 SHA512 2b3e4808b1297a3ef8436b45ac38782e070658a0ecc62bcf8d0b2cf49f256cdad799ccc5d28df11ff595c042e8474fa2e87065d9a89cdb5a936237c44fdfd9e7
+DIST midori-v7.0.tar.gz 1827341 BLAKE2B e008be32851a3ee12744b7b4e686545a2f9cd84fc6f05a647744c512ea5286fdc1db3b1ec40f546208ffbca4ca8a179752f27b85d9060765a7612ac7c260c67f SHA512 4110d1566ba8b0979c29f1c3a95af3da4cba884f44a1305403d8951f7f2dfb17946c3c7326eebafc111738950c907d06cc6c54ce670cde321da890d8b9ced051
DIST midori_0.5.11_all_.tar.bz2 1428791 BLAKE2B c19872b3271360877b2affa0ab86d93884895037a72cb9182a44a597bf930394153fea5a744c1cf225f2c4bd8f3c691c5622d0b4abdb33c202c4aa1da48b5ee5 SHA512 237310d1f0bf70796474b9ec5be6755927e66acd2b527d04db39696c5e2f7ea2d11f7deb51ba3f5c151a450ab71e642282a1386e34253aaea1d8602ce76ac87d
diff --git a/www-client/midori/midori-7.0.ebuild b/www-client/midori/midori-7.0.ebuild
new file mode 100644
index 000000000000..b3558ed38a06
--- /dev/null
+++ b/www-client/midori/midori-7.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VALA_MIN_API_VERSION=0.36
+
+inherit cmake-utils eapi7-ver gnome2-utils vala xdg-utils
+
+MY_P=${PN}-v${PV}
+DESCRIPTION="A lightweight web browser based on WebKitGTK+"
+HOMEPAGE="http://www.midori-browser.org/"
+SRC_URI="https://github.com/midori-browser/core/releases/download/v$(ver_cut 1)/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/gcr-3:=[gtk,vala]
+ >=dev-db/sqlite-3.6.19:3
+ >=dev-libs/glib-2.48.0:2
+ dev-libs/libpeas[gtk]
+ dev-libs/libxml2
+ >=net-libs/libsoup-2.38:2.4[vala]
+ >=net-libs/webkit-gtk-2.16.6:4[introspection,opengl]
+ >=x11-libs/libnotify-0.7
+ >=x11-libs/gtk+-3.12.0:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ vala_src_prepare
+ sed -i -e '/^install/s:COPYING::' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DVALA_EXECUTABLE="${VALAC}"
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}