summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-11-14 11:44:16 +0100
committerJeroen Roovers <jer@gentoo.org>2019-11-14 11:44:39 +0100
commitbe77831e33f344dd997a871ad4bf6429f30870b7 (patch)
tree8becea9a1c7f64b3d682233741484de0a2b21ace /www-client/opera
parentwww-client/opera-beta: Old (diff)
downloadgentoo-be77831e33f344dd997a871ad4bf6429f30870b7.tar.gz
gentoo-be77831e33f344dd997a871ad4bf6429f30870b7.tar.bz2
gentoo-be77831e33f344dd997a871ad4bf6429f30870b7.zip
www-client/opera: Version 65.0.3467.38
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'www-client/opera')
-rw-r--r--www-client/opera/Manifest1
-rw-r--r--www-client/opera/opera-65.0.3467.38.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/www-client/opera/Manifest b/www-client/opera/Manifest
index 30bdcdfbc624..5da6700febe9 100644
--- a/www-client/opera/Manifest
+++ b/www-client/opera/Manifest
@@ -1 +1,2 @@
DIST opera-stable_64.0.3417.92_amd64.deb 66230620 BLAKE2B 1b4c3ad7956727d9a849e545e4ff95318ebddaf2e87073cefc5c13eb685b56171cb12f9ba698dba32dddd2013897c6584ad080767bbca5693d9971e07ba0e683 SHA512 9a0ff699dc00a3984854db8838158d17a27665d91b98221a31b23fa82f0a3c1259b1ceff83902cc782cf21b4780deb8426a3cb45c88c0a7d3ea3450b15ce4e0f
+DIST opera-stable_65.0.3467.38_amd64.deb 67578426 BLAKE2B 8efa5b7f655b1d2f5d9968e61c6e23fef0ab5ab39a633c3249e93bdafab593293ae206e7b68122d4eb3ffa90b0daac7031d4b8d10ae76106f8618c1bdc9b0f71 SHA512 b46fc9ff5595f0c70fa4d42b7ec5031020a39bc8945cbbecf6890be6faca8b4fa5dba4eab1801597a550806c686690d320ff667ed49e1b8ed64ed6577f6fbec1
diff --git a/www-client/opera/opera-65.0.3467.38.ebuild b/www-client/opera/opera-65.0.3467.38.ebuild
new file mode 100644
index 000000000000..eec568e74cf4
--- /dev/null
+++ b/www-client/opera/opera-65.0.3467.38.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CHROMIUM_LANGS="
+ be bg bn ca cs da de el en-GB en-US es-419 es fil fi fr-CA fr hi hr hu id
+ it ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+ zh-CN zh-TW
+
+"
+inherit chromium-2 multilib unpacker xdg-utils
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2014"
+SLOT="0"
+SRC_URI_BASE="
+ https://download1.operacdn.com/pub/
+ https://download2.operacdn.com/pub/
+ https://download3.operacdn.com/pub/
+ https://download4.operacdn.com/pub/
+"
+for uri in ${SRC_URI_BASE}; do
+SRC_URI+="
+ "${uri}${PN}/desktop/${PV}/linux/${PN}-stable_${PV}_amd64.deb"
+"
+done
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gconf:2
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libnotify
+ x11-libs/pango[X]
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ default
+
+ OPERA_HOME="usr/$(get_libdir)/${PN}"
+
+ case ${ARCH} in
+ amd64)
+ mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
+ rm -r usr/lib || die
+ ;;
+ esac
+
+ rm usr/bin/${PN} || die
+
+ rm usr/share/doc/${PN}-stable/copyright || die
+ mv usr/share/doc/${PN}-stable usr/share/doc/${PF} || die
+ gunzip usr/share/doc/${PF}/changelog.gz || die
+
+ pushd "${OPERA_HOME}"/localization > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ sed -i \
+ -e 's|^TargetEnvironment|X-&|g' \
+ usr/share/applications/${PN}.desktop || die
+}
+
+src_install() {
+ rm "${OPERA_HOME}"/${PN}_autoupdate || die
+ mv * "${D}" || die
+ dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
+ fperms 4711 /"${OPERA_HOME}"/opera_sandbox
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}