summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-10 19:05:51 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-10 19:09:30 +0200
commit0887cc03be7e334a3f542c8074dca4d0c4fbfea7 (patch)
tree0a176c43e1f8bf293b53d6a1ae8b361c5a06b345 /www-client/otter
parentsys-libs/glibc: amd64 stable wrt bug #727758 (diff)
downloadgentoo-0887cc03be7e334a3f542c8074dca4d0c4fbfea7.tar.gz
gentoo-0887cc03be7e334a3f542c8074dca4d0c4fbfea7.tar.bz2
gentoo-0887cc03be7e334a3f542c8074dca4d0c4fbfea7.zip
www-client/otter: Drop support for dev-qt/qtwebkit
- Add upstream patch for qtgui 5.15.0 - Drop USE="webengine webkit" and use only dev-qt/qtwebengine - EAPI=7 - cmake-utils.eclass => cmake.eclass Package-Manager: Portage-3.0.2, Repoman-2.3.23 Closes: https://bugs.gentoo.org/649170 Closes: https://bugs.gentoo.org/show_bug.cgi?id=712172 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'www-client/otter')
-rw-r--r--www-client/otter/files/otter-1.0.01-qtgui-5.15.0.patch10
-rw-r--r--www-client/otter/files/otter-1.0.01-webengine.patch11
-rw-r--r--www-client/otter/otter-1.0.01-r1.ebuild85
-rw-r--r--www-client/otter/otter-9999.ebuild24
4 files changed, 124 insertions, 6 deletions
diff --git a/www-client/otter/files/otter-1.0.01-qtgui-5.15.0.patch b/www-client/otter/files/otter-1.0.01-qtgui-5.15.0.patch
new file mode 100644
index 000000000000..ec60a4b2c42b
--- /dev/null
+++ b/www-client/otter/files/otter-1.0.01-qtgui-5.15.0.patch
@@ -0,0 +1,10 @@
+--- a/src/modules/windows/web/StartPageWidget.cpp
++++ b/src/modules/windows/web/StartPageWidget.cpp
+@@ -41,6 +41,7 @@
+ #include <QtGui/QGuiApplication>
+ #include <QtGui/QMouseEvent>
+ #include <QtGui/QPainter>
++#include <QtGui/QPainterPath>
+ #include <QtGui/QPixmapCache>
+ #include <QtWidgets/QDesktopWidget>
+ #include <QtWidgets/QGridLayout>
diff --git a/www-client/otter/files/otter-1.0.01-webengine.patch b/www-client/otter/files/otter-1.0.01-webengine.patch
new file mode 100644
index 000000000000..f8029d95f26e
--- /dev/null
+++ b/www-client/otter/files/otter-1.0.01-webengine.patch
@@ -0,0 +1,11 @@
+--- a/src/core/SettingsManager.cpp
++++ b/src/core/SettingsManager.cpp
+@@ -73,7 +73,7 @@ void SettingsManager::createInstance(con
+ registerOption(AddressField_SuggestSearchOption, BooleanType, true);
+ registerOption(AddressField_SuggestSpecialPagesOption, BooleanType, true);
+ registerOption(Backends_PasswordsOption, EnumerationType, QLatin1String("file"), {QLatin1String("file")});
+- registerOption(Backends_WebOption, EnumerationType, QLatin1String("qtwebkit"), {QLatin1String("qtwebkit")}, (OptionDefinition::IsEnabledFlag | OptionDefinition::IsVisibleFlag | OptionDefinition::RequiresRestartFlag));
++ registerOption(Backends_WebOption, EnumerationType, QLatin1String("qtwebengine"), {QLatin1String("qtwebengine")}, (OptionDefinition::IsEnabledFlag | OptionDefinition::IsVisibleFlag | OptionDefinition::RequiresRestartFlag));
+ registerOption(Browser_AlwaysAskWhereToSaveDownloadOption, BooleanType, true);
+ registerOption(Browser_EnableMouseGesturesOption, BooleanType, true);
+ registerOption(Browser_EnableSingleKeyShortcutsOption, BooleanType, true);
diff --git a/www-client/otter/otter-1.0.01-r1.ebuild b/www-client/otter/otter-1.0.01-r1.ebuild
new file mode 100644
index 000000000000..2efa58e6f140
--- /dev/null
+++ b/www-client/otter/otter-1.0.01-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake desktop xdg-utils
+
+DESCRIPTION="Project aiming to recreate classic Opera (12.x) UI using Qt5"
+HOMEPAGE="https://otter-browser.org/"
+SRC_URI="https://github.com/OtterBrowser/${PN}-browser/archive/v${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="spell"
+
+DEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxmlpatterns:5
+ spell? ( kde-frameworks/sonnet )
+ >=dev-qt/qtwebengine-5.9:5[widgets]
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=( CHANGELOG CONTRIBUTING.md TODO )
+S=${WORKDIR}/${PN}-browser-${PV/_p/-dev}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.01-qtgui-5.15.0.patch
+ "${FILESDIR}"/${PN}-1.0.01-webengine.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ if [[ -n ${LINGUAS} ]]; then
+ local lingua
+ for lingua in resources/translations/*.qm; do
+ lingua=$(basename ${lingua})
+ lingua=${lingua/otter-browser_/}
+ lingua=${lingua/.qm/}
+ if ! has ${lingua} ${LINGUAS}; then
+ rm resources/translations/otter-browser_${lingua}.qm || die
+ fi
+ done
+ fi
+
+ if ! use spell; then
+ sed -i -e '/find_package(KF5Sonnet)/d' CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_QTWEBENGINE=true
+ -DENABLE_QTWEBKIT=false
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ domenu ${PN}-browser.desktop
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/www-client/otter/otter-9999.ebuild b/www-client/otter/otter-9999.ebuild
index dd20d3231ae6..7b5172796e7e 100644
--- a/www-client/otter/otter-9999.ebuild
+++ b/www-client/otter/otter-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils desktop git-r3 xdg-utils
+inherit cmake desktop git-r3 xdg-utils
DESCRIPTION="Project aiming to recreate classic Opera (12.x) UI using Qt5"
HOMEPAGE="https://otter-browser.org/"
-EGIT_REPO_URI="https://github.com/OtterBrowser/otter-browser"
+EGIT_REPO_URI="https://github.com/OtterBrowser/${PN}-browser"
LICENSE="GPL-3"
SLOT="0"
@@ -25,18 +25,21 @@ DEPEND="
dev-qt/qtscript:5
dev-qt/qtsql:5
dev-qt/qtsvg:5
- dev-qt/qtwebkit:5
dev-qt/qtwidgets:5
dev-qt/qtxmlpatterns:5
spell? ( kde-frameworks/sonnet )
+ >=dev-qt/qtwebengine-5.9:5[widgets]
"
RDEPEND="
${DEPEND}
"
DOCS=( CHANGELOG CONTRIBUTING.md TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.01-webengine.patch
+)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if [[ -n ${LINGUAS} ]]; then
local lingua
@@ -55,8 +58,17 @@ src_prepare() {
fi
}
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_QTWEBENGINE=true
+ -DENABLE_QTWEBKIT=false
+ )
+
+ cmake_src_configure
+}
+
src_install() {
- cmake-utils_src_install
+ cmake_src_install
domenu ${PN}-browser.desktop
}