summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2021-02-15 22:10:58 +0300
committerStefan Strogin <steils@gentoo.org>2021-02-15 19:11:48 +0000
commitb1b7ad638453d1db10e4bf4bb76d15c43fa3b791 (patch)
tree91fc8fc1f919b27833fa00d9995365522ff893ed /www-client/qutebrowser
parentpackage.mask: Masked net-misc/kea development versions (diff)
downloadgentoo-b1b7ad638453d1db10e4bf4bb76d15c43fa3b791.tar.gz
gentoo-b1b7ad638453d1db10e4bf4bb76d15c43fa3b791.tar.bz2
gentoo-b1b7ad638453d1db10e4bf4bb76d15c43fa3b791.zip
www-client/qutebrowser: upgrade to 2.0.2
Closes: https://bugs.gentoo.org/768717 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'www-client/qutebrowser')
-rw-r--r--www-client/qutebrowser/Manifest1
-rw-r--r--www-client/qutebrowser/qutebrowser-2.0.2.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/www-client/qutebrowser/Manifest b/www-client/qutebrowser/Manifest
index 57d3242a8695..45fcf1299ea7 100644
--- a/www-client/qutebrowser/Manifest
+++ b/www-client/qutebrowser/Manifest
@@ -1,2 +1,3 @@
DIST qutebrowser-1.14.0.tar.gz 4144761 BLAKE2B cc220990c119904c18932b7f240e428fd36baaf42a592f8fe15e9a1b1e5506cf82291ac0365fd43c75ffa78b403cbe35616f8bd5b362a686db389f5ab7a02345 SHA512 7330b685b5852c7700738bf1063121c6cb19b190143e4b98680563ae1a6ce7affaf9691db8c3a4e3686172be7da26ce841709dbc5d31a941326d7432c857cb25
DIST qutebrowser-1.14.1.tar.gz 4161759 BLAKE2B 5ea4d032cb8137af1ac9add9fe85b7dc0b8d9c78c838bd91b09444035f3e433d7cfd75672fbaafc1eceb2a0e1bac8f54b8419a7ff0d7c3b272d588818194a260 SHA512 2902b1f320c80601195f0a87b4cd1ce6dac7e79df82df692b08d00f1f0be449fcc7d7a855f4fc2cc5773f3b2142f508b0dfc6612778c416401f1117acc081de8
+DIST qutebrowser-2.0.2.tar.gz 6190348 BLAKE2B 0646f7879c049f3c754c98d6929f2851507804cc95fe117cafbac8477203799afd9af5c8e6b97fd48a09dffcc17f41982b035a0459737e289f02ab34eef63f7e SHA512 523eb6a46e88fc3bea724867d92042e86f75948a660159e4bf7c21b98737dd67e05fd62840d3de06c5562c8e8833a2178cfd9fd620b95b7521d695044e08f5bd
diff --git a/www-client/qutebrowser/qutebrowser-2.0.2.ebuild b/www-client/qutebrowser/qutebrowser-2.0.2.ebuild
new file mode 100644
index 000000000000..defe2baa7c46
--- /dev/null
+++ b/www-client/qutebrowser/qutebrowser-2.0.2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit desktop distutils-r1 optfeature xdg-utils
+
+DESCRIPTION="A keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
+HOMEPAGE="https://www.qutebrowser.org/ https://github.com/qutebrowser/qutebrowser"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="scripts test"
+
+BDEPEND="
+ app-text/asciidoc"
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_{7,8})
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},declarative,multimedia,gui,network,opengl,printsupport,sql,widgets]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP},libyaml]
+"
+
+distutils_enable_tests setup.py
+
+# Tests restricted as the deplist (misc/requirements/requirements-tests.txt)
+# isn't complete and X11 is required in order to start up qutebrowser.
+RESTRICT="test"
+
+python_compile_all() {
+ a2x -f manpage doc/${PN}.1.asciidoc || die "Failed generating man page"
+}
+
+python_install_all() {
+ doman doc/${PN}.1
+ domenu misc/org.${PN}.${PN}.desktop
+ doicon -s scalable icons/${PN}.svg
+
+ if use scripts; then
+ insinto /usr/share/qutebrowser/userscripts/
+ doins misc/userscripts/README.md
+ exeinto /usr/share/qutebrowser/userscripts/
+ doexe misc/userscripts/add-nextcloud-bookmarks \
+ misc/userscripts/add-nextcloud-cookbook \
+ misc/userscripts/cast \
+ misc/userscripts/dmenu_qutebrowser \
+ misc/userscripts/format_json \
+ misc/userscripts/getbib \
+ misc/userscripts/kodi \
+ misc/userscripts/open_download \
+ misc/userscripts/openfeeds \
+ misc/userscripts/password_fill \
+ misc/userscripts/qr \
+ misc/userscripts/qute-bitwarden \
+ misc/userscripts/qutedmenu \
+ misc/userscripts/qute-keepass \
+ misc/userscripts/qute-lastpass \
+ misc/userscripts/qute-pass \
+ misc/userscripts/readability \
+ misc/userscripts/readability-js \
+ misc/userscripts/ripbang \
+ misc/userscripts/rss \
+ misc/userscripts/taskadd \
+ misc/userscripts/tor_identity \
+ misc/userscripts/view_in_mpv
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "PDF display support" www-plugins/pdfjs
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}