summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-07-18 20:42:57 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-07-18 20:43:15 +0200
commite4aed962d8b2b13cca1109f0e899df83733f3623 (patch)
tree7413850dff279fd61acacf43001afe25e0073416 /www-client/seamonkey
parentmedia-gfx/jhead: sparc stable (bug #711220) (diff)
downloadgentoo-e4aed962d8b2b13cca1109f0e899df83733f3623.tar.gz
gentoo-e4aed962d8b2b13cca1109f0e899df83733f3623.tar.bz2
gentoo-e4aed962d8b2b13cca1109f0e899df83733f3623.zip
www-client/seamonkey: Fixed build with =dev-lang/rust-1.45.0
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'www-client/seamonkey')
-rw-r--r--www-client/seamonkey/files/seamonkey-2.53.3-rust-1.45.0.patch15
-rw-r--r--www-client/seamonkey/seamonkey-2.53.3.ebuild5
2 files changed, 20 insertions, 0 deletions
diff --git a/www-client/seamonkey/files/seamonkey-2.53.3-rust-1.45.0.patch b/www-client/seamonkey/files/seamonkey-2.53.3-rust-1.45.0.patch
new file mode 100644
index 000000000000..e2c6aa20161b
--- /dev/null
+++ b/www-client/seamonkey/files/seamonkey-2.53.3-rust-1.45.0.patch
@@ -0,0 +1,15 @@
+--- seamonkey-2.53.3/mozilla/config/rules.mk
++++ seamonkey-2.53.3/mozilla/config/rules.mk
+@@ -871,12 +871,6 @@
+ # These flags are passed via `cargo rustc` and only apply to the final rustc
+ # invocation (i.e., only the top-level crate, not its dependencies).
+ cargo_rustc_flags = $(CARGO_RUSTCFLAGS)
+-ifndef DEVELOPER_OPTIONS
+-ifndef MOZ_DEBUG_RUST
+-# Enable link-time optimization for release builds.
+-cargo_rustc_flags += -C lto
+-endif
+-endif
+
+ rustflags_override = RUSTFLAGS='$(MOZ_RUST_DEFAULT_FLAGS) $(RUSTFLAGS)'
+
diff --git a/www-client/seamonkey/seamonkey-2.53.3.ebuild b/www-client/seamonkey/seamonkey-2.53.3.ebuild
index 8d4b46d1b783..c81cbe49b6a7 100644
--- a/www-client/seamonkey/seamonkey-2.53.3.ebuild
+++ b/www-client/seamonkey/seamonkey-2.53.3.ebuild
@@ -189,6 +189,11 @@ src_prepare() {
edos2unix "${file}"
done
+ if has_version ">=virtual/rust-1.45.0" ; then
+ einfo "Unbreak build with >=rust-1.45.0, bmo#1640982 ..."
+ eapply "${FILESDIR}/${PN}-2.53.3-rust-1.45.0.patch"
+ fi
+
# Allow user to apply any additional patches without modifing ebuild
eapply_user