summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-10-17 00:12:45 -0400
committerMike Gilbert <floppym@gentoo.org>2016-10-17 00:12:45 -0400
commit1056f45c6d5733e899383b265df42f74af61e2c2 (patch)
tree34d66d5da4ff6254eb1b2410ccc23257cab7d08b /www-client
parentdev-libs/re2: add MULTILIB_USEDEP to icu dependency (diff)
downloadgentoo-1056f45c6d5733e899383b265df42f74af61e2c2.tar.gz
gentoo-1056f45c6d5733e899383b265df42f74af61e2c2.tar.bz2
gentoo-1056f45c6d5733e899383b265df42f74af61e2c2.zip
www-client/chromium: work around invalid LD in environment
Bug: https://bugs.gentoo.org/597218 Package-Manager: portage-2.3.2
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-54.0.2840.59.ebuild4
-rw-r--r--www-client/chromium/chromium-55.0.2873.0.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-54.0.2840.59.ebuild b/www-client/chromium/chromium-54.0.2840.59.ebuild
index 26e676cf5ac9..150f342b539a 100644
--- a/www-client/chromium/chromium-54.0.2840.59.ebuild
+++ b/www-client/chromium/chromium-54.0.2840.59.ebuild
@@ -537,6 +537,10 @@ src_configure() {
# Make sure the build system will use the right tools, bug #340795.
tc-export AR CC CXX NM
+ # Work around people setting LD in make.conf, bug 597218.
+ # gn's bootstrap.py looks at the environment first.
+ export LD=${CXX}
+
# Define a custom toolchain for GN
myconf_gn+=" custom_toolchain=\"${FILESDIR}/toolchain:default\""
diff --git a/www-client/chromium/chromium-55.0.2873.0.ebuild b/www-client/chromium/chromium-55.0.2873.0.ebuild
index 53bd9394457d..133ec4a2caa8 100644
--- a/www-client/chromium/chromium-55.0.2873.0.ebuild
+++ b/www-client/chromium/chromium-55.0.2873.0.ebuild
@@ -535,6 +535,10 @@ src_configure() {
# Make sure the build system will use the right tools, bug #340795.
tc-export AR CC CXX NM
+ # Work around people setting LD in make.conf, bug 597218.
+ # gn's bootstrap.py looks at the environment first.
+ export LD=${CXX}
+
# Define a custom toolchain for GN
myconf_gn+=" custom_toolchain=\"${FILESDIR}/toolchain:default\""