summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-10-17 11:34:49 -0400
committerMike Gilbert <floppym@gentoo.org>2016-10-17 11:35:36 -0400
commit11df69ff96e563593943e29479e84f2a6c8dcfc9 (patch)
treedf72e016e2a211f1ce993e36114a7dad7b72cb47 /www-client
parentjava-utils-2.eclass: Call eapply_user and drop java_prepare for EAPI 6 (diff)
downloadgentoo-11df69ff96e563593943e29479e84f2a6c8dcfc9.tar.gz
gentoo-11df69ff96e563593943e29479e84f2a6c8dcfc9.tar.bz2
gentoo-11df69ff96e563593943e29479e84f2a6c8dcfc9.zip
www-client/chromium: use cxx for linking when bootstrapping gn
Bug: https://bugs.gentoo.org/597218 Package-Manager: portage-2.3.2
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-54.0.2840.59.ebuild5
-rw-r--r--www-client/chromium/chromium-55.0.2873.0.ebuild5
-rw-r--r--www-client/chromium/files/chromium-gn-bootstrap-ld.patch29
3 files changed, 31 insertions, 8 deletions
diff --git a/www-client/chromium/chromium-54.0.2840.59.ebuild b/www-client/chromium/chromium-54.0.2840.59.ebuild
index 150f342b539a..80087d294456 100644
--- a/www-client/chromium/chromium-54.0.2840.59.ebuild
+++ b/www-client/chromium/chromium-54.0.2840.59.ebuild
@@ -165,6 +165,7 @@ PATCHES=(
"${FILESDIR}/${PN}-system-jinja-r13.patch"
"${FILESDIR}/${PN}-widevine-r1.patch"
"${FILESDIR}/chromium-54-ffmpeg2compat.patch"
+ "${FILESDIR}/${PN}-gn-bootstrap-ld.patch"
)
pkg_pretend() {
@@ -537,10 +538,6 @@ src_configure() {
# Make sure the build system will use the right tools, bug #340795.
tc-export AR CC CXX NM
- # Work around people setting LD in make.conf, bug 597218.
- # gn's bootstrap.py looks at the environment first.
- export LD=${CXX}
-
# Define a custom toolchain for GN
myconf_gn+=" custom_toolchain=\"${FILESDIR}/toolchain:default\""
diff --git a/www-client/chromium/chromium-55.0.2873.0.ebuild b/www-client/chromium/chromium-55.0.2873.0.ebuild
index 133ec4a2caa8..cc219080cb55 100644
--- a/www-client/chromium/chromium-55.0.2873.0.ebuild
+++ b/www-client/chromium/chromium-55.0.2873.0.ebuild
@@ -168,6 +168,7 @@ PATCHES=(
"${FILESDIR}/${PN}-54-ffmpeg2compat.patch"
"${FILESDIR}/${PN}-gn-r7.patch"
"${FILESDIR}/${PN}-system-zlib-r1.patch"
+ "${FILESDIR}/${PN}-gn-bootstrap-ld.patch"
)
pkg_pretend() {
@@ -535,10 +536,6 @@ src_configure() {
# Make sure the build system will use the right tools, bug #340795.
tc-export AR CC CXX NM
- # Work around people setting LD in make.conf, bug 597218.
- # gn's bootstrap.py looks at the environment first.
- export LD=${CXX}
-
# Define a custom toolchain for GN
myconf_gn+=" custom_toolchain=\"${FILESDIR}/toolchain:default\""
diff --git a/www-client/chromium/files/chromium-gn-bootstrap-ld.patch b/www-client/chromium/files/chromium-gn-bootstrap-ld.patch
new file mode 100644
index 000000000000..7916a7b05d84
--- /dev/null
+++ b/www-client/chromium/files/chromium-gn-bootstrap-ld.patch
@@ -0,0 +1,29 @@
+From 7f8c896c0e4d7e65b94a23e4e75fc6d1545c3cfd Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Mon, 17 Oct 2016 10:41:10 -0400
+Subject: [PATCH] gn: bootstrap: always use cxx for linking
+
+LD may be set to something like "ld.bfd" or "ld.gold". We want to let
+the compiler invoke the linker instead of calling these directly.
+
+Bug: https://bugs.gentoo.org/597218
+---
+ tools/gn/bootstrap/bootstrap.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/gn/bootstrap/bootstrap.py b/tools/gn/bootstrap/bootstrap.py
+index b86757a..d66da12 100755
+--- a/tools/gn/bootstrap/bootstrap.py
++++ b/tools/gn/bootstrap/bootstrap.py
+@@ -288,7 +288,7 @@ def write_gn_ninja(path, root_gen_dir, options):
+ else:
+ cc = os.environ.get('CC', 'cc')
+ cxx = os.environ.get('CXX', 'c++')
+- ld = os.environ.get('LD', cxx)
++ ld = cxx
+ ar = os.environ.get('AR', 'ar')
+
+ cflags = os.environ.get('CFLAGS', '').split()
+--
+2.10.1
+