summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-03-09 21:59:38 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-03-09 22:02:39 +0100
commit29a1852e1e8c5802ed2e31000321bbea313e4ac2 (patch)
tree86127e0a4156fbd10eee0a2bd7504061d2906f78 /www-client
parentsys-block/scsiadd: EAPI7 bump, minor improvements. (diff)
downloadgentoo-29a1852e1e8c5802ed2e31000321bbea313e4ac2.tar.gz
gentoo-29a1852e1e8c5802ed2e31000321bbea313e4ac2.tar.bz2
gentoo-29a1852e1e8c5802ed2e31000321bbea313e4ac2.zip
www-client/firefox: reorder LVM deps to start from best
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-60.5.2.ebuild2
-rw-r--r--www-client/firefox/firefox-65.0.2.ebuild42
2 files changed, 24 insertions, 20 deletions
diff --git a/www-client/firefox/firefox-60.5.2.ebuild b/www-client/firefox/firefox-60.5.2.ebuild
index a96c670e53ef..0b8b37bfe425 100644
--- a/www-client/firefox/firefox-60.5.2.ebuild
+++ b/www-client/firefox/firefox-60.5.2.ebuild
@@ -32,6 +32,8 @@ MOZ_HTTP_URI="https://archive.mozilla.org/pub/${PN}/releases"
MOZCONFIG_OPTIONAL_WIFI=1
+LLVM_MAX_SLOT=8
+
inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils llvm \
mozconfig-v6.60 pax-utils xdg-utils autotools mozlinguas-v2
diff --git a/www-client/firefox/firefox-65.0.2.ebuild b/www-client/firefox/firefox-65.0.2.ebuild
index df3ae98aab10..8c9f3333e124 100644
--- a/www-client/firefox/firefox-65.0.2.ebuild
+++ b/www-client/firefox/firefox-65.0.2.ebuild
@@ -30,6 +30,8 @@ fi
PATCH="${PN}-65.0-patches-04"
MOZ_HTTP_URI="https://archive.mozilla.org/pub/${PN}/releases"
+LLVM_MAX_SLOT=8
+
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
autotools mozlinguas-v2 virtualx
@@ -116,21 +118,21 @@ DEPEND="${CDEPEND}
sys-apps/findutils
|| (
(
- sys-devel/clang:4
- !clang? ( sys-devel/llvm:4 )
+ sys-devel/clang:8
+ !clang? ( sys-devel/llvm:8 )
clang? (
- =sys-devel/lld-4*
- sys-devel/llvm:4[gold]
- pgo? ( =sys-libs/compiler-rt-sanitizers-4*[profile] )
+ =sys-devel/lld-8*
+ sys-devel/llvm:8[gold]
+ pgo? ( =sys-libs/compiler-rt-sanitizers-8*[profile] )
)
)
(
- sys-devel/clang:5
- !clang? ( sys-devel/llvm:5 )
+ sys-devel/clang:7
+ !clang? ( sys-devel/llvm:7 )
clang? (
- =sys-devel/lld-5*
- sys-devel/llvm:5[gold]
- pgo? ( =sys-libs/compiler-rt-sanitizers-5*[profile] )
+ =sys-devel/lld-7*
+ sys-devel/llvm:7[gold]
+ pgo? ( =sys-libs/compiler-rt-sanitizers-7*[profile] )
)
)
(
@@ -143,21 +145,21 @@ DEPEND="${CDEPEND}
)
)
(
- sys-devel/clang:7
- !clang? ( sys-devel/llvm:7 )
+ sys-devel/clang:5
+ !clang? ( sys-devel/llvm:5 )
clang? (
- =sys-devel/lld-7*
- sys-devel/llvm:7[gold]
- pgo? ( =sys-libs/compiler-rt-sanitizers-7*[profile] )
+ =sys-devel/lld-5*
+ sys-devel/llvm:5[gold]
+ pgo? ( =sys-libs/compiler-rt-sanitizers-5*[profile] )
)
)
(
- sys-devel/clang:8
- !clang? ( sys-devel/llvm:8 )
+ sys-devel/clang:4
+ !clang? ( sys-devel/llvm:4 )
clang? (
- =sys-devel/lld-8*
- sys-devel/llvm:8[gold]
- pgo? ( =sys-libs/compiler-rt-sanitizers-8*[profile] )
+ =sys-devel/lld-4*
+ sys-devel/llvm:4[gold]
+ pgo? ( =sys-libs/compiler-rt-sanitizers-4*[profile] )
)
)
)