summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-08-20 11:14:05 -0400
committerMike Gilbert <floppym@gentoo.org>2016-08-20 11:14:05 -0400
commit2e061569e42df13ad574999d1f5a8f8ea09942e9 (patch)
tree2da267af49d769f40fc35808d82c832b678ff1b0 /www-client
parentwww-client/chromium: simplify gcc version check (diff)
downloadgentoo-2e061569e42df13ad574999d1f5a8f8ea09942e9.tar.gz
gentoo-2e061569e42df13ad574999d1f5a8f8ea09942e9.tar.bz2
gentoo-2e061569e42df13ad574999d1f5a8f8ea09942e9.zip
www-client/chromium: use a bash array for bundled libs
This looks much cleaner and is less error-prone since we do not need to escape line breaks.
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-54.0.2832.2.ebuild223
1 files changed, 111 insertions, 112 deletions
diff --git a/www-client/chromium/chromium-54.0.2832.2.ebuild b/www-client/chromium/chromium-54.0.2832.2.ebuild
index 9a46018043ff..d6fb0335f606 100644
--- a/www-client/chromium/chromium-54.0.2832.2.ebuild
+++ b/www-client/chromium/chromium-54.0.2832.2.ebuild
@@ -191,130 +191,129 @@ pkg_setup() {
src_prepare() {
default
- local conditional_bundled_libraries=""
+ local keeplibs=(
+ base/third_party/dmg_fp
+ base/third_party/dynamic_annotations
+ base/third_party/icu
+ base/third_party/nspr
+ base/third_party/superfasthash
+ base/third_party/symbolize
+ base/third_party/valgrind
+ base/third_party/xdg_mime
+ base/third_party/xdg_user_dirs
+ breakpad/src/third_party/curl
+ chrome/third_party/mozilla_security_manager
+ courgette/third_party
+ net/third_party/mozilla_security_manager
+ net/third_party/nss
+ third_party/WebKit
+ third_party/analytics
+ third_party/angle
+ third_party/angle/src/common/third_party/numerics
+ third_party/angle/src/third_party/compiler
+ third_party/angle/src/third_party/libXNVCtrl
+ third_party/angle/src/third_party/murmurhash
+ third_party/angle/src/third_party/trace_event
+ third_party/boringssl
+ third_party/brotli
+ third_party/cacheinvalidation
+ third_party/catapult
+ third_party/catapult/third_party/polymer
+ third_party/catapult/third_party/py_vulcanize
+ third_party/catapult/third_party/py_vulcanize/third_party/rcssmin
+ third_party/catapult/third_party/py_vulcanize/third_party/rjsmin
+ third_party/catapult/tracing/third_party/d3
+ third_party/catapult/tracing/third_party/gl-matrix
+ third_party/catapult/tracing/third_party/jszip
+ third_party/catapult/tracing/third_party/mannwhitneyu
+ third_party/ced
+ third_party/cld_2
+ third_party/cld_3
+ third_party/cros_system_api
+ third_party/cython/python_flags.py
+ third_party/devscripts
+ third_party/dom_distiller_js
+ third_party/fips181
+ third_party/flatbuffers
+ third_party/flot
+ third_party/google_input_tools
+ third_party/google_input_tools/third_party/closure_library
+ third_party/google_input_tools/third_party/closure_library/third_party/closure
+ third_party/hunspell
+ third_party/iccjpeg
+ third_party/icu
+ third_party/jstemplate
+ third_party/khronos
+ third_party/leveldatabase
+ third_party/libXNVCtrl
+ third_party/libaddressinput
+ third_party/libjingle
+ third_party/libjpeg_turbo
+ third_party/libphonenumber
+ third_party/libsecret
+ third_party/libsrtp
+ third_party/libudev
+ third_party/libusb
+ third_party/libwebm
+ third_party/libxml/chromium
+ third_party/libyuv
+ third_party/lss
+ third_party/lzma_sdk
+ third_party/mesa
+ third_party/modp_b64
+ third_party/mt19937ar
+ third_party/openh264
+ third_party/openmax_dl
+ third_party/opus
+ third_party/ots
+ third_party/pdfium
+ third_party/pdfium/third_party/agg23
+ third_party/pdfium/third_party/base
+ third_party/pdfium/third_party/bigint
+ third_party/pdfium/third_party/freetype
+ third_party/pdfium/third_party/lcms2-2.6
+ third_party/pdfium/third_party/libjpeg
+ third_party/pdfium/third_party/libopenjpeg20
+ third_party/pdfium/third_party/libpng16
+ third_party/pdfium/third_party/libtiff
+ third_party/pdfium/third_party/zlib_v128
+ third_party/polymer
+ third_party/protobuf
+ third_party/protobuf/third_party/six
+ third_party/qcms
+ third_party/re2
+ third_party/sfntly
+ third_party/skia
+ third_party/smhasher
+ third_party/sqlite
+ third_party/tcmalloc
+ third_party/usrsctp
+ third_party/web-animations-js
+ third_party/webdriver
+ third_party/webrtc
+ third_party/widevine
+ third_party/woff2
+ third_party/x86inc
+ third_party/zlib/google
+ url/third_party/mozilla
+ v8/src/third_party/valgrind
+ )
if ! use system-ffmpeg; then
- conditional_bundled_libraries+=" third_party/ffmpeg"
+ keeplibs+=( third_party/ffmpeg )
fi
if use gn; then
- conditional_bundled_libraries+="
+ keeplibs+=(
base/third_party/libevent
third_party/adobe
third_party/speech-dispatcher
third_party/usb_ids
third_party/xdg-utils
third_party/yasm/run_yasm.py
- "
+ )
fi
# Remove most bundled libraries. Some are still needed.
- build/linux/unbundle/remove_bundled_libraries.py \
- ${conditional_bundled_libraries} \
- 'base/third_party/dmg_fp' \
- 'base/third_party/dynamic_annotations' \
- 'base/third_party/icu' \
- 'base/third_party/nspr' \
- 'base/third_party/superfasthash' \
- 'base/third_party/symbolize' \
- 'base/third_party/valgrind' \
- 'base/third_party/xdg_mime' \
- 'base/third_party/xdg_user_dirs' \
- 'breakpad/src/third_party/curl' \
- 'chrome/third_party/mozilla_security_manager' \
- 'courgette/third_party' \
- 'net/third_party/mozilla_security_manager' \
- 'net/third_party/nss' \
- 'third_party/WebKit' \
- 'third_party/analytics' \
- 'third_party/angle' \
- 'third_party/angle/src/common/third_party/numerics' \
- 'third_party/angle/src/third_party/compiler' \
- 'third_party/angle/src/third_party/libXNVCtrl' \
- 'third_party/angle/src/third_party/murmurhash' \
- 'third_party/angle/src/third_party/trace_event' \
- 'third_party/boringssl' \
- 'third_party/brotli' \
- 'third_party/cacheinvalidation' \
- 'third_party/catapult' \
- 'third_party/catapult/third_party/polymer' \
- 'third_party/catapult/third_party/py_vulcanize' \
- 'third_party/catapult/third_party/py_vulcanize/third_party/rcssmin' \
- 'third_party/catapult/third_party/py_vulcanize/third_party/rjsmin' \
- 'third_party/catapult/tracing/third_party/d3' \
- 'third_party/catapult/tracing/third_party/gl-matrix' \
- 'third_party/catapult/tracing/third_party/jszip' \
- 'third_party/catapult/tracing/third_party/mannwhitneyu' \
- 'third_party/ced' \
- 'third_party/cld_2' \
- 'third_party/cld_3' \
- 'third_party/cros_system_api' \
- 'third_party/cython/python_flags.py' \
- 'third_party/devscripts' \
- 'third_party/dom_distiller_js' \
- 'third_party/fips181' \
- 'third_party/flatbuffers' \
- 'third_party/flot' \
- 'third_party/google_input_tools' \
- 'third_party/google_input_tools/third_party/closure_library' \
- 'third_party/google_input_tools/third_party/closure_library/third_party/closure' \
- 'third_party/hunspell' \
- 'third_party/iccjpeg' \
- 'third_party/icu' \
- 'third_party/jstemplate' \
- 'third_party/khronos' \
- 'third_party/leveldatabase' \
- 'third_party/libXNVCtrl' \
- 'third_party/libaddressinput' \
- 'third_party/libjingle' \
- 'third_party/libjpeg_turbo' \
- 'third_party/libphonenumber' \
- 'third_party/libsecret' \
- 'third_party/libsrtp' \
- 'third_party/libudev' \
- 'third_party/libusb' \
- 'third_party/libwebm' \
- 'third_party/libxml/chromium' \
- 'third_party/libyuv' \
- 'third_party/lss' \
- 'third_party/lzma_sdk' \
- 'third_party/mesa' \
- 'third_party/modp_b64' \
- 'third_party/mt19937ar' \
- 'third_party/openh264' \
- 'third_party/openmax_dl' \
- 'third_party/opus' \
- 'third_party/ots' \
- 'third_party/pdfium' \
- 'third_party/pdfium/third_party/agg23' \
- 'third_party/pdfium/third_party/base' \
- 'third_party/pdfium/third_party/bigint' \
- 'third_party/pdfium/third_party/freetype' \
- 'third_party/pdfium/third_party/lcms2-2.6' \
- 'third_party/pdfium/third_party/libjpeg' \
- 'third_party/pdfium/third_party/libopenjpeg20' \
- 'third_party/pdfium/third_party/libpng16' \
- 'third_party/pdfium/third_party/libtiff' \
- 'third_party/pdfium/third_party/zlib_v128' \
- 'third_party/polymer' \
- 'third_party/protobuf' \
- 'third_party/protobuf/third_party/six' \
- 'third_party/qcms' \
- 'third_party/re2' \
- 'third_party/sfntly' \
- 'third_party/skia' \
- 'third_party/smhasher' \
- 'third_party/sqlite' \
- 'third_party/tcmalloc' \
- 'third_party/usrsctp' \
- 'third_party/web-animations-js' \
- 'third_party/webdriver' \
- 'third_party/webrtc' \
- 'third_party/widevine' \
- 'third_party/woff2' \
- 'third_party/x86inc' \
- 'third_party/zlib/google' \
- 'url/third_party/mozilla' \
- 'v8/src/third_party/valgrind' \
- --do-remove || die
+ build/linux/unbundle/remove_bundled_libraries.py "${keeplibs[@]}" --do-remove || die
}
src_configure() {