summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-04 11:34:07 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-04 11:36:38 +0200
commit3c69586eee5fcb908bdf9def11c203313e283219 (patch)
tree5e092a672f60f34dc0abe71e27902b360e010a2c /www-client
parentmedia-gfx/shotwell: bump to 0.30.8 (diff)
downloadgentoo-3c69586eee5fcb908bdf9def11c203313e283219.tar.gz
gentoo-3c69586eee5fcb908bdf9def11c203313e283219.tar.bz2
gentoo-3c69586eee5fcb908bdf9def11c203313e283219.zip
www-client/epiphany: bump to 3.32.6
Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.32.6.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index dc9d0c389c8d..7faab68ab414 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
DIST epiphany-3.30.5.tar.xz 4532136 BLAKE2B 7c42e7ff5624bd85c380da97b2ca057b59d4dc77bec85f33bab755032b519db10ee52aa93c503e5b1f57c5acfce5a9b3decc7dddfacc3d68ea620eb884ec2da3 SHA512 1d31022e91a5ac79a032ebf988d4f8828cfa38a2b67e06b9432e479d7ebc93d3a08338261b92dfe3f37b6f745aeb5286b4acc65c537d935c1ace61ad9a494b7d
DIST epiphany-3.32.5.tar.xz 5468976 BLAKE2B 7e15eccbf48e7d2ada7b7a4ee4643219149f0d81c8c1767e5871fbed023bf53cd548822eabe5c9e0a26fd62a255ec69efdbd5efd05faef0e0374cedb473f5978 SHA512 e14a2626071460ddf8493a765d877f7683ba51e572778bb03f83ce31170856c6de91327955bd2d3b43e9016457da35a966014019d8837cd85765f948a7d1e5d2
+DIST epiphany-3.32.6.tar.xz 5469624 BLAKE2B 96e35001482c4062917d160d4b3e851ebf83850cc6d9d449e8c62c5d5c44d3fbab4ff0121c265ed363fa1e686d2ff9797a7dff8fe100a138aa72217fb8ba4183 SHA512 2d2fc57deb798c7666e2b7f9859318c1e9ae5477a79ccc3bb4f6de79edfc34c6096493306047ad2134a466da932e825d59881e896136ea7a0586fbd36177b0c4
diff --git a/www-client/epiphany/epiphany-3.32.6.ebuild b/www-client/epiphany/epiphany-3.32.6.ebuild
new file mode 100644
index 000000000000..19dbe29bb074
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.32.6.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.24.1:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ dev-libs/icu:=
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ >=dev-libs/libdazzle-3.31.90
+ >=gui-libs/libhandy-0.0.9:0.0=
+ >=x11-libs/libnotify-0.5.1
+ >=app-crypt/libsecret-0.14
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ dev-db/sqlite:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}