summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-04-25 21:51:57 +0000
committerSam James <sam@gentoo.org>2021-04-25 22:00:50 +0000
commit5d3abfa9559c11bd9ac3087a9bf3debd51cf0c30 (patch)
treeb7877442fdc36f36592f8b91568de5be7c250c04 /www-client
parentvirtual/w3m: port to EAPI 7 (diff)
downloadgentoo-5d3abfa9559c11bd9ac3087a9bf3debd51cf0c30.tar.gz
gentoo-5d3abfa9559c11bd9ac3087a9bf3debd51cf0c30.tar.bz2
gentoo-5d3abfa9559c11bd9ac3087a9bf3debd51cf0c30.zip
www-client/w3m: add 0.5.3_p20210102
Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/w3m/Manifest1
-rw-r--r--www-client/w3m/files/lang.patch32
-rw-r--r--www-client/w3m/w3m-0.5.3_p20210102.ebuild136
3 files changed, 169 insertions, 0 deletions
diff --git a/www-client/w3m/Manifest b/www-client/w3m/Manifest
index 8de29484f7db..0f12153d81dd 100644
--- a/www-client/w3m/Manifest
+++ b/www-client/w3m/Manifest
@@ -1,2 +1,3 @@
DIST w3m-0.5.3+git20180125.tar.gz 2181743 BLAKE2B d0766fa215be971ba280e4933ee9521ac4b7806f77ced5be4de58a5e28fa478e29a9102d101174f8d216cb982827b347c0fbcbfc494068d1cb8e443e73df7228 SHA512 61b8498b927569937c509460e291eeba6eb302d34ccd6e1bf4d1eb07ac73a3ac5a477161727d310324625be04b907f8c3e970382d08c9fa0846b371699f04e14
DIST w3m-0.5.3+git20190105.tar.gz 2183651 BLAKE2B 624fe3b8c1daa2a6d4ce21e051ee363a29114bdb64e0e0d9864b8098f2a12bcb27e293fa3dfa4dc1dff691fa40046f4878b7d39c321f591d3689d00e3ed42bad SHA512 b63b15d0bea82f50bcaa9fc0826c2d3c265a3ad73069b4a020812f28b552cdf08618ab877280c9f3a43bd64f51b80b7a526098e6395ea121c0981a3fcd2562b4
+DIST w3m-0.5.3+git20210102.tar.gz 2189272 BLAKE2B f82c13c26b1c83cda90655abdcf30422e257a5c2e48c32d5636a70f895078d11a95fc6ce623fa94624bb2a1125b71e7654d872dfb91fd86c4290278de3cf88f8 SHA512 357eeecf0f63bfd5174c9670533882323879657bdecefd0758d853ca645e368331bfdf91e99c0917f19829e184ce892ecdc99bd865851707d93baccfb4b97632
diff --git a/www-client/w3m/files/lang.patch b/www-client/w3m/files/lang.patch
new file mode 100644
index 000000000000..dccc35426900
--- /dev/null
+++ b/www-client/w3m/files/lang.patch
@@ -0,0 +1,32 @@
+new file mode 100644
+index 00000000..da1b2aef
+--- /dev/null
++++ b/m4/codeset.m4
+@@ -0,0 +1,25 @@
++# codeset.m4 serial 5 (gettext-0.18.2)
++dnl Copyright (C) 2000-2002, 2006, 2008-2014, 2016 Free Software Foundation,
++dnl Inc.
++dnl This file is free software; the Free Software Foundation
++dnl gives unlimited permission to copy and/or distribute it,
++dnl with or without modifications, as long as this notice is preserved.
++
++dnl From Bruno Haible.
++
++AC_DEFUN([AM_LANGINFO_CODESET],
++[
++ AC_CACHE_CHECK([for nl_langinfo and CODESET], [am_cv_langinfo_codeset],
++ [AC_LINK_IFELSE(
++ [AC_LANG_PROGRAM(
++ [[#include <langinfo.h>]],
++ [[char* cs = nl_langinfo(CODESET); return !cs;]])],
++ [am_cv_langinfo_codeset=yes],
++ [am_cv_langinfo_codeset=no])
++ ])
++ if test $am_cv_langinfo_codeset = yes; then
++ AC_DEFINE([HAVE_LANGINFO_CODESET], [1],
++ [Define if you have <langinfo.h> and nl_langinfo(CODESET).])
++ fi
++])
++
+--
+2.20.1
diff --git a/www-client/w3m/w3m-0.5.3_p20210102.ebuild b/www-client/w3m/w3m-0.5.3_p20210102.ebuild
new file mode 100644
index 000000000000..cb833a9cd2b5
--- /dev/null
+++ b/www-client/w3m/w3m-0.5.3_p20210102.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools prefix toolchain-funcs
+
+MY_P="${P/_p/+git}"
+MY_PV="${PV/_p/+git}"
+
+DESCRIPTION="Text based WWW browser, supports tables and frames"
+HOMEPAGE="https://github.com/tats/w3m"
+SRC_URI="https://github.com/tats/w3m/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="w3m"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="fbcon gdk-pixbuf gpm imlib l10n_de l10n_ja lynxkeymap nls nntp ssl unicode X xface"
+
+REQUIRED_USE="
+ fbcon? ( ?? ( gdk-pixbuf imlib ) )
+ X? ( ?? ( gdk-pixbuf imlib ) )
+"
+
+RDEPEND="
+ dev-libs/boehm-gc:=
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ gdk-pixbuf? (
+ x11-libs/gdk-pixbuf
+ X? ( x11-libs/gdk-pixbuf-xlib )
+ )
+ !gdk-pixbuf? (
+ imlib? ( media-libs/imlib2[X?] )
+ )
+ gpm? ( sys-libs/gpm )
+ ssl? ( dev-libs/openssl:0= )
+ X? (
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ )
+ xface? ( media-libs/compface )
+"
+
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/lang.patch" )
+
+S="${WORKDIR}/${P/_p/-git}"
+
+src_prepare() {
+ default
+ sed -i "/^AR=/s:ar:$(tc-getAR):" {.,${PN}img,libwc}/Makefile.in || die
+ hprefixify acinclude.m4
+
+ eautoconf
+}
+
+src_configure() {
+ local myconf=()
+ local image imagelib
+
+ if use gdk-pixbuf ; then
+ imagelib="gtk3"
+ elif use imlib ; then
+ imagelib="imlib2"
+ fi
+ if [[ -n "${imagelib}" ]] ; then
+ use X && image="${image}${image:+,}x11"
+ use fbcon && image="${image}${image:+,}fb"
+ fi
+ # emacs-w3m doesn't like "--enable-m17n --disable-unicode,"
+ # so we better enable or disable both. Default to enable
+ # m17n and unicode, see bug #47046.
+ if use l10n_ja ; then
+ myconf+=( --enable-japanese=$(usex unicode U E) )
+ else
+ myconf+=( --with-charset=$(usex unicode UTF-8 US-ASCII) )
+ fi
+ # lynxkeymap IUSE flag. bug #49397
+ myconf+=( --enable-keymap=$(usex lynxkeymap lynx ${PN}) )
+
+ econf \
+ $(use_enable gpm mouse) \
+ $(use_enable nls) \
+ $(use_enable nntp) \
+ $(use_enable ssl digest-auth) \
+ $(use_enable xface) \
+ $(use_with ssl) \
+ --enable-image=${image:-no} \
+ --enable-m17n \
+ --enable-unicode \
+ --with-browser="${EPREFIX}/usr/bin/xdg-open" \
+ --with-editor="${EPREFIX}/usr/bin/vi" \
+ --with-imagelib="${imagelib:-no}" \
+ --with-mailer="${EPREFIX}/bin/mail" \
+ --without-migemo \
+ --with-termlib=yes \
+ "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /etc/${PN}
+ newins "${FILESDIR}"/${PN}.mailcap mailcap
+
+ insinto /usr/share/${PN}/Bonus
+ doins Bonus/{*.{cgi,rb},html*,makeref}
+
+ docinto en
+ dodoc doc/{HISTORY,README,keymap,menu}*
+ newdoc Bonus/README.eng README.Bonus
+ docinto html/en
+ dodoc doc/*.html
+ if use l10n_de ; then
+ docinto de
+ dodoc doc-de/README*
+ docinto html/de
+ dodoc doc-de/*.html
+ else
+ rm -rf "${ED}"/usr/share/man/de || die
+ fi
+ if use l10n_ja ; then
+ docinto ja
+ dodoc doc-jp/{HISTORY,README,keymap,menu}*
+ newdoc Bonus/README README.Bonus
+ docinto html/ja
+ dodoc doc-jp/*.html
+ else
+ rm -rf "${ED}"/usr/share/man/ja || die
+ fi
+}