summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-11-02 11:46:26 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-11-02 11:50:41 -0500
commit5f6d70ba477a7e3d68dda817fd2f7698eac06a84 (patch)
treed0f6541ee865a17bd8b8f2a07df41077797622b3 /www-client
parentdev-util/lldb: Enable tests (need more upstream fixes though) (diff)
downloadgentoo-5f6d70ba477a7e3d68dda817fd2f7698eac06a84.tar.gz
gentoo-5f6d70ba477a7e3d68dda817fd2f7698eac06a84.tar.bz2
gentoo-5f6d70ba477a7e3d68dda817fd2f7698eac06a84.zip
www-client/pybugz: 0.13 version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'www-client')
-rw-r--r--www-client/pybugz/Manifest1
-rw-r--r--www-client/pybugz/pybugz-0.13.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/www-client/pybugz/Manifest b/www-client/pybugz/Manifest
index bac304256ed4..6843a6b01558 100644
--- a/www-client/pybugz/Manifest
+++ b/www-client/pybugz/Manifest
@@ -1 +1,2 @@
DIST pybugz-0.12.1.tar.gz 25606 SHA256 aade267d2ee6b02d6872e019ef4ddf8f96e1d81668faa2506e96875fa2981bc7 SHA512 bb76baf8105f4b56b106c3e63f5aebb322659141edf9c5e5af747db5824abffb7b127703ecb7111f9480d05bdb2f11b3fef2cd5f99078d9dda00e841b4ce7394 WHIRLPOOL 0b345efb5f6ce40e5c5910f576e544b2fc65c73beec3843fae21504455c23f3cd5aac41801a2eb733def50485455345e78e8c94287a1943747f608cc63a27e3d
+DIST pybugz-0.13.tar.gz 26876 SHA256 a99309d42b7ed2e52cc0f0f3adc72d1ddc9354e3d944af276f9a7da946665afb SHA512 2cbbd32b44d0d513e91e5c35dca5c68e34a963190c31f9139922f6b8ba69c7362063155b35833a00c2bd064f94d99367e2941a573aed4488f9a71a3b163d4b54 WHIRLPOOL 866b759b37e96be8a0d3e8004b760aaef2368de8319628791830caf84a3c87fe46bf464358e98b3ebcb37f027e9e4ec4843a70ab34c6bf8a121e88cad84f7877
diff --git a/www-client/pybugz/pybugz-0.13.ebuild b/www-client/pybugz/pybugz-0.13.ebuild
new file mode 100644
index 000000000000..ae71b896dbb6
--- /dev/null
+++ b/www-client/pybugz/pybugz-0.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_4 python3_5 )
+PYTHON_REQ_USE="readline(+)"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/williamh/pybugz.git
+ https://github.com/williamh/pybugz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+ inherit vcs-snapshot
+fi
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
+HOMEPAGE="https://github.com/williamh/pybugz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zsh-completion"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp contrib/bash-completion bugz
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _pybugz
+ fi
+}