summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-16 23:02:12 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-16 23:03:39 +0200
commit83c0a8f0637bd3be98c7a88a58dea53aa4920b39 (patch)
treec19124f27edcc79bf73a8315e08cbba3386444ef /www-client
parentdev-libs/libuv: Version 1.33.0 (diff)
downloadgentoo-83c0a8f0637bd3be98c7a88a58dea53aa4920b39.tar.gz
gentoo-83c0a8f0637bd3be98c7a88a58dea53aa4920b39.tar.bz2
gentoo-83c0a8f0637bd3be98c7a88a58dea53aa4920b39.zip
www-client/opera: Version 64.0.3417.61
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/opera/Manifest1
-rw-r--r--www-client/opera/opera-64.0.3417.61.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/www-client/opera/Manifest b/www-client/opera/Manifest
index 3d5e574ca165..ceede36fd849 100644
--- a/www-client/opera/Manifest
+++ b/www-client/opera/Manifest
@@ -1 +1,2 @@
DIST opera-stable_64.0.3417.54_amd64.deb 65791314 BLAKE2B 394b38a3ce7002124c5ca2bf1612f2ed019e1b275bbc04926603646029091954b217ac45cf0a9ca4b5ff98780fe3666ae18aed9cb9adea7531bf95c1cfb9338e SHA512 49f32c44b7877ccb0c3d306fe00a03d20f70d884df0bcd00a8468700d0420793aca50462427aad2bd948e3db1c91f20b97e49ee5e462f929e67d40b8000468f0
+DIST opera-stable_64.0.3417.61_amd64.deb 66139492 BLAKE2B bdb6c8d622418a11bea98149c502145b9d39425f044d81885cc03fee395ed6dfe756c4817cf68d84bd97fdc7f79eb99ff47a2fa8395036519961a1e4cb526517 SHA512 443862bbf74769d7242350e974bba298ab2a39d05a169dbf9e5dbf8f9e75da2b57fa5595d29499010b3a05ffd111f6753a598ae5c05c1a374935c484b969eb24
diff --git a/www-client/opera/opera-64.0.3417.61.ebuild b/www-client/opera/opera-64.0.3417.61.ebuild
new file mode 100644
index 000000000000..eec568e74cf4
--- /dev/null
+++ b/www-client/opera/opera-64.0.3417.61.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CHROMIUM_LANGS="
+ be bg bn ca cs da de el en-GB en-US es-419 es fil fi fr-CA fr hi hr hu id
+ it ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+ zh-CN zh-TW
+
+"
+inherit chromium-2 multilib unpacker xdg-utils
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2014"
+SLOT="0"
+SRC_URI_BASE="
+ https://download1.operacdn.com/pub/
+ https://download2.operacdn.com/pub/
+ https://download3.operacdn.com/pub/
+ https://download4.operacdn.com/pub/
+"
+for uri in ${SRC_URI_BASE}; do
+SRC_URI+="
+ "${uri}${PN}/desktop/${PV}/linux/${PN}-stable_${PV}_amd64.deb"
+"
+done
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gconf:2
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libnotify
+ x11-libs/pango[X]
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ default
+
+ OPERA_HOME="usr/$(get_libdir)/${PN}"
+
+ case ${ARCH} in
+ amd64)
+ mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
+ rm -r usr/lib || die
+ ;;
+ esac
+
+ rm usr/bin/${PN} || die
+
+ rm usr/share/doc/${PN}-stable/copyright || die
+ mv usr/share/doc/${PN}-stable usr/share/doc/${PF} || die
+ gunzip usr/share/doc/${PF}/changelog.gz || die
+
+ pushd "${OPERA_HOME}"/localization > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ sed -i \
+ -e 's|^TargetEnvironment|X-&|g' \
+ usr/share/applications/${PN}.desktop || die
+}
+
+src_install() {
+ rm "${OPERA_HOME}"/${PN}_autoupdate || die
+ mv * "${D}" || die
+ dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
+ fperms 4711 /"${OPERA_HOME}"/opera_sandbox
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}