summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-03-16 22:28:56 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-03-16 22:49:40 +0000
commit884bc14b983c2bfd58eef4c4a23c17a89a3f4f69 (patch)
tree39bc4c3db7695ac43d1d48d3c9cf17824f48a8dc /www-client
parentapp-office/libreoffice: Some patches have been picked for 6.2 (diff)
downloadgentoo-884bc14b983c2bfd58eef4c4a23c17a89a3f4f69.tar.gz
gentoo-884bc14b983c2bfd58eef4c4a23c17a89a3f4f69.tar.bz2
gentoo-884bc14b983c2bfd58eef4c4a23c17a89a3f4f69.zip
www-client/firefox: Add --host-root option to has_version LLVM checks
These LLVM-related dependencies are build-only so we need to check for them in / and not ROOT. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-60.5.2.ebuild4
-rw-r--r--www-client/firefox/firefox-65.0.2.ebuild6
-rw-r--r--www-client/firefox/firefox-66.0_rc3.ebuild6
3 files changed, 8 insertions, 8 deletions
diff --git a/www-client/firefox/firefox-60.5.2.ebuild b/www-client/firefox/firefox-60.5.2.ebuild
index 0b8b37bfe425..b2efd3d0d491 100644
--- a/www-client/firefox/firefox-60.5.2.ebuild
+++ b/www-client/firefox/firefox-60.5.2.ebuild
@@ -81,13 +81,13 @@ if [[ -z $GMP_PLUGIN_LIST ]]; then
fi
llvm_check_deps() {
- if ! has_version "sys-devel/clang:${LLVM_SLOT}" ; then
+ if ! has_version --host-root "sys-devel/clang:${LLVM_SLOT}" ; then
ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
return 1
fi
if use clang ; then
- if ! has_version "=sys-devel/lld-${LLVM_SLOT}*" ; then
+ if ! has_version --host-root "=sys-devel/lld-${LLVM_SLOT}*" ; then
ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
return 1
fi
diff --git a/www-client/firefox/firefox-65.0.2.ebuild b/www-client/firefox/firefox-65.0.2.ebuild
index b90c657c3a14..e376a6a307fa 100644
--- a/www-client/firefox/firefox-65.0.2.ebuild
+++ b/www-client/firefox/firefox-65.0.2.ebuild
@@ -170,19 +170,19 @@ if [[ -z $GMP_PLUGIN_LIST ]] ; then
fi
llvm_check_deps() {
- if ! has_version "sys-devel/clang:${LLVM_SLOT}" ; then
+ if ! has_version --host-root "sys-devel/clang:${LLVM_SLOT}" ; then
ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
return 1
fi
if use clang ; then
- if ! has_version "=sys-devel/lld-${LLVM_SLOT}*" ; then
+ if ! has_version --host-root "=sys-devel/lld-${LLVM_SLOT}*" ; then
ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
return 1
fi
if use pgo ; then
- if ! has_version "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*" ; then
+ if ! has_version --host-root "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*" ; then
ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
return 1
fi
diff --git a/www-client/firefox/firefox-66.0_rc3.ebuild b/www-client/firefox/firefox-66.0_rc3.ebuild
index 90a1f49e277e..17912ebc4e21 100644
--- a/www-client/firefox/firefox-66.0_rc3.ebuild
+++ b/www-client/firefox/firefox-66.0_rc3.ebuild
@@ -178,19 +178,19 @@ if [[ -z $GMP_PLUGIN_LIST ]] ; then
fi
llvm_check_deps() {
- if ! has_version "sys-devel/clang:${LLVM_SLOT}" ; then
+ if ! has_version --host-root "sys-devel/clang:${LLVM_SLOT}" ; then
ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
return 1
fi
if use clang ; then
- if ! has_version "=sys-devel/lld-${LLVM_SLOT}*" ; then
+ if ! has_version --host-root "=sys-devel/lld-${LLVM_SLOT}*" ; then
ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
return 1
fi
if use pgo ; then
- if ! has_version "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*" ; then
+ if ! has_version --host-root "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*" ; then
ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
return 1
fi