summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-26 11:48:36 +0000
committerSam James <sam@gentoo.org>2021-04-26 12:55:33 +0000
commita2b0043db4a6af646e549feb68b50c3dccff7708 (patch)
tree0aa75d3c014d0362952339b10eb0904534a53723 /www-client
parentmail-filter/amavisd-milter: Always return success in init script start_pre (diff)
downloadgentoo-a2b0043db4a6af646e549feb68b50c3dccff7708.tar.gz
gentoo-a2b0043db4a6af646e549feb68b50c3dccff7708.tar.bz2
gentoo-a2b0043db4a6af646e549feb68b50c3dccff7708.zip
www-client/w3m: fix gettext with eautoreconf
Thanks-to: David Seifert <soap@gentoo.org> Bug: https://bugs.gentoo.org/785760 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/w3m/files/w3m-0.5.3_p20210102-fix-configure-gettext.patch26
-rw-r--r--www-client/w3m/w3m-0.5.3_p20210102.ebuild6
2 files changed, 29 insertions, 3 deletions
diff --git a/www-client/w3m/files/w3m-0.5.3_p20210102-fix-configure-gettext.patch b/www-client/w3m/files/w3m-0.5.3_p20210102-fix-configure-gettext.patch
new file mode 100644
index 000000000000..4212b5aa4c98
--- /dev/null
+++ b/www-client/w3m/files/w3m-0.5.3_p20210102-fix-configure-gettext.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/785760
+https://savannah.gnu.org/bugs/?60201
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,6 +25,9 @@
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+ AC_PROG_RANLIB
++AC_PROG_MKDIR_P
++mkdir_p="${MKDIR_P}"
++AC_SUBST([mkdir_p])
+ AC_PATH_PROGS(PERL, perl, /usr/local/bin/perl)
+ AC_PATH_PROGS(NKF, nkf, /usr/local/bin/nkf)
+ AC_PATH_PROGS(MAN, man, /usr/bin/man)
+@@ -42,9 +45,8 @@
+ AC_DEFINE_UNQUOTED(W3M_TARGET, $W3M_TARGET)
+
+ AC_W3M_M17N
+-if test x$enable_messagel10n = xno; then
+- AM_GNU_GETTEXT([external])
+-fi
++AM_GNU_GETTEXT_REQUIRE_VERSION([0.18])
++AM_GNU_GETTEXT([external])
+
+ NLSTARGET=""
+ if test x"$USE_NLS" = xyes; then
diff --git a/www-client/w3m/w3m-0.5.3_p20210102.ebuild b/www-client/w3m/w3m-0.5.3_p20210102.ebuild
index 9a715d6d57c8..dfc11d716e27 100644
--- a/www-client/w3m/w3m-0.5.3_p20210102.ebuild
+++ b/www-client/w3m/w3m-0.5.3_p20210102.ebuild
@@ -42,14 +42,14 @@ RDEPEND="
)
xface? ( media-libs/compface )
"
-
+DEPEND="${RDEPEND}"
BDEPEND="
- ${RDEPEND}
virtual/pkgconfig
"
PATCHES=(
"${FILESDIR}"/${PN}-0.5.3_p20210102-restore-gettext-macro.patch
+ "${FILESDIR}"/${PN}-0.5.3_p20210102-fix-configure-gettext.patch
)
src_prepare() {
@@ -58,7 +58,7 @@ src_prepare() {
sed -i "/^AR=/s:ar:$(tc-getAR):" {.,${PN}img,libwc}/Makefile.in || die
hprefixify acinclude.m4
- AT_M4DIR="m4" eautoconf
+ AT_M4DIR="m4" eautoreconf
}
src_configure() {