summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-06 14:40:18 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-06 14:49:17 -0700
commita2f2db1bd978277b0c2b67321169ae886d748661 (patch)
treea52151606febf1e7125d04b9b2f8c4db8ec0df15 /www-client
parentsys-apps/osinfo-db: Version bump to 20210531 (diff)
downloadgentoo-a2f2db1bd978277b0c2b67321169ae886d748661.tar.gz
gentoo-a2f2db1bd978277b0c2b67321169ae886d748661.tar.bz2
gentoo-a2f2db1bd978277b0c2b67321169ae886d748661.zip
www-client/epiphany: Version bump to 40.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-40.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 2d355061f076..ee62b7d70a49 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1 +1,2 @@
DIST epiphany-40.1.tar.xz 5374236 BLAKE2B 71508de3554ef646061ab7ff62df8892fed0b7add112309d2660ed3795fee3e2e9460bbc80c7cec402e1922eafffcffae7845761a23b13f3245f5a688599e7ba SHA512 8598ae77f8ba446e132a82a256a346ef9b3c1f9b786d24f0fd4f891f75aba476197f3b155e1aa08ffd0b0a9357604b46bea6b9da34d138ff21bc41a46fa24c7f
+DIST epiphany-40.2.tar.xz 5372180 BLAKE2B cd75f645980c37b0cdd92133505cf7961168bf5d67ad0bdf3140f155c737a070f7ffafa63bb8a0e5de175826b79b2ca380a2851e7f1f0454d4f372d48f48c9c7 SHA512 29a5b7e65f7e5decb3c370fc9ae654727cce30f397ffd3289a9f77f3527f0471c821e3bea0f1a5ab9c1ab44e670898b46e66e41de5cb8c76fabd23b135a4a1a9
diff --git a/www-client/epiphany/epiphany-40.2.ebuild b/www-client/epiphany/epiphany-40.2.ebuild
new file mode 100644
index 000000000000..1f8745203fcf
--- /dev/null
+++ b/www-client/epiphany/epiphany-40.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.64.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.31.1:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ app-arch/libarchive:=
+ >=dev-libs/libdazzle-3.37.1
+ >=gui-libs/libhandy-1.1.0:1=
+ >=x11-libs/libnotify-0.5.1
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-db/sqlite-3.22:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Dlibportal=disabled
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}