summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2023-01-22 23:03:26 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-01-22 23:04:10 -0800
commitf0a36facc56573707efebc07c743e0ed7e8ddd44 (patch)
tree1975a25bdb1c286cff20b28d34dee6cd14fd0f88 /www-client
parentsys-process/parallel: add 20230122 (diff)
downloadgentoo-f0a36facc56573707efebc07c743e0ed7e8ddd44.tar.gz
gentoo-f0a36facc56573707efebc07c743e0ed7e8ddd44.tar.bz2
gentoo-f0a36facc56573707efebc07c743e0ed7e8ddd44.zip
www-client/firefox: fix 109 webrtc build on ppc64le
Bug: https://bugs.gentoo.org/891389 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/files/0030-bmo-1775202-ppc64-webrtc-missing-conditions-109.patch16
-rw-r--r--www-client/firefox/firefox-109.0.ebuild7
2 files changed, 23 insertions, 0 deletions
diff --git a/www-client/firefox/files/0030-bmo-1775202-ppc64-webrtc-missing-conditions-109.patch b/www-client/firefox/files/0030-bmo-1775202-ppc64-webrtc-missing-conditions-109.patch
new file mode 100644
index 000000000000..1203476cf3b4
--- /dev/null
+++ b/www-client/firefox/files/0030-bmo-1775202-ppc64-webrtc-missing-conditions-109.patch
@@ -0,0 +1,16 @@
+diff --git a/third_party/libwebrtc/moz.build b/third_party/libwebrtc/moz.build
+index 8579f8bb3622..d9ca79d4fcb8 100644
+--- a/third_party/libwebrtc/moz.build
++++ b/third_party/libwebrtc/moz.build
+@@ -520,7 +520,9 @@ if CONFIG["CPU_ARCH"] == "ppc64" and CONFIG["OS_TARGET"] == "Linux":
+ "/third_party/libwebrtc/api/audio_codecs/isac/audio_decoder_isac_float_gn",
+ "/third_party/libwebrtc/api/audio_codecs/isac/audio_encoder_isac_float_gn",
+ "/third_party/libwebrtc/modules/audio_coding/isac_c_gn",
+- "/third_party/libwebrtc/modules/audio_coding/isac_gn"
++ "/third_party/libwebrtc/modules/audio_coding/isac_gn",
++ "/third_party/libwebrtc/modules/desktop_capture/desktop_capture_gn",
++ "/third_party/libwebrtc/modules/desktop_capture/primitives_gn"
+ ]
+
+ if CONFIG["CPU_ARCH"] == "x86" and CONFIG["OS_TARGET"] == "Linux":
+
diff --git a/www-client/firefox/firefox-109.0.ebuild b/www-client/firefox/firefox-109.0.ebuild
index 62bacfdb5569..55a7abd6da29 100644
--- a/www-client/firefox/firefox-109.0.ebuild
+++ b/www-client/firefox/firefox-109.0.ebuild
@@ -612,6 +612,13 @@ src_unpack() {
src_prepare() {
use lto && rm -v "${WORKDIR}"/firefox-patches/*-LTO-Only-enable-LTO-*.patch
! use ppc64 && rm -v "${WORKDIR}"/firefox-patches/*bmo-1775202-ppc64*.patch
+
+ # workaround for https://bugs.gentoo.org/891389 until new patch gets into tarball
+ if use ppc64; then
+ rm -v "${WORKDIR}"/firefox-patches/0030-bmo-1775202-ppc64-webrtc-missing-conditions.patch
+ eapply "${FILESDIR}"/0030-bmo-1775202-ppc64-webrtc-missing-conditions-109.patch
+ fi
+
eapply "${WORKDIR}/firefox-patches"
# Allow user to apply any additional patches without modifing ebuild