summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-30 17:34:36 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-03-30 17:43:00 +0200
commitf17173196454c9e684737e3896fc4dad87fe7031 (patch)
tree0fb02a9bb72cce5dc6a9e929274fc55c34ee894e /www-client
parentapp-cdr/dumpet: add musl fix (diff)
downloadgentoo-f17173196454c9e684737e3896fc4dad87fe7031.tar.gz
gentoo-f17173196454c9e684737e3896fc4dad87fe7031.tar.bz2
gentoo-f17173196454c9e684737e3896fc4dad87fe7031.zip
www-client/firefox: don't install -x11 shortcut/.desktop file when not needed
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-68.6.0-r3.ebuild11
-rw-r--r--www-client/firefox/firefox-74.0-r2.ebuild11
2 files changed, 14 insertions, 8 deletions
diff --git a/www-client/firefox/firefox-68.6.0-r3.ebuild b/www-client/firefox/firefox-68.6.0-r3.ebuild
index 24ceeba5ece5..035e41b50ae7 100644
--- a/www-client/firefox/firefox-68.6.0-r3.ebuild
+++ b/www-client/firefox/firefox-68.6.0-r3.ebuild
@@ -762,11 +762,14 @@ PROFILE_EOF
newbin "${FILESDIR}"/firefox-wayland.sh firefox-wayland
;;
X11)
- exec_command='firefox-x11 --name firefox-x11'
- if use wayland ; then
- # Only needed when there's actually a choice
- newbin "${FILESDIR}"/firefox-x11.sh firefox-x11
+ if ! use wayland ; then
+ # Exit loop here because there's no choice so
+ # we don't need wrapper/.desktop file for X11.
+ continue
fi
+
+ exec_command='firefox-x11 --name firefox-x11'
+ newbin "${FILESDIR}"/firefox-x11.sh firefox-x11
;;
*)
app_name="${name}"
diff --git a/www-client/firefox/firefox-74.0-r2.ebuild b/www-client/firefox/firefox-74.0-r2.ebuild
index f6e5a2262fa6..2698ac6f81fa 100644
--- a/www-client/firefox/firefox-74.0-r2.ebuild
+++ b/www-client/firefox/firefox-74.0-r2.ebuild
@@ -781,11 +781,14 @@ PROFILE_EOF
newbin "${FILESDIR}"/firefox-wayland.sh firefox-wayland
;;
X11)
- exec_command='firefox-x11 --name firefox-x11'
- if use wayland ; then
- # Only needed when there's actually a choice
- newbin "${FILESDIR}"/firefox-x11.sh firefox-x11
+ if ! use wayland ; then
+ # Exit loop here because there's no choice so
+ # we don't need wrapper/.desktop file for X11.
+ continue
fi
+
+ exec_command='firefox-x11 --name firefox-x11'
+ newbin "${FILESDIR}"/firefox-x11.sh firefox-x11
;;
*)
app_name="${name}"