summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-01-11 22:59:27 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-01-12 15:05:47 +0100
commit548c27a3072459b77f9406e96decd214f3c46d94 (patch)
tree965ce7353484fd6429f87f486fa2e4017b548c69 /www-misc/profile-sync-daemon/profile-sync-daemon-6.31.ebuild
parentnet-p2p/retroshare: correct dependency on net-libs/libupnp (diff)
downloadgentoo-548c27a3072459b77f9406e96decd214f3c46d94.tar.gz
gentoo-548c27a3072459b77f9406e96decd214f3c46d94.tar.bz2
gentoo-548c27a3072459b77f9406e96decd214f3c46d94.zip
www-misc/profile-sync-daemon: version bump to 6.31.
Closes: https://github.com/gentoo/gentoo/pull/3436
Diffstat (limited to 'www-misc/profile-sync-daemon/profile-sync-daemon-6.31.ebuild')
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-6.31.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-6.31.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-6.31.ebuild
new file mode 100644
index 000000000000..9475ef996cab
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-6.31.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit versionator
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM."
+HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
+
+SRC_URI="https://github.com/graysky2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync[xattr]
+ sys-apps/systemd"
+
+pkg_postinst() {
+ local replacing
+ for replacing in ${REPLACING_VERSIONS}; do
+ if [[ "$(get_major_version ${replacing})" == "5" ]]; then
+ ewarn "${PN}-6 and later dropped OpenRC and /etc/psd.conf support"
+ ewarn "See https://github.com/graysky2/profile-sync-daemon#note-for-version-6"
+ break
+ fi
+ done
+}