summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-misc/profile-sync-daemon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-misc/profile-sync-daemon')
-rw-r--r--www-misc/profile-sync-daemon/Manifest1
-rw-r--r--www-misc/profile-sync-daemon/metadata.xml10
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild35
3 files changed, 46 insertions, 0 deletions
diff --git a/www-misc/profile-sync-daemon/Manifest b/www-misc/profile-sync-daemon/Manifest
new file mode 100644
index 000000000000..7aa277ca65a9
--- /dev/null
+++ b/www-misc/profile-sync-daemon/Manifest
@@ -0,0 +1 @@
+DIST profile-sync-daemon-5.45.1.tar.gz 25543 SHA256 da4e215f053ca3f2b4cfae3f83e8a8e8370ef328aa343eea1011719a3ca9ede8 SHA512 8a61ebfe52031bd59c70416adfd477edc313641cec93a4e96c80f316517cdb53f49840cfd7711ea2f6180ecce8e8e5d45f01d7bd85ba787c3fe288a14426b944 WHIRLPOOL 07a377c71557c4e285893a2b03513cedf99b5f2c4c7805de1c297393716873d32be2d003090c59fa2a260da64cf48611d910515ffcb907cfe9637614ddfc90bd
diff --git a/www-misc/profile-sync-daemon/metadata.xml b/www-misc/profile-sync-daemon/metadata.xml
new file mode 100644
index 000000000000..5182ce937a17
--- /dev/null
+++ b/www-misc/profile-sync-daemon/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">graysky2/profile-sync-daemon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild
new file mode 100644
index 000000000000..295f34a18211
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils vcs-snapshot
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
+SRC_URI="https://github.com/graysky2/profile-sync-daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="systemd"
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync
+ systemd? ( sys-apps/systemd )"
+
+src_install() {
+ emake -j1 DESTDIR="${ED}" \
+ install-openrc-all \
+ $(usex systemd "install-systemd" "")
+
+ fperms -x /etc/cron.hourly/psd-update
+}
+
+pkg_postinst() {
+ elog "The cronjob is -x by default."
+ elog "You might want to set it +x if you don't use"
+ elog "the systemd provided \"psd-resync.timer\"."
+}