summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2019-04-21 11:48:29 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-30 16:30:42 +0200
commitd74fea75f42233e9d63fcbea51b9b4786fa054da (patch)
tree064e414004c0259ac4d8661e47c49b2d07a46ae0 /www-plugins/passff
parentnet-dns/unbound: install unbound-event.h (diff)
downloadgentoo-d74fea75f42233e9d63fcbea51b9b4786fa054da.tar.gz
gentoo-d74fea75f42233e9d63fcbea51b9b4786fa054da.tar.bz2
gentoo-d74fea75f42233e9d63fcbea51b9b4786fa054da.zip
www-plugins/passff: Bump to 1.8
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-plugins/passff')
-rw-r--r--www-plugins/passff/Manifest1
-rw-r--r--www-plugins/passff/passff-1.8.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/www-plugins/passff/Manifest b/www-plugins/passff/Manifest
index e1dfb70e122f..28b0246c1d98 100644
--- a/www-plugins/passff/Manifest
+++ b/www-plugins/passff/Manifest
@@ -1 +1,2 @@
DIST passff-1.6.3-fx.xpi 66124 BLAKE2B 9638567e141f0bc68d754325df2bc97a45f918778bddf536ccf9b5701a7e805f0081f8cd1c4193cd750c079b7e00880872cecb71324fd7267fe39638f4c46a9a SHA512 83dffe2b2f1284d90c6e37b5e794e45cc8e2e59f782ee0cce37da4bf16a6349f645e5fb59516bf5a10ef6a9e77a775cd81e4e775fb45b8a8454c9db4c0b781b5
+DIST passff-1.8-fx.xpi 72678 BLAKE2B d5ec67fff396d62960fbf813ab9d8f6086028a282bab78aa4dc6e63132e723ce4b1bb6d05015d3934fabbd37460d04f7626043b97fd29c5c72486754ef14e111 SHA512 5500e7439d5eda3481eaa405abaef5b846f4f29b5fee4dffc49084b2ce658f9e13e4ced747a28d368892034921a556e3a989c1f8682365cdab787e41913c8250
diff --git a/www-plugins/passff/passff-1.8.ebuild b/www-plugins/passff/passff-1.8.ebuild
new file mode 100644
index 000000000000..8a9894c396e9
--- /dev/null
+++ b/www-plugins/passff/passff-1.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_XPINAME="${P}-fx"
+
+DESCRIPTION="zx2c4 pass manager extension for Firefox"
+HOMEPAGE="https://github.com/passff/passff"
+SRC_URI="https://addons.mozilla.org/firefox/downloads/file/2983533/${MY_XPINAME}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="www-plugins/passff-host[firefox]"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${MY_XPINAME}.xpi" . || die
+}
+
+src_install() {
+ # See https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/Distribution_options/Sideloading_add-ons#Installation_using_the_standard_extension_folders
+ insinto "/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/"
+ # passff@invicem.pro is the extension id found in the manifest.json
+ newins "${MY_XPINAME}.xpi" "passff@invicem.pro.xpi"
+}