summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2017-10-06 22:24:40 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-10-08 23:55:47 +0200
commitbe874f61abf4bdab529b32a090dbaf36aacf0798 (patch)
treeb463342c2180564e9072a1931b84ef6724f9c8ab /www-plugins/pdfjs/pdfjs-1.9.426.ebuild
parentmedia-libs/libraw: remove old (diff)
downloadgentoo-be874f61abf4bdab529b32a090dbaf36aacf0798.tar.gz
gentoo-be874f61abf4bdab529b32a090dbaf36aacf0798.tar.bz2
gentoo-be874f61abf4bdab529b32a090dbaf36aacf0798.zip
www-plugins/pdfjs: version bump to 1.9.426.
added missing app-arch/unzip DEPEND. Closes: https://bugs.gentoo.org/628018 Closes: https://bugs.gentoo.org/633610 Closes: https://github.com/gentoo/gentoo/pull/5874
Diffstat (limited to 'www-plugins/pdfjs/pdfjs-1.9.426.ebuild')
-rw-r--r--www-plugins/pdfjs/pdfjs-1.9.426.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/www-plugins/pdfjs/pdfjs-1.9.426.ebuild b/www-plugins/pdfjs/pdfjs-1.9.426.ebuild
new file mode 100644
index 000000000000..4c12535dad2d
--- /dev/null
+++ b/www-plugins/pdfjs/pdfjs-1.9.426.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A PDF reader in JavaScript"
+HOMEPAGE="http://mozilla.github.io/pdf.js/"
+SRC_URI="https://github.com/mozilla/pdf.js/releases/download/v${PV}/${P}-dist.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/pdf.js/
+
+ doins -r build
+ doins -r web
+}