summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-03-12 19:06:15 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2016-03-12 19:14:55 -0500
commit428f5168452714a44c3527354043ccd2f413f854 (patch)
treeae1a72cfc3298a80bd8e8014c5ea3cc781d3f37e /www-plugins/pipelight/pipelight-9999.ebuild
parentdev-vcs/hub: remove old (diff)
downloadgentoo-428f5168452714a44c3527354043ccd2f413f854.tar.gz
gentoo-428f5168452714a44c3527354043ccd2f413f854.tar.bz2
gentoo-428f5168452714a44c3527354043ccd2f413f854.zip
www-plugins/pipelight: Add 0.2.8.2; Add 64 bit support per #528404
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-plugins/pipelight/pipelight-9999.ebuild')
-rw-r--r--www-plugins/pipelight/pipelight-9999.ebuild34
1 files changed, 23 insertions, 11 deletions
diff --git a/www-plugins/pipelight/pipelight-9999.ebuild b/www-plugins/pipelight/pipelight-9999.ebuild
index 8f1557d50051..75380cf01222 100644
--- a/www-plugins/pipelight/pipelight-9999.ebuild
+++ b/www-plugins/pipelight/pipelight-9999.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit multilib
+inherit multilib-build
if [ ${PV} == "9999" ] ; then
- inherit git-2
+ inherit git-r3
EGIT_REPO_URI="https://bitbucket.org/mmueller2012/${PN}.git"
else
inherit vcs-snapshot
SRC_URI="https://bitbucket.org/mmueller2012/${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="Wine-based wrapper for running Windows plugins on POSIX systems"
@@ -20,19 +20,31 @@ HOMEPAGE="https://launchpad.net/pipelight"
LICENSE="|| ( GPL-2+ LGPL-2.1+ MPL-1.1 )"
SLOT="0"
-KEYWORDS=""
-IUSE=""
+IUSE="+abi_x86_32 abi_x86_64"
-DEPEND="app-emulation/wine[X,abi_x86_32,pipelight]"
+DEPEND="app-emulation/wine[X,${MULTILIB_USEDEP},pipelight]"
RDEPEND="${DEPEND}
app-arch/cabextract
- gnome-extra/zenity"
+ app-crypt/gnupg
+ media-fonts/corefonts
+ || (
+ gnome-extra/zenity
+ kde-apps/kdialog
+ )"
-QA_FLAGS_IGNORED="usr/share/pipelight/pluginloader.exe
- usr/share/pipelight/winecheck.exe"
+QA_FLAGS_IGNORED="usr/share/pipelight/pluginloader{,64}.exe
+ usr/share/pipelight/winecheck{,64}.exe"
src_configure() {
- econf --wine-path="${EPREFIX}/usr/bin/wine"
+ local myconf=( --wine-path="${EPREFIX}/usr/bin/wine" )
+ if use abi_x86_64; then
+ myconf+=(
+ --with-win64
+ --win64-cxx=wineg++
+ --wine64-path="${EPREFIX}/usr/bin/wine64"
+ )
+ fi
+ econf "${myconf[@]}"
}
src_install() {