summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-20 09:36:34 -0500
committerSebastian Pipping <sping@gentoo.org>2018-04-21 22:56:10 +0200
commit149e967321483b5d1934b897a9ac7c18f715b1fa (patch)
treef693eb2b447219afaeebd948f30729153c4f51c3 /www-servers/gatling
parentwww-client/httrack: epatch->PATCHES=() (diff)
downloadgentoo-149e967321483b5d1934b897a9ac7c18f715b1fa.tar.gz
gentoo-149e967321483b5d1934b897a9ac7c18f715b1fa.tar.bz2
gentoo-149e967321483b5d1934b897a9ac7c18f715b1fa.zip
www-servers/gatling: epatch->PATCHES=()
Also reworked the patch to be -p1. Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'www-servers/gatling')
-rw-r--r--www-servers/gatling/files/gatling-0.13-compile.patch4
-rw-r--r--www-servers/gatling/gatling-0.15.ebuild9
2 files changed, 8 insertions, 5 deletions
diff --git a/www-servers/gatling/files/gatling-0.13-compile.patch b/www-servers/gatling/files/gatling-0.13-compile.patch
index 7b4d44af9c09..a87a9541becb 100644
--- a/www-servers/gatling/files/gatling-0.13-compile.patch
+++ b/www-servers/gatling/files/gatling-0.13-compile.patch
@@ -1,5 +1,5 @@
---- GNUmakefile 2012-04-10 04:31:14.505474482 +0200
-+++ GNUmakefile 2012-04-10 04:31:53.821982958 +0200
+--- a/GNUmakefile
++++ b/GNUmakefile
@@ -64,7 +64,7 @@
acc: acc.c
$(CC) -o $@ $< $(CFLAGS) $(LDFLAGS) -lowfat
diff --git a/www-servers/gatling/gatling-0.15.ebuild b/www-servers/gatling/gatling-0.15.ebuild
index f2b75dd25464..b404cfd8a5c9 100644
--- a/www-servers/gatling/gatling-0.15.ebuild
+++ b/www-servers/gatling/gatling-0.15.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -23,10 +23,13 @@ DEPEND=">=dev-libs/libowfat-0.25[diet=]
)"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.13-compile.patch"
+)
+
src_prepare() {
+ default
rm Makefile # leaves us with GNUmakefile
- epatch "${FILESDIR}/${PN}-0.13-compile.patch"
- eapply_user
}
src_compile() {